summaryrefslogtreecommitdiff
path: root/games-action
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-19 08:46:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-19 08:46:18 +0100
commit9e65a38a260a44292ceb8a0bf4fea5f0b5666826 (patch)
tree40c907f5d72cda463e42d2ee5d5434b3790e06df /games-action
parentcf1a411e806b434c96329401a6ff0901ec7f0d5c (diff)
gentoo auto-resync : 19:04:2025 - 08:46:17edge
Diffstat (limited to 'games-action')
-rw-r--r--games-action/Manifest.gzbin14374 -> 14380 bytes
-rw-r--r--games-action/prismlauncher/Manifest2
-rw-r--r--games-action/prismlauncher/prismlauncher-9.4.ebuild117
3 files changed, 119 insertions, 0 deletions
diff --git a/games-action/Manifest.gz b/games-action/Manifest.gz
index c6f0c3a77ce1..63c1e2ced107 100644
--- a/games-action/Manifest.gz
+++ b/games-action/Manifest.gz
Binary files differ
diff --git a/games-action/prismlauncher/Manifest b/games-action/prismlauncher/Manifest
index aca34d3d5fdd..52f0c9b04db6 100644
--- a/games-action/prismlauncher/Manifest
+++ b/games-action/prismlauncher/Manifest
@@ -1,5 +1,7 @@
AUX prismlauncher-9.1-openjdk21.patch 1547 BLAKE2B 2f0354d9e7d700ba84095b72b4256c4f9d89810acd18f2c93531f13ca03d989f397d88607700e320cae4d0859c49b01c7cb19f2b977edc2d2335be784b55db44 SHA512 fbe65970549d4becae06ef1b1498e2dd7538403dc98fdf74777b9faa2aee27750299c39752fae82750332f7955bebb09be9108186969fce71b6bcc72b3f32be4
DIST prismlauncher-9.1.tar.gz 8460672 BLAKE2B 1bb31dab88d9ca4317e61b6938f9b5aeb0b76cab3407d69b62ecf9bfa1ade3308a8927f53e020b6531fbe0cce962c7e560727298a911f07b9fec1f51b1470cd9 SHA512 5a486bb0034464be873d80512ba164fab44eb60e3abda28771387f8bed471c5a323269a5f961a0950692915698b849bb4e7de7405c26e3ad29aa8732f140a66d
+DIST prismlauncher-9.4.tar.gz 8544189 BLAKE2B 57bb4391e8b84265e42b08545bb0cf64046915fca2a80a7f40923f6abf605d9bdd7efefae40694cb5118451346ed4cf8b9d77291b6ebc5b82ec1bb1fbafc16fc SHA512 7a81d6bd77da953ca92311f93ed753287b837ebdf51ae6898afa14769a0407eee55c17b6d9e09f4623f012375314b533c2a0bca2a16dedcce2e5327a5a1930a6
EBUILD prismlauncher-9.1-r1.ebuild 3560 BLAKE2B 8d4df02b8299d9c51c4c586fe7ec18f5faa4510f161aec94eaafa5c42d6c520409bbaff2fcaa5d587391081b9c5c124fd69b4da56ab943de58a58e36c978b3af SHA512 ccb5425fa3e653e6998db97b140728efef92fc9331f9e083e8bb5babe755f342c532c674762199d5e90fb2b8eaab50c53751e229a714e35ac126e3ea9f52697f
+EBUILD prismlauncher-9.4.ebuild 3561 BLAKE2B 15d429ea65be066aeaf751c1c6b38edfd066af1496b5edc7733767434be52d4f7d685842416a03b60d0119dc2328849209dc3b2b216bcd1095303af2e81f80ba SHA512 84110a780135d091bc4b38bfa678af31362bccb849d8345216b4b313a10ac66e180905e04a86a1520970d64766e99d4c02857c40d4dbe6bbf8d4aee605576f73
EBUILD prismlauncher-9999.ebuild 3561 BLAKE2B 24f6048d10dd2038ac6853931903c6bfa1bbee01a90fcacb6f2e0d017fffcda07ef609ff1cb1dc0005d326dd9bc4900ecb539d061307d344434a068a9bb1b2da SHA512 485c96ceee443256962f1d72d750cb0e4ecfdaa27114f2836f91ec0dfa15f1666c01816d78762ca51c4b82c6aa5a95036d62c6ab86951b3003e57b9039fb2557
MISC metadata.xml 918 BLAKE2B 53ec62a5f7c7e0c8bc4dcd91412ca0758f43cdde1e3a86462141fee856b2f29445e125d1c4ae3c78c603d11bb6e9d5186ea3ad574220ad95a7d2a277bef1c8d9 SHA512 57b3063d3b8feb6ebae17bc6125505bf2d33207a1fedeb98e39e49d06021f79f72c30b16dc70a7718192abc5127e7cb9903c5103d3d6ae67a24224dcd4825ba8
diff --git a/games-action/prismlauncher/prismlauncher-9.4.ebuild b/games-action/prismlauncher/prismlauncher-9.4.ebuild
new file mode 100644
index 000000000000..15e4cfcb7d53
--- /dev/null
+++ b/games-action/prismlauncher/prismlauncher-9.4.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QTMIN=6.0.0
+inherit cmake java-pkg-2 optfeature toolchain-funcs xdg
+
+DESCRIPTION="Custom, open source Minecraft launcher"
+HOMEPAGE="https://prismlauncher.org/ https://github.com/PrismLauncher/PrismLauncher"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PrismLauncher/PrismLauncher"
+ EGIT_SUBMODULES=(
+ '*' '-libraries/cmark' '-libraries/extra-cmake-modules' '-libraries/filesystem' '-libraries/quazip'
+ '-libraries/tomlplusplus' '-libraries/zlib'
+ )
+else
+ MY_PN="PrismLauncher"
+ # use vendored tarball to avoid dealing with submodules directly
+ SRC_URI="
+ https://github.com/PrismLauncher/PrismLauncher/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
+ "
+ S="${WORKDIR}/${MY_PN}-${PV}"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+# GPL-3 for PolyMC (PrismLauncher is forked from it) and Prism itself
+# Apache-2.0 for MultiMC (PolyMC is forked from it)
+# LGPL-3+ for libnbtplusplus
+# rest of its libs: https://github.com/PrismLauncher/PrismLauncher/tree/develop/libraries
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2+ GPL-3 ISC LGPL-2.1+ LGPL-3+"
+SLOT="0"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+# Required at both build time and runtime
+COMMON_DEPEND="
+ app-text/cmark:=
+ dev-cpp/tomlplusplus
+ >=dev-libs/quazip-1.3-r2:=[qt6(+)]
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent,gui,network,widgets,xml(+)]
+ >=dev-qt/qt5compat-${QTMIN}:6
+ >=dev-qt/qtnetworkauth-${QTMIN}:6
+ sys-libs/zlib
+"
+# gulrak-filesystem dependency is only needed at build time, because we don't
+# actually use it on Linux, only on legacy macOS. Still, we need it present at
+# build time to appease CMake, and having it like this makes it easier to
+# maintain than patching the CMakeLists file directly.
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/gulrak-filesystem
+ media-libs/libglvnd
+ >=virtual/jdk-1.8.0:*
+"
+# QtSvg imageplugin needed at runtime for svg icons, via QIcon.
+# At runtime we don't depend on JDK, only JRE
+# And we need more than just the GL headers
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtsvg-${QTMIN}:6
+ >=virtual/jre-1.8.0:*
+ virtual/opengl
+"
+BDEPEND="
+ app-text/scdoc
+ >=kde-frameworks/extra-cmake-modules-6.0.0:*
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ local java="$(java-config -f)"
+ local java_version=${java//[^0-9]/}
+ if [[ ${java_version} -ge 20 ]]; then
+ elog "Java 20 and up has dropped binary compatibility with java 7."
+ elog "${PN} is being compiled with java ${java_version}."
+ elog "The sources will be patched to build binary compatible with"
+ elog "java 8 instead of java 7. This may cause issues with very old"
+ elog "Minecraft versions and/or older forge versions."
+ elog
+ elog "If you experience any problems, install an older java compiler"
+ elog "and select it with \"eselect java\", then recompile ${PN}."
+ eapply "${FILESDIR}/${PN}-9.1-openjdk21.patch"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ # Resulting binary is named prismlauncher
+ -DLauncher_APP_BINARY_NAME="${PN}"
+ -DLauncher_BUILD_PLATFORM="Gentoo"
+ -DLauncher_QT_VERSION_MAJOR=6
+
+ -DENABLE_LTO=$(tc-is-lto)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Original issue: https://github.com/PolyMC/PolyMC/issues/227
+ optfeature "old Minecraft (<= 1.12.2) support" x11-apps/xrandr
+
+ optfeature "built-in MangoHud support" games-util/mangohud
+ optfeature "built-in Feral Gamemode support" games-util/gamemode
+}