summaryrefslogtreecommitdiff
path: root/games-action/xpilot/xpilot-4.5.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/xpilot/xpilot-4.5.5-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/xpilot/xpilot-4.5.5-r1.ebuild')
-rw-r--r--games-action/xpilot/xpilot-4.5.5-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/games-action/xpilot/xpilot-4.5.5-r1.ebuild b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
new file mode 100644
index 000000000000..ecc92dce8706
--- /dev/null
+++ b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A multi-player 2D client/server space game"
+HOMEPAGE="http://www.xpilot.org/"
+SRC_URI="mirror://sourceforge/xpilotgame/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-base/xorg-proto
+ x11-misc/gccmakedep
+ x11-misc/imake"
+
+src_prepare() {
+ #default
+ eapply_user
+
+ sed -i \
+ -e '/^INSTMAN/s:=.*:=/usr/share/man/man6:' \
+ -e "/^INSTLIB/s:=.*:=/usr/share/${PN}:" \
+ -e "/^INSTBIN/s:=.*:=/usr/bin:" \
+ Local.config || die
+
+ # work with glibc-2.20
+ sed -i \
+ -e 's/getline/lgetline/' \
+ src/client/textinterface.c || die
+}
+
+src_compile() {
+ xmkmf || die
+ emake Makefiles
+ emake includes
+ emake depend
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" install.man
+ newicon lib/textures/logo.ppm ${PN}.ppm
+ make_desktop_entry ${PN} XPilot /usr/share/pixmaps/${PN}.ppm
+ dodoc README.txt doc/{ChangeLog,CREDITS,FAQ,README*,TODO}
+}