summaryrefslogtreecommitdiff
path: root/games-action/xpilot/xpilot-4.5.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-action/xpilot/xpilot-4.5.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-action/xpilot/xpilot-4.5.5-r1.ebuild')
-rw-r--r--games-action/xpilot/xpilot-4.5.5-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-action/xpilot/xpilot-4.5.5-r1.ebuild b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
new file mode 100644
index 000000000000..cfd0162fb1aa
--- /dev/null
+++ b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A multi-player 2D client/server space game"
+HOMEPAGE="http://www.xpilot.org/"
+SRC_URI="mirror://sourceforge/xpilotgame/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/gccmakedep
+ x11-misc/imake
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_prepare() {
+ #default
+ eapply_user
+
+ sed -i \
+ -e '/^INSTMAN/s:=.*:=/usr/share/man/man6:' \
+ -e "/^INSTLIB/s:=.*:=/usr/share/${PN}:" \
+ -e "/^INSTBIN/s:=.*:=/usr/bin:" \
+ Local.config || die
+
+ # work with glibc-2.20
+ sed -i \
+ -e 's/getline/lgetline/' \
+ src/client/textinterface.c || die
+}
+
+src_compile() {
+ xmkmf || die
+ emake Makefiles
+ emake includes
+ emake depend
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" install.man
+ newicon lib/textures/logo.ppm ${PN}.ppm
+ make_desktop_entry ${PN} XPilot /usr/share/pixmaps/${PN}.ppm
+ dodoc README.txt doc/{ChangeLog,CREDITS,FAQ,README*,TODO}
+}