summaryrefslogtreecommitdiff
path: root/games-action/xbomber/xbomber-101-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-action/xbomber/xbomber-101-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-action/xbomber/xbomber-101-r1.ebuild')
-rw-r--r--games-action/xbomber/xbomber-101-r1.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/games-action/xbomber/xbomber-101-r1.ebuild b/games-action/xbomber/xbomber-101-r1.ebuild
index 2757b322f5db..c6c7c8ab4069 100644
--- a/games-action/xbomber/xbomber-101-r1.ebuild
+++ b/games-action/xbomber/xbomber-101-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Bomberman clone w/multiplayer support"
HOMEPAGE="http://www.xdr.com/dash/bomber.html"
@@ -10,7 +12,6 @@ SRC_URI="http://www.xdr.com/dash/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="x11-libs/libX11"
RDEPEND="!sci-biology/emboss
@@ -39,9 +40,17 @@ src_prepare() {
-e "s:=\"data\":=\"/usr/share/${PN}\":" sound.c || die
}
+src_compile() {
+ tc-export CC
+
+ emake
+}
+
src_install() {
dobin matcher bomber
+
insinto /usr/share/${PN}
doins -r data/*
+
dodoc README Changelog
}