summaryrefslogtreecommitdiff
path: root/games-action/xblast/xblast-2.10.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /games-action/xblast/xblast-2.10.4-r2.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'games-action/xblast/xblast-2.10.4-r2.ebuild')
-rw-r--r--games-action/xblast/xblast-2.10.4-r2.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/games-action/xblast/xblast-2.10.4-r2.ebuild b/games-action/xblast/xblast-2.10.4-r2.ebuild
new file mode 100644
index 000000000000..0f7e212495eb
--- /dev/null
+++ b/games-action/xblast/xblast-2.10.4-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+MY_GAMEDATA=(
+ images-2005-01-06:image
+ levels-2005-01-06:level
+ models-2005-01-06:image/sprite
+ musics-2005-01-06:sounds
+ sounds
+)
+
+DESCRIPTION="Bomberman clone with network support for up to 6 players"
+HOMEPAGE="http://xblast.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/xblast/${P}.tar.gz
+ $(printf 'mirror://sourceforge/xblast/%s.tar.gz ' "${MY_GAMEDATA[@]%:*}")"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ media-fonts/font-adobe-100dpi"
+DEPEND="
+ x11-base/xorg-proto
+ x11-libs/libX11
+ x11-libs/libXt"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-10.patch
+)
+
+src_prepare() {
+ default
+
+ find "${WORKDIR}" -name Imakefile -exec rm {} + || die
+
+ # badly non-utf8 named file that doesn't match xblast.wxs runtime #750077
+ mv "${WORKDIR}"/levels-2005-01-06/reconstruct{?,i}on2.xal || die
+
+ eautoreconf #255857
+}
+
+src_configure() {
+ econf \
+ --enable-sound \
+ --with-otherdatadir="${EPREFIX}"/usr/share/${PN}
+}
+
+src_install() {
+ default
+
+ local data
+ for data in "${MY_GAMEDATA[@]}"; do
+ insinto /usr/share/${PN}/${data#*:}
+ doins -r "${WORKDIR}"/${data%:*}/.
+ done
+
+ make_desktop_entry ${PN} XBlast applications-games
+}