summaryrefslogtreecommitdiff
path: root/games-action/trosh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/trosh
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/trosh')
-rw-r--r--games-action/trosh/Manifest4
-rw-r--r--games-action/trosh/metadata.xml8
-rw-r--r--games-action/trosh/trosh-20-r1.ebuild47
3 files changed, 59 insertions, 0 deletions
diff --git a/games-action/trosh/Manifest b/games-action/trosh/Manifest
new file mode 100644
index 000000000000..3fa4440520cf
--- /dev/null
+++ b/games-action/trosh/Manifest
@@ -0,0 +1,4 @@
+DIST trosh-20.zip 5182303 BLAKE2B b22d0e5138c5d5ce3bbbe8e3fe8cdc732b9002d67ceccf636b93c6c48acc8a32898de978ccb752742a3be0e8e1bdee97507a469d87d30af8a493ad4104fc657c SHA512 2a8988f5715340850a61acde54403c968947d41d5f0a1ac098c4cc3959f69f150cee567933fd5148a2c23c237210c10dc58005de1bd949d6db59cd794a0003ec
+DIST trosh.png 242 BLAKE2B 3f9a2fcd08669004f40f5ade1c4f119d18b1983b2d0ff73fb61fdd9764aa9903c5b053267507ec5cc3f4a8dd5d2246df6830b96fbfaa3f536fd7cad458f09436 SHA512 85ff46c8c75b018a59a8e7dace85fc5ccf2439babedb0e4d134301eb9f7edfe5d7f4f3af1329f04257c16d978f27df38f10cb3ffbc4b424808a5f3c5c78bfc69
+EBUILD trosh-20-r1.ebuild 894 BLAKE2B 8ab22d1c6d681307a9526359c1bc7dfed3fc5a8021682c805f578ac6d2d6f1ff2309f8c03ba75554adea7b96732c67b5f88f0e46dbf06def50c6d0b87e133f5b SHA512 40a2075d54ac3b6e334c8e8e4562637c3bfb3e3cef5b071dd691341ad56f818146c77877b0e0654e91fd66b4d49f6b06f4f71ca3e671ebf93c29bbbf1e8158f9
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-action/trosh/metadata.xml b/games-action/trosh/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-action/trosh/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-action/trosh/trosh-20-r1.ebuild b/games-action/trosh/trosh-20-r1.ebuild
new file mode 100644
index 000000000000..5de7abfdbbc1
--- /dev/null
+++ b/games-action/trosh/trosh-20-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils gnome2-utils
+
+DESCRIPTION="A game made in 20 hours for a friend. It has explosions"
+HOMEPAGE="http://stabyourself.net/trosh/"
+SRC_URI="http://stabyourself.net/dl.php?file=trosh/trosh-linux.zip -> ${P}.zip
+ https://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=games-engines/love-0.8.0:0
+ media-libs/devil[png]
+"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ local dir=/usr/share/love/${PN}
+
+ exeinto "${dir}"
+ doexe ${PN}.love
+
+ einstalldocs
+
+ doicon -s 32 "${DISTDIR}"/${PN}.png
+ make_wrapper ${PN} "love ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}