summaryrefslogtreecommitdiff
path: root/games-action/trine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
commit6bd95d1f6320b8666a31ec949183aaa3088aa16f (patch)
treeff9f0cde8bfba5191f96c690c269c814c134a51e /games-action/trine
parentb279bbe94522565b8feb19b8e5f377d3ea76f157 (diff)
gentoo resync : 25.03.2018
Diffstat (limited to 'games-action/trine')
-rw-r--r--games-action/trine/Manifest3
-rw-r--r--games-action/trine/metadata.xml11
-rw-r--r--games-action/trine/trine-1.08-r3.ebuild97
3 files changed, 111 insertions, 0 deletions
diff --git a/games-action/trine/Manifest b/games-action/trine/Manifest
new file mode 100644
index 000000000000..7db21e5d4541
--- /dev/null
+++ b/games-action/trine/Manifest
@@ -0,0 +1,3 @@
+DIST TrineUpdate4.64.run 647258173 BLAKE2B b520d1f312b9bd9ef94f32cd5fbe7ceaea0cb1bd839d8a898ac02cac0eb3464d83588f1163949ca2f53d7badb2eca456b8e1438d6f5e96e3c6baa10ca6cb865a SHA512 1255edc90cfd47c4f5a3cf7fa07cebac047f46f9b5f9f6621baff01d9c4295c95204a695127ce4947038c50c80253e7a004ec1c3accff6ac8697605fd25885f9
+EBUILD trine-1.08-r3.ebuild 2401 BLAKE2B c81708cf345a2a67e7ef0e0edc570bcb95946145dc78408aa2d03d5f365efc269df9c8a69c40d97037853f6efa860ba9a6bf0cd2cffe2adb65a592cf6459e715 SHA512 cebbd8d3a103cf6fa5e363b2f504a45b20f2dd3dbf071071fd3b003a45aba2f2f955f16e32d679a8406504eb46f37fbcd85cf06c99bad9d9a2de0eda82f89525
+MISC metadata.xml 321 BLAKE2B 5aca052a154cd0d9a43b96774253a2999ad36aa01c956961ad0021fa7cc6cbc8b89b7f93c6318308f6310a877ac9cb2b70bf622f25b882cf0c13261a7fae9b9c SHA512 ab5d27c4f1f5760f902abe8829db8732a19206739001dd349ac170bc64e5edb9b10ec4d16ec3d8f52569a05bc90ac08af6724f11206fce2b3506d99555712747
diff --git a/games-action/trine/metadata.xml b/games-action/trine/metadata.xml
new file mode 100644
index 000000000000..b26a6baa4124
--- /dev/null
+++ b/games-action/trine/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="launcher">Install GTK+ launcher</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-action/trine/trine-1.08-r3.ebuild b/games-action/trine/trine-1.08-r3.ebuild
new file mode 100644
index 000000000000..f9b9673cdd45
--- /dev/null
+++ b/games-action/trine/trine-1.08-r3.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop eutils gnome2-utils unpacker
+
+DESCRIPTION="A physics-based action game with character-dependent solutions to challenges"
+HOMEPAGE="https://www.frozenbyte.com/games/trine-enchanted-edition"
+SRC_URI="TrineUpdate4.64.run"
+LICENSE="frozenbyte-eula"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+launcher"
+RESTRICT="bindist fetch strip"
+
+QA_PREBUILT="opt/${PN}/${PN}*
+ opt/${PN}/lib/*"
+
+DEPEND="
+ app-admin/chrpath
+ app-arch/unzip
+"
+
+RDEPEND="
+ media-gfx/nvidia-cg-toolkit
+ >=media-libs/libsdl-1.2[opengl,video]
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-ttf-2.0
+ >=media-libs/libvorbis-1.3
+ >=media-libs/openal-1.15
+ >=sys-devel/gcc-4.3.0
+ >=sys-libs/glibc-2.4
+ sys-libs/zlib
+ x11-libs/gtk+:2
+ launcher? (
+ dev-libs/glib:2
+ gnome-base/libglade:2.0
+ )"
+
+S="${WORKDIR}"
+dir="/opt/${PN}"
+
+pkg_nofetch() {
+ einfo "Fetch ${SRC_URI} and put it into your distfiles directory."
+ einfo "It is no longer available to purchase but you can still download it"
+ einfo "from https://www.humblebundle.com if you bought it previously."
+ einfo "Otherwise install ${CATEGORY}/trine-enchanted-edition instead."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ default
+ use launcher || rm -v lib*/lib{boost*,icu*}.* || die
+ rm -v lib*/lib{Cg*,direct*,fusion*,gcc_s,jpeg,m,ogg,openal,png*,rt,SDL*,selinux,stdc++,tiff,vga,vorbis*}.* || die
+ chrpath --replace "${EPREFIX}${dir}"/lib trine-{bin,launcher}$(usex x86 32 64) || die
+}
+
+src_install() {
+ local sfx=$(usex x86 32 64)
+
+ insinto "${dir}"
+ doins -r binds config data dev profiles *.fbz *.glade trine-logo.png
+
+ exeinto "${dir}/lib"
+ doexe lib${sfx}/*
+
+ exeinto "${dir}"
+ newexe trine-bin${sfx} ${PN}
+
+ make_wrapper ${PN} ./${PN} "${dir}"
+ make_desktop_entry ${PN} "Trine"
+
+ # Compatibility with trine-bin.
+ dosym ${PN} /usr/bin/${PN}-bin
+
+ if use launcher ; then
+ exeinto "${dir}"
+ newexe trine-launcher${sfx} ${PN}-launcher
+
+ dosym {"../..${dir}",/usr/bin}/${PN}-launcher
+ make_desktop_entry ${PN}-launcher "Trine (launcher)"
+
+ # Launcher binary has hardcoded the game path.
+ dosym ${PN} "${dir}"/${PN}-bin
+ fi
+
+ newicon -s 512 Trine.xpm ${PN}.xpm
+ dodoc Trine_Manual_linux.pdf Trine_updates.txt
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }