summaryrefslogtreecommitdiff
path: root/games-action/trine/trine-1.08-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/trine/trine-1.08-r3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/trine/trine-1.08-r3.ebuild')
-rw-r--r--games-action/trine/trine-1.08-r3.ebuild97
1 files changed, 97 insertions, 0 deletions
diff --git a/games-action/trine/trine-1.08-r3.ebuild b/games-action/trine/trine-1.08-r3.ebuild
new file mode 100644
index 000000000000..f9b9673cdd45
--- /dev/null
+++ b/games-action/trine/trine-1.08-r3.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop eutils gnome2-utils unpacker
+
+DESCRIPTION="A physics-based action game with character-dependent solutions to challenges"
+HOMEPAGE="https://www.frozenbyte.com/games/trine-enchanted-edition"
+SRC_URI="TrineUpdate4.64.run"
+LICENSE="frozenbyte-eula"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+launcher"
+RESTRICT="bindist fetch strip"
+
+QA_PREBUILT="opt/${PN}/${PN}*
+ opt/${PN}/lib/*"
+
+DEPEND="
+ app-admin/chrpath
+ app-arch/unzip
+"
+
+RDEPEND="
+ media-gfx/nvidia-cg-toolkit
+ >=media-libs/libsdl-1.2[opengl,video]
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-ttf-2.0
+ >=media-libs/libvorbis-1.3
+ >=media-libs/openal-1.15
+ >=sys-devel/gcc-4.3.0
+ >=sys-libs/glibc-2.4
+ sys-libs/zlib
+ x11-libs/gtk+:2
+ launcher? (
+ dev-libs/glib:2
+ gnome-base/libglade:2.0
+ )"
+
+S="${WORKDIR}"
+dir="/opt/${PN}"
+
+pkg_nofetch() {
+ einfo "Fetch ${SRC_URI} and put it into your distfiles directory."
+ einfo "It is no longer available to purchase but you can still download it"
+ einfo "from https://www.humblebundle.com if you bought it previously."
+ einfo "Otherwise install ${CATEGORY}/trine-enchanted-edition instead."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ default
+ use launcher || rm -v lib*/lib{boost*,icu*}.* || die
+ rm -v lib*/lib{Cg*,direct*,fusion*,gcc_s,jpeg,m,ogg,openal,png*,rt,SDL*,selinux,stdc++,tiff,vga,vorbis*}.* || die
+ chrpath --replace "${EPREFIX}${dir}"/lib trine-{bin,launcher}$(usex x86 32 64) || die
+}
+
+src_install() {
+ local sfx=$(usex x86 32 64)
+
+ insinto "${dir}"
+ doins -r binds config data dev profiles *.fbz *.glade trine-logo.png
+
+ exeinto "${dir}/lib"
+ doexe lib${sfx}/*
+
+ exeinto "${dir}"
+ newexe trine-bin${sfx} ${PN}
+
+ make_wrapper ${PN} ./${PN} "${dir}"
+ make_desktop_entry ${PN} "Trine"
+
+ # Compatibility with trine-bin.
+ dosym ${PN} /usr/bin/${PN}-bin
+
+ if use launcher ; then
+ exeinto "${dir}"
+ newexe trine-launcher${sfx} ${PN}-launcher
+
+ dosym {"../..${dir}",/usr/bin}/${PN}-launcher
+ make_desktop_entry ${PN}-launcher "Trine (launcher)"
+
+ # Launcher binary has hardcoded the game path.
+ dosym ${PN} "${dir}"/${PN}-bin
+ fi
+
+ newicon -s 512 Trine.xpm ${PN}.xpm
+ dodoc Trine_Manual_linux.pdf Trine_updates.txt
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }