summaryrefslogtreecommitdiff
path: root/games-action/towbowl-tactics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/towbowl-tactics
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/towbowl-tactics')
-rw-r--r--games-action/towbowl-tactics/Manifest4
-rw-r--r--games-action/towbowl-tactics/files/towbowl-tactics-0.5-gentoo.patch42
-rw-r--r--games-action/towbowl-tactics/metadata.xml8
-rw-r--r--games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild51
4 files changed, 105 insertions, 0 deletions
diff --git a/games-action/towbowl-tactics/Manifest b/games-action/towbowl-tactics/Manifest
new file mode 100644
index 000000000000..975ae76685ba
--- /dev/null
+++ b/games-action/towbowl-tactics/Manifest
@@ -0,0 +1,4 @@
+AUX towbowl-tactics-0.5-gentoo.patch 1731 BLAKE2B e7049005e54fb6f10f29fca09d42705f787dbb6c440b2b939b694b050219efaec8aaa8149c3247f8ffe1943bd678cb9b2d035eb86bda08f6496af7e32710e74e SHA512 3292a83b642f23f1549acdb53586a5ea0860b7ace4643cf42bb0248bdbf5a7c5b9f66fcd62e5d2432fb1ba5a029061215657a9d65932523e3dbd51f54843295d
+DIST tbt.0.5.src.zip 5321239 BLAKE2B 3391b2b0dd3a88eebfcec722d256720f262fde4ff64111467b53e02911f356cc7f388aad64c1a13bb1e64a59be8065259cd2fe0a1ea79366828a0c19456bb924 SHA512 930d7ba78210e0ad566989279e6d77235c61c641c18da36618de36fcd82d28dd8ca40516ce1384c2a000e4efe86584928cf9c7d2da5fb455f89d358653089f97
+EBUILD towbowl-tactics-0.5.ebuild 1260 BLAKE2B bfc2c1b8854244d95386b05d8f6fe0b671b7e7decfd83a4a640e04bb3a6fc1ee3126ba4971b4432b3f70572236a8e4c2d4cfb8a081a0e34379a0429a8ac0d52e SHA512 b413fd71b1eef923d8df547c3703cdd65a78a28a1a0e56f859f126e4de05656b97e1384af0051f3962bf644a12e3b5b536ffa4ee4336ee6e9f726af985cdf680
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-action/towbowl-tactics/files/towbowl-tactics-0.5-gentoo.patch b/games-action/towbowl-tactics/files/towbowl-tactics-0.5-gentoo.patch
new file mode 100644
index 000000000000..aa6a950e9a07
--- /dev/null
+++ b/games-action/towbowl-tactics/files/towbowl-tactics-0.5-gentoo.patch
@@ -0,0 +1,42 @@
+diff -ru tbt.orig/config.xml tbt/config.xml
+--- tbt.orig/config.xml 2003-02-01 15:14:56.000000000 -0500
++++ tbt/config.xml 2011-01-10 12:08:01.564649048 -0500
+@@ -5,5 +5,5 @@
+ <screen_h>600</screen_h>
+ <sound_enabled>1</sound_enabled>
+ <video_enabled>1</video_enabled>
+-<language>0</language>
++<language>1</language>
+ </config>
+diff -ru tbt.orig/src/Makefile tbt/src/Makefile
+--- tbt.orig/src/Makefile 2003-02-01 15:07:40.000000000 -0500
++++ tbt/src/Makefile 2011-01-10 12:07:29.075274834 -0500
+@@ -1,24 +1,20 @@
+ TBTHOME = /usr/local/games/tbt
+ INCDIR = -I /usr/include/smpeg -I /usr/include/libxml2 -I /usr/include/SDL/
+-CFLAGS = -O2 -g -fno-strength-reduce -Wall -W -DTBTHOME=\"$(TBTHOME)\"
+-LFLAGS = -L. -lm -lSDL -lSDL_net -lSDL_image -lSDL_mixer -ldl -pthread -lxml2 -lsmpeg
+-CC = g++
++CXXFLAGS += -DTBTHOME=\"$(TBTHOME)\"
++LIBS = -lm -lSDL -lSDL_net -lSDL_image -lSDL_mixer -ldl -pthread -lxml2 -lsmpeg
+ SOURCES = movies.cpp sounds.cpp SFont.cpp Ball.cpp CON_console.cpp CON_consolecommands.cpp CON_internal.cpp Config.cpp Console.cpp DT_drawtext.cpp DialogBox.cpp Dice.cpp Formation.cpp Main.cpp MoviePlayer.cpp NetClient.cpp NetServer.cpp Network.cpp Path.cpp Player.cpp ProgressBar.cpp Public.cpp Screen.cpp Shared.cpp SoundPlayer.cpp Square.cpp State.cpp Team.cpp Transformation.cpp Translator.cpp XmlParser.cpp dir_func.cpp
+ OBJS = $(patsubst %.c,%.o,$(SOURCES:%.cpp=%.o))
+ PRGM = tbt
+
+ .SUFFIXES: .cpp .c
+
+-.c.o:
+- $(CC) -c $< $(CFLAGS) $(INCDIR) -o $@
+-
+ .cpp.o:
+- $(CC) -c $< $(CFLAGS) $(INCDIR) -o $@
++ $(CXX) -c $< $(CXXFLAGS) $(INCDIR) -o $@
+
+ all: $(PRGM)
+
+ $(PRGM): $(OBJS)
+- $(CC) $(OBJS) -o $(PRGM) $(LFLAGS)
++ $(CXX) $(OBJS) -o $(PRGM) $(LDFLAGS) $(LIBS)
+
+ clean:
+ -rm -f $(PRGM) *core *~ *.o
diff --git a/games-action/towbowl-tactics/metadata.xml b/games-action/towbowl-tactics/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-action/towbowl-tactics/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild b/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
new file mode 100644
index 000000000000..68970fe0ac94
--- /dev/null
+++ b/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Tow Bowl Tactics is a game based on Games Workshop's Blood Bowl"
+HOMEPAGE="http://www.towbowltactics.com/index_en.html"
+SRC_URI="http://www.towbowltactics.com/download/tbt.${PV}.src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2
+ media-libs/smpeg
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-net
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/tbt/src
+
+src_prepare() {
+ cd ..
+ edos2unix $(find src -type f) config.xml
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "/^TBTHOME/ s:/.*:${GAMES_DATADIR}/tbt:" \
+ src/Makefile || die
+ sed -i \
+ -e "/tbt.ico/ s:\"\./:TBTHOME \"/:" \
+ src/Main.cpp || die
+ sed -i \
+ -e "s:TBTHOME \"/config.xml:\"${GAMES_SYSCONFDIR}/tbt/config.xml:g" \
+ src/global.h || die
+}
+
+src_install() {
+ dogamesbin tbt
+ dodir "${GAMES_DATADIR}/tbt"
+ cp -r ../data ../tbt.ico "${D}${GAMES_DATADIR}/tbt" || die
+ insinto "${GAMES_SYSCONFDIR}/tbt"
+ doins ../config.xml
+ newicon ../data/images/panel/turn.png ${PN}.png
+ make_desktop_entry tbt "Tow Bowl Tactics"
+ prepgamesdirs
+}