summaryrefslogtreecommitdiff
path: root/games-action/swordandsworcery
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/swordandsworcery
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/swordandsworcery')
-rw-r--r--games-action/swordandsworcery/Manifest4
-rw-r--r--games-action/swordandsworcery/files/swordandsworcery-wrapper23
-rw-r--r--games-action/swordandsworcery/metadata.xml13
-rw-r--r--games-action/swordandsworcery/swordandsworcery-1.02.ebuild108
4 files changed, 148 insertions, 0 deletions
diff --git a/games-action/swordandsworcery/Manifest b/games-action/swordandsworcery/Manifest
new file mode 100644
index 000000000000..eac8dc2513e9
--- /dev/null
+++ b/games-action/swordandsworcery/Manifest
@@ -0,0 +1,4 @@
+AUX swordandsworcery-wrapper 641 BLAKE2B 3609da1a899e05c3291ff20f30e75a335ac4aee0b53fac8a59786ce9992cf2b6081a8286ff40384f652e1bf35c4768ed7d9b87e6fcca149afd7ac2a6a8344203 SHA512 a29ff0cfadfd537129f5561fe9fa6acd88630340da49cc754f219aa125d01b8f73be7500dcc636140bbf707d73d8376b229e1897017819614fe6f4f28df1a545
+DIST swordandsworcery_1.02.tar.gz 325277619 BLAKE2B 7e03350b31d2dc68c5ea3643d7e22ec7da1789729201c2e8aec9e06db8c28c0a38bc826de0769dcec78080f17435d90ae3b0441ee230d7b8a9545a66f6e0ec1f SHA512 1178492628e8b8196bbb57b3d4d7526d5545bd31d0da34bcbed92150753fbb768c8682f071e2a473b95f1b6ee7c3efb30ccb9fce2e3e319d76673b79617e47c0
+EBUILD swordandsworcery-1.02.ebuild 2653 BLAKE2B 9a49ca92edb06d3314ccf21911e3aae1963ca6a5493d8f17ceb163fd4f96f1abb98a79b80c9074708c58fce1afe4c950c9a7ced3392868c28ef585d212194750 SHA512 c4307b85c406b9730d0b10386083b4cd9c752c1c628fc202543168a922b1a9de809c109c858534c92d3bb2994a3459de7357bf67aa92e9425d377a765f21edf8
+MISC metadata.xml 355 BLAKE2B 2ebe0923f754bb09445457bb7f266a9fb673682281d31d70b39a05f1cd0beb682fa26e89861c46e9dab0f77428b916f9f99d8324b3780c795f317b6e06efde84 SHA512 78f8cc8f1f1be915da206e4b8be196a21b58a6f209023594755e481136a1b86ee31c8d0dfedd516d756a47db624e89728875b073b71c3b08ac94a5cde8ff3b83
diff --git a/games-action/swordandsworcery/files/swordandsworcery-wrapper b/games-action/swordandsworcery/files/swordandsworcery-wrapper
new file mode 100644
index 000000000000..ce668c71843a
--- /dev/null
+++ b/games-action/swordandsworcery/files/swordandsworcery-wrapper
@@ -0,0 +1,23 @@
+#!/bin/sh
+# Get game directory
+GAMEDIR="@GAMEDIR@"
+LIB=$GAMEDIR/lib
+BIN=$GAMEDIR/bin
+
+# Ensure the log directory exists
+LOGDIR=~/.capy/SwordAndSworcery
+[ -e ~/.capy ] || mkdir ~/.capy
+[ -e ~/.capy/SwordAndSworcery ] || mkdir ~/.capy/SwordAndSworcery
+
+# For multi-monitor displays, choose a screen to display on to avoid having
+# the game be displayed in the middle across both screens in fullscreen mode
+#export SDL_VIDEO_FULLSCREEN_DISPLAY=0
+
+# Modify library paths here
+export LD_LIBRARY_PATH="$LIB:$LD_LIBRARY_PATH"
+
+# Run the game and try to log any errors if any
+cd "$BIN"
+exec ./swordandsworcery $@ 2>&1 | tee -a $LOGDIR/log.txt
+
+exit
diff --git a/games-action/swordandsworcery/metadata.xml b/games-action/swordandsworcery/metadata.xml
new file mode 100644
index 000000000000..b878aaa1812d
--- /dev/null
+++ b/games-action/swordandsworcery/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="bundled-libs">
+ Use the upstream provided bundled libraries.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/games-action/swordandsworcery/swordandsworcery-1.02.ebuild b/games-action/swordandsworcery/swordandsworcery-1.02.ebuild
new file mode 100644
index 000000000000..7369ce107ba3
--- /dev/null
+++ b/games-action/swordandsworcery/swordandsworcery-1.02.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: unbundle liblua-5.1 when available for multilib
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="An exploratory action adventure game with an emphasis on audiovisual style"
+HOMEPAGE="http://www.swordandsworcery.com/"
+SRC_URI="${PN}_${PV}.tar.gz"
+
+LICENSE="CAPYBARA-EULA LGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="bundled-libs"
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/bin/*
+ ${MYGAMEDIR#/}/lib/*"
+
+# linked to pulseaudio
+RDEPEND="
+ virtual/opengl
+ amd64? (
+ >=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_32(-)]
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ >=virtual/glu-9.0-r1[abi_x86_32(-)]
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=media-libs/alsa-lib-1.0.27.2[abi_x86_32(-)]
+ >=media-libs/flac-1.2.1-r5[abi_x86_32(-)]
+ >=media-libs/libogg-1.3.0[abi_x86_32(-)]
+ >=media-libs/libsndfile-1.0.25[abi_x86_32(-)]
+ >=media-libs/libvorbis-1.3.3-r1[abi_x86_32(-)]
+ >=media-sound/pulseaudio-2.1-r1[abi_x86_32(-)]
+ >=x11-libs/libICE-1.0.8-r1[abi_x86_32(-)]
+ >=x11-libs/libSM-1.2.1-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-)]
+ >=x11-libs/libxcb-1.9.1[abi_x86_32(-)]
+ >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libXi-1.7.2[abi_x86_32(-)]
+ >=x11-libs/libXtst-1.2.1-r1[abi_x86_32(-)]
+ !bundled-libs? (
+ >=net-misc/curl-7.36.0[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[X,sound,video,opengl,joystick,abi_x86_32(-)]
+ )
+ )
+ x86? (
+ dev-libs/openssl:0=
+ media-libs/alsa-lib
+ media-libs/flac
+ media-libs/libogg
+ media-libs/libsndfile
+ media-libs/libvorbis
+ media-sound/pulseaudio
+ sys-libs/zlib
+ virtual/glu
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXtst
+ !bundled-libs? (
+ net-misc/curl
+ media-libs/libsdl[X,sound,video,opengl,joystick]
+ )
+ )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_prepare() {
+ if ! use bundled-libs ; then
+ einfo "removing bundled libs..."
+ rm -v lib/libcurl.so* lib/libSDL-1.2.so* \
+ lib/libstdc++.so* || die
+ fi
+
+ sed \
+ -e "s#@GAMEDIR@#${MYGAMEDIR}#" \
+ "${FILESDIR}"/${PN}-wrapper > "${T}"/${PN} || die
+}
+
+src_install() {
+ insinto "${MYGAMEDIR}"
+ doins -r bin lib res
+
+ dogamesbin "${T}"/${PN}
+ make_desktop_entry ${PN}
+
+ dohtml README.html
+
+ fperms +x "${MYGAMEDIR}"/bin/${PN}
+ prepgamesdirs
+}