summaryrefslogtreecommitdiff
path: root/games-action/super-hexagon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/super-hexagon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/super-hexagon')
-rw-r--r--games-action/super-hexagon/Manifest3
-rw-r--r--games-action/super-hexagon/metadata.xml8
-rw-r--r--games-action/super-hexagon/super-hexagon-20160217.ebuild60
3 files changed, 71 insertions, 0 deletions
diff --git a/games-action/super-hexagon/Manifest b/games-action/super-hexagon/Manifest
new file mode 100644
index 000000000000..387d1d5d9235
--- /dev/null
+++ b/games-action/super-hexagon/Manifest
@@ -0,0 +1,3 @@
+DIST superhexagon-02172016-bin 27481878 BLAKE2B bae4d841cd3a03923b92c511a963ea836bf67b79b23dd800fb2731f33344981ad0f8392025173e2840ad3291646427ce42ba6ebd4b4920a29edb68cf9579103b SHA512 ffb54a9c3fd2e78efcdbf491e995f242ea10da40f32d36c17a0e29f6ac5d684426b542abc1dcdc8c281fa62b6a267642f834b8007686c35f54a445568808eb1e
+EBUILD super-hexagon-20160217.ebuild 1371 BLAKE2B f8a7eccd25c322b2f0a66e5f4f774df0d4fbbf0d2496c5ce10b335d7042727b9812f7f5da6e31e45251cdc0eec1365a6fdb7484b3364c5816e9883eb6c71cb8b SHA512 5b5039241bd83a32ee573f85d3300e592ce1c7a1f6beff8b8798aa281b7b44eed4a7e082d9a09159427a0ea95e72514635aeaa6970c346f771718cf8d3381f7f
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-action/super-hexagon/metadata.xml b/games-action/super-hexagon/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-action/super-hexagon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-action/super-hexagon/super-hexagon-20160217.ebuild b/games-action/super-hexagon/super-hexagon-20160217.ebuild
new file mode 100644
index 000000000000..a985d2bed49c
--- /dev/null
+++ b/games-action/super-hexagon/super-hexagon-20160217.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop eutils gnome2-utils unpacker
+
+TIMESTAMP="${PV:4:2}${PV:6:2}${PV:0:4}"
+DESCRIPTION="A minimal action game by Terry Cavanagh, with music by Chipzel"
+HOMEPAGE="https://www.superhexagon.com/"
+SRC_URI="superhexagon-${TIMESTAMP}-bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR="/opt/${PN}"
+QA_PREBUILT="${MYGAMEDIR#/}/superhexagon"
+
+DEPEND="app-arch/unzip"
+
+RDEPEND="media-libs/glew:1.6
+ media-libs/libsdl2[opengl,sound,video]
+ media-libs/libvorbis
+ media-libs/openal
+ virtual/glu
+ virtual/opengl"
+
+S="${WORKDIR}/data"
+DOCS=( Linux.README )
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ local myarch=$(usex amd64 x86_64 x86)
+
+ exeinto "${MYGAMEDIR}"
+ insinto "${MYGAMEDIR}"
+ newexe ${myarch}/superhexagon.${myarch} superhexagon
+ doins -r data SuperHexagon.png
+
+ make_wrapper ${PN} ./superhexagon "${MYGAMEDIR}"
+ newicon -s 512 SuperHexagon.png ${PN}.png
+ make_desktop_entry ${PN}
+
+ einstalldocs
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }