summaryrefslogtreecommitdiff
path: root/games-action/spacetripper-demo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/spacetripper-demo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/spacetripper-demo')
-rw-r--r--games-action/spacetripper-demo/Manifest3
-rw-r--r--games-action/spacetripper-demo/metadata.xml8
-rw-r--r--games-action/spacetripper-demo/spacetripper-demo-1-r1.ebuild47
3 files changed, 58 insertions, 0 deletions
diff --git a/games-action/spacetripper-demo/Manifest b/games-action/spacetripper-demo/Manifest
new file mode 100644
index 000000000000..3c33104e7f2b
--- /dev/null
+++ b/games-action/spacetripper-demo/Manifest
@@ -0,0 +1,3 @@
+DIST spacetripperdemo.sh 5179095 BLAKE2B a2d3109c6557df46b2afa221b92983d4a364abe77260c96066bf466682a022832fef2aee80a438b4e07da5bfcb5d868f45429be87b024d0bcd21eb6636a3a100 SHA512 43c0aac805671716816dfba58fe1ccad333886a1a20a3dfdaba7b78512dbe2ca6fbe6c09782e14f81d475c9c9bccb4043bac4c8bd756800fe43596dbee5018a0
+EBUILD spacetripper-demo-1-r1.ebuild 1122 BLAKE2B 645b89ba3dda465c7b9f15e12268070e76add220ec533947baa988a3a1d034cd866974ce2b5f95aec792170d6632965bc59e91a2da9a81809ad309ee6bc9fb4c SHA512 f84cc7d97f13cec694b21e56c52e22ea75d746edbfa42cdf0a9d719761049bac94108ae43257e0481412cfa1fa6ad84aaae333c4905c268f2f7e7e86c98fd7bc
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-action/spacetripper-demo/metadata.xml b/games-action/spacetripper-demo/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-action/spacetripper-demo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-action/spacetripper-demo/spacetripper-demo-1-r1.ebuild b/games-action/spacetripper-demo/spacetripper-demo-1-r1.ebuild
new file mode 100644
index 000000000000..40bcbf3485b8
--- /dev/null
+++ b/games-action/spacetripper-demo/spacetripper-demo-1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils unpacker
+
+MY_P="spacetripperdemo"
+DESCRIPTION="Hardcore arcade shoot-em-up"
+HOMEPAGE="http://www.pompomgames.com/"
+SRC_URI="http://www.btinternet.com/~bongpig/${MY_P}.sh"
+
+LICENSE="POMPOM"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[abi_x86_32(-),X,video,joystick,opengl,sound]"
+
+S=${WORKDIR}
+
+dir=/opt/${PN}
+Ddir=${D}/${dir}
+
+QA_PREBUILT="${dir}/*"
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ exeinto "${dir}"
+ doexe bin/x86/*
+ # Remove libSDL since we use the system version and our version doesn't
+ # have TEXTRELs in it.
+ rm -f "${Ddir}"/libSDL-1.2.so.0.0.5 || die
+ sed -i -e "s:XYZZY:${dir}:" "${Ddir}/${MY_P}" || die
+
+ insinto "${dir}"
+ doins -r preview run styles README license.txt icon.xpm
+ newicon icon.xpm spacetripper-demo.png
+
+ make_wrapper spacetripper-demo ./spacetripperdemo "${dir}" "${dir}"
+ make_desktop_entry spacetripper-demo spacetripper-demo spacetripper-demo
+}