summaryrefslogtreecommitdiff
path: root/games-action/solar2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/solar2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/solar2')
-rw-r--r--games-action/solar2/Manifest4
-rw-r--r--games-action/solar2/metadata.xml13
-rw-r--r--games-action/solar2/solar2-1.10.ebuild105
3 files changed, 122 insertions, 0 deletions
diff --git a/games-action/solar2/Manifest b/games-action/solar2/Manifest
new file mode 100644
index 000000000000..12ee5c767763
--- /dev/null
+++ b/games-action/solar2/Manifest
@@ -0,0 +1,4 @@
+DIST solar2-linux-1.10.tar.gz 106202569 BLAKE2B 4dc1f0c273aa8363178c581a516969a22707a5345eb11a373f96dd8136af3b390451cd72e7b06bc661ef3e8926f0339d3dad70e9b950210e7820efe9913fe9af SHA512 68475cfe9220a1f19608cd2dfb575979e231dcf1bc61e12230db5a39856a03afceeb8c3f2b0ea6d958b36a53945bdb2768261f2b0bcc50a88f2b3eeddc48df9d
+DIST solar2.png 8260 BLAKE2B cf154377ee73b6d0f3c86e0377b29ca7208ef030183db7bae88b352d5684f3c513d0ad57119121a79906287e72d0a863891285224b631fa44d2ccee12a1eacef SHA512 a85e875e3a159670ea2a3f32687e7e52cf369f29add86f19e6431f05e7835c1a30303ddd4ff406a525c1086298807c2f94773dd987d4d99b89bc7c63150c9c85
+EBUILD solar2-1.10.ebuild 2565 BLAKE2B 54e3e442833df5219b50802340278d5497ab66cf56e9c165557b7d36a06734104a9f2773985ccd5af98befcf69d28b7623968aa96e8066ac8715c63376ef30a1 SHA512 ef5c7201c482e36d987ba02c78324edc0f2b179449915139fa5f695ef18b4f7cc25e3ea11cfa0f3ae3f2a83cf54193bbd457edbd465095cc2bd6ad11db831e0c
+MISC metadata.xml 355 BLAKE2B 2ebe0923f754bb09445457bb7f266a9fb673682281d31d70b39a05f1cd0beb682fa26e89861c46e9dab0f77428b916f9f99d8324b3780c795f317b6e06efde84 SHA512 78f8cc8f1f1be915da206e4b8be196a21b58a6f209023594755e481136a1b86ee31c8d0dfedd516d756a47db624e89728875b073b71c3b08ac94a5cde8ff3b83
diff --git a/games-action/solar2/metadata.xml b/games-action/solar2/metadata.xml
new file mode 100644
index 000000000000..b878aaa1812d
--- /dev/null
+++ b/games-action/solar2/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="bundled-libs">
+ Use the upstream provided bundled libraries.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/games-action/solar2/solar2-1.10.ebuild b/games-action/solar2/solar2-1.10.ebuild
new file mode 100644
index 000000000000..2a092f697e3a
--- /dev/null
+++ b/games-action/solar2/solar2-1.10.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: - unbundle libmono for 64bit
+# - unbundling libSDL_mixer breaks the game
+# - provide icon
+# - test useflags for libsdl on x86
+
+EAPI=5
+
+inherit eutils gnome2-utils games
+
+DESCRIPTION="An open-world, sandbox game set in an infinite abstract universe"
+HOMEPAGE="http://murudai.com/solar/"
+GAMEBALL="${PN}-linux-${PV}.tar.gz"
+ICONFILE="https://dev.gentoo.org/~chewi/distfiles/${PN}.png"
+SRC_URI="${GAMEBALL} ${ICONFILE}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="bundled-libs"
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/lib/*
+ ${MYGAMEDIR#/}/Solar2.bin.x86"
+
+RDEPEND="
+ virtual/opengl
+ amd64? (
+ >=media-libs/flac-1.2.1-r5[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[X,sound,video,joystick,abi_x86_32(-)]
+ >=media-libs/libvorbis-1.3.3-r1[abi_x86_32(-)]
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ !bundled-libs? (
+ >=media-libs/libmad-0.15.1b-r8[abi_x86_32(-)]
+ >=media-libs/openal-1.15.1[abi_x86_32(-)]
+ >=media-libs/sdl-mixer-1.2.12-r4[flac,mikmod,mad,mp3,vorbis,abi_x86_32(-)]
+ >=media-libs/libmikmod-3.2.0[abi_x86_32(-)]
+ )
+ )
+ x86? (
+ media-libs/flac
+ media-libs/libsdl[X,sound,video,joystick]
+ media-libs/libvorbis
+ !bundled-libs? (
+ dev-lang/mono
+ media-libs/libmad
+ media-libs/libmikmod
+ media-libs/openal
+ media-libs/sdl-mixer[flac,mikmod,mad,mp3,vorbis]
+ )
+ )"
+
+S=${WORKDIR}/Solar2
+
+pkg_nofetch() {
+ einfo "Please buy and download ${GAMEBALL} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "Also download ${ICONFILE}"
+ einfo "and move both to your distfiles directory. The Humble Bundle download"
+ einfo "may have a timestamp appended to the filename."
+}
+
+src_prepare() {
+ # remove unused files
+ rm solar2.sh || die
+
+ if ! use bundled-libs ; then
+ einfo "Removing bundled libs..."
+ if use amd64 ; then
+ # no mono 32bit libs on amd64 yet
+ rm -v lib/libmad.so* lib/libmikmod.so* lib/libopenal.so* || die
+ else
+ rm -v lib/libmad.so* lib/libmikmod.so* lib/libopenal.so* lib/libmono-2.0.so* || die
+ fi
+ fi
+}
+
+src_install() {
+ insinto "${MYGAMEDIR}"
+ doins -r *
+
+ games_make_wrapper ${PN} "./Solar2.bin.x86" "${MYGAMEDIR}"
+ make_desktop_entry ${PN}
+ doicon -s 64 "${DISTDIR}"/${PN}.png
+
+ fperms +x "${MYGAMEDIR}"/Solar2.bin.x86
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}