summaryrefslogtreecommitdiff
path: root/games-action/solar2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-action/solar2
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-action/solar2')
-rw-r--r--games-action/solar2/Manifest2
-rw-r--r--games-action/solar2/solar2-1.10-r1.ebuild (renamed from games-action/solar2/solar2-1.10.ebuild)42
2 files changed, 22 insertions, 22 deletions
diff --git a/games-action/solar2/Manifest b/games-action/solar2/Manifest
index 12ee5c767763..3d753a0d196b 100644
--- a/games-action/solar2/Manifest
+++ b/games-action/solar2/Manifest
@@ -1,4 +1,4 @@
DIST solar2-linux-1.10.tar.gz 106202569 BLAKE2B 4dc1f0c273aa8363178c581a516969a22707a5345eb11a373f96dd8136af3b390451cd72e7b06bc661ef3e8926f0339d3dad70e9b950210e7820efe9913fe9af SHA512 68475cfe9220a1f19608cd2dfb575979e231dcf1bc61e12230db5a39856a03afceeb8c3f2b0ea6d958b36a53945bdb2768261f2b0bcc50a88f2b3eeddc48df9d
DIST solar2.png 8260 BLAKE2B cf154377ee73b6d0f3c86e0377b29ca7208ef030183db7bae88b352d5684f3c513d0ad57119121a79906287e72d0a863891285224b631fa44d2ccee12a1eacef SHA512 a85e875e3a159670ea2a3f32687e7e52cf369f29add86f19e6431f05e7835c1a30303ddd4ff406a525c1086298807c2f94773dd987d4d99b89bc7c63150c9c85
-EBUILD solar2-1.10.ebuild 2565 BLAKE2B 54e3e442833df5219b50802340278d5497ab66cf56e9c165557b7d36a06734104a9f2773985ccd5af98befcf69d28b7623968aa96e8066ac8715c63376ef30a1 SHA512 ef5c7201c482e36d987ba02c78324edc0f2b179449915139fa5f695ef18b4f7cc25e3ea11cfa0f3ae3f2a83cf54193bbd457edbd465095cc2bd6ad11db831e0c
+EBUILD solar2-1.10-r1.ebuild 2499 BLAKE2B bbe1195d0f7a651f15d086392a33999fa3dd947f2ea988fbd845b13bababa98ddaff37302732c1e8f7c5a150a218cc6e89519f5f818aade98e737e46776eccbd SHA512 ea04f3ae67e3a4b3c867ccd803351c4fe641dd084503c32bdfbaa7e4fe1be657c394866daf7c7cc47d745e03416673839286bb8fd031aadba326daa7805242fb
MISC metadata.xml 355 BLAKE2B 2ebe0923f754bb09445457bb7f266a9fb673682281d31d70b39a05f1cd0beb682fa26e89861c46e9dab0f77428b916f9f99d8324b3780c795f317b6e06efde84 SHA512 78f8cc8f1f1be915da206e4b8be196a21b58a6f209023594755e481136a1b86ee31c8d0dfedd516d756a47db624e89728875b073b71c3b08ac94a5cde8ff3b83
diff --git a/games-action/solar2/solar2-1.10.ebuild b/games-action/solar2/solar2-1.10-r1.ebuild
index 2a092f697e3a..1d32c61c8bba 100644
--- a/games-action/solar2/solar2-1.10.ebuild
+++ b/games-action/solar2/solar2-1.10-r1.ebuild
@@ -1,31 +1,34 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# TODO: - unbundle libmono for 64bit
-# - unbundling libSDL_mixer breaks the game
-# - provide icon
-# - test useflags for libsdl on x86
+EAPI=7
-EAPI=5
+inherit desktop gnome2-utils wrapper
-inherit eutils gnome2-utils games
-
-DESCRIPTION="An open-world, sandbox game set in an infinite abstract universe"
-HOMEPAGE="http://murudai.com/solar/"
GAMEBALL="${PN}-linux-${PV}.tar.gz"
ICONFILE="https://dev.gentoo.org/~chewi/distfiles/${PN}.png"
+DESCRIPTION="An open-world, sandbox game set in an infinite abstract universe"
+HOMEPAGE="http://murudai.com/solar/"
SRC_URI="${GAMEBALL} ${ICONFILE}"
+S="${WORKDIR}"/Solar2
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="bundled-libs"
+
RESTRICT="bindist fetch splitdebug"
-MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
-QA_PREBUILT="${MYGAMEDIR#/}/lib/*
- ${MYGAMEDIR#/}/Solar2.bin.x86"
+MYGAMEDIR=opt/${PN}
+QA_PREBUILT="
+ ${MYGAMEDIR#/}/lib/*
+ ${MYGAMEDIR#/}/Solar2.bin.x86
+"
+# TODO: - unbundle libmono for 64bit
+# - unbundling libSDL_mixer breaks the game
+# - provide icon
+# - test useflags for libsdl on x86
RDEPEND="
virtual/opengl
amd64? (
@@ -53,8 +56,6 @@ RDEPEND="
)
)"
-S=${WORKDIR}/Solar2
-
pkg_nofetch() {
einfo "Please buy and download ${GAMEBALL} from:"
einfo " ${HOMEPAGE}"
@@ -64,6 +65,8 @@ pkg_nofetch() {
}
src_prepare() {
+ default
+
# remove unused files
rm solar2.sh || die
@@ -79,24 +82,21 @@ src_prepare() {
}
src_install() {
- insinto "${MYGAMEDIR}"
+ insinto ${MYGAMEDIR}
doins -r *
- games_make_wrapper ${PN} "./Solar2.bin.x86" "${MYGAMEDIR}"
+ make_wrapper ${PN} "./Solar2.bin.x86" "${MYGAMEDIR}"
make_desktop_entry ${PN}
doicon -s 64 "${DISTDIR}"/${PN}.png
- fperms +x "${MYGAMEDIR}"/Solar2.bin.x86
- prepgamesdirs
+ fperms +x ${MYGAMEDIR}/Solar2.bin.x86
}
pkg_preinst() {
- games_pkg_preinst
gnome2_icon_savelist
}
pkg_postinst() {
- games_pkg_postinst
gnome2_icon_cache_update
}