summaryrefslogtreecommitdiff
path: root/games-action/snipes/snipes-1.0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-action/snipes/snipes-1.0.4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-action/snipes/snipes-1.0.4-r1.ebuild')
-rw-r--r--games-action/snipes/snipes-1.0.4-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-action/snipes/snipes-1.0.4-r1.ebuild b/games-action/snipes/snipes-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..9d8e9a36c48b
--- /dev/null
+++ b/games-action/snipes/snipes-1.0.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs eutils
+
+DESCRIPTION="2D scrolling shooter, resembles the old DOS game of same name"
+HOMEPAGE="https://cyp.github.com/snipes/"
+SRC_URI="https://cyp.github.com/snipes/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-nongnulinker.patch
+)
+
+src_compile() {
+ tc-getLD
+ default
+}
+
+src_install() {
+ dobin snipes
+ doman snipes.6
+ dodoc ChangeLog
+ doicon ${PN}.png
+ make_desktop_entry snipes "Snipes"
+}