summaryrefslogtreecommitdiff
path: root/games-action/shadowgrounds-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/shadowgrounds-bin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/shadowgrounds-bin')
-rw-r--r--games-action/shadowgrounds-bin/Manifest3
-rw-r--r--games-action/shadowgrounds-bin/metadata.xml8
-rw-r--r--games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1.ebuild68
3 files changed, 79 insertions, 0 deletions
diff --git a/games-action/shadowgrounds-bin/Manifest b/games-action/shadowgrounds-bin/Manifest
new file mode 100644
index 000000000000..f1f0932b39b2
--- /dev/null
+++ b/games-action/shadowgrounds-bin/Manifest
@@ -0,0 +1,3 @@
+DIST shadowgroundsUpdate1.run 817462983 BLAKE2B 52f49f9777fc909cd4aba0b77513726db5257e97e6f667710e728fd012522810c1caad2130cfeb6bc09ffc0056e2aa5024fcb330789320c4b1242584f67697cd SHA512 8e2cc340d4917e7e0ac6b0a6f3d36aeadc0217c437da8ed5641c82b7da7632f8e0c4f59d21088dcc922cc3f740a5eadb27143bd73ba774c258ff9b668a7b3da6
+EBUILD shadowgrounds-bin-0_p1.ebuild 1604 BLAKE2B 48071fac42ca8595bfb077cd0afcb0efae10b71dc89ba8afa8aa937c72af167a904478c9d0ebdcc8e6bdcf7cd563730e4670af63481ee0639dca0a2463513ec6 SHA512 c95f8e79bd70eb4ac4faf4c8028f42181b26c582ebc006be599169a6025bdc7ca97da206eeea919cdc5bce92b9179848b7498b906800495d8a59e9a7f8ea94d0
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-action/shadowgrounds-bin/metadata.xml b/games-action/shadowgrounds-bin/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-action/shadowgrounds-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1.ebuild b/games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1.ebuild
new file mode 100644
index 000000000000..3a8863f6bb90
--- /dev/null
+++ b/games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit unpacker games eutils versionator
+
+DIST_PV=$(get_version_component_range 2)
+
+DESCRIPTION="an epic action experience combining modern technology with addictive playability"
+HOMEPAGE="http://shadowgroundsgame.com/"
+# FIXME: PV should perhaps be 0_p1, in which case a filter is in order
+SRC_URI="shadowgroundsUpdate${DIST_PV/p/}.run"
+
+LICENSE="frozenbyte-eula"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=sys-libs/glibc-2.4
+ >=sys-devel/gcc-4.3.0
+ !amd64? (
+ gnome-base/libglade
+ sys-libs/zlib
+ )
+ amd64? (
+ >=gnome-base/libglade-2.6.4-r1[abi_x86_32(-)]
+ sys-libs/zlib[abi_x86_32(-)]
+ )"
+
+S=${WORKDIR}
+
+d="${GAMES_PREFIX_OPT}/${PN}"
+QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
+QA_TEXTRELS_amd64=${QA_TEXTRELS_x86}
+
+pkg_nofetch() {
+ einfo "Fetch ${SRC_URI} and put it into ${DISTDIR}"
+ einfo "See http://www.humblebundle.com/ for more info."
+}
+
+src_unpack() {
+ # manually run unzip as the initial seek causes it to exit(1)
+ unpack_zip ${A}
+ rm lib*/lib{gcc_s,m,rt,selinux,z}.so.?
+}
+
+src_install() {
+ local b bb
+
+ doicon Shadowgrounds.xpm
+ for b in bin launcher ; do
+ bb="shadowgrounds-${b}"
+ exeinto ${d}
+ newexe ${bb} ${bb} || die
+ games_make_wrapper ${bb} "./${bb}" "${d}"
+ make_desktop_entry ${bb} "Shadowgrounds ${b}" Shadowgrounds
+ done
+
+ exeinto ${d}/lib32
+ doexe lib32/*
+
+ insinto ${d}
+ doins -r Config data Profiles *.fbz *.glade *-logo.png
+
+ prepgamesdirs
+}