summaryrefslogtreecommitdiff
path: root/games-action/shadowgrounds-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-action/shadowgrounds-bin
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-action/shadowgrounds-bin')
-rw-r--r--games-action/shadowgrounds-bin/Manifest2
-rw-r--r--games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1-r1.ebuild (renamed from games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1.ebuild)36
2 files changed, 19 insertions, 19 deletions
diff --git a/games-action/shadowgrounds-bin/Manifest b/games-action/shadowgrounds-bin/Manifest
index 88fa8d6a62a7..134e39a511c1 100644
--- a/games-action/shadowgrounds-bin/Manifest
+++ b/games-action/shadowgrounds-bin/Manifest
@@ -1,3 +1,3 @@
DIST shadowgroundsUpdate1.run 817462983 BLAKE2B 52f49f9777fc909cd4aba0b77513726db5257e97e6f667710e728fd012522810c1caad2130cfeb6bc09ffc0056e2aa5024fcb330789320c4b1242584f67697cd SHA512 8e2cc340d4917e7e0ac6b0a6f3d36aeadc0217c437da8ed5641c82b7da7632f8e0c4f59d21088dcc922cc3f740a5eadb27143bd73ba774c258ff9b668a7b3da6
-EBUILD shadowgrounds-bin-0_p1.ebuild 1614 BLAKE2B f819f8933d3b3cd4628fc7d02f98c5ccca16c60ef4816848b8b9c16f5131f0186380a847c04d6fc418a018c856e71de1df4c0aa28fbc46a5890380bdbd94c2ce SHA512 7bde396460c2a7e5b798324acfbb5813d2e028004ff39d7fe4dfc08c398200f6af938746d0a3dbb1a9f37bec36f121a2c0f5874286f99af8f093a07f8d69f3e1
+EBUILD shadowgrounds-bin-0_p1-r1.ebuild 1547 BLAKE2B 3424a8cd312cac2be387e4289afa736574619a2fe2c2eb581829df260d75857182a44a69f82a991eee5f0b179d8a1600a015aad9842ffdc05d20106650755869 SHA512 4232da13a39a763a071a38ed680e1f84a4ab05a10b4a6729ad71a87f01e826af64613207653df790774bc8a38a49d34e405cd5d75f2a920ccf86e8a4b039d82e
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1.ebuild b/games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1-r1.ebuild
index 232160a45498..90a1666c8a04 100644
--- a/games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1.ebuild
+++ b/games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1-r1.ebuild
@@ -1,25 +1,26 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit unpacker games eutils versionator
+EAPI=7
-DIST_PV=$(get_version_component_range 2)
+inherit desktop unpacker wrapper
-DESCRIPTION="an epic action experience combining modern technology with addictive playability"
+DIST_PV=$(ver_cut 2-)
+
+DESCRIPTION="An epic action experience combining modern technology with addictive playability"
HOMEPAGE="http://shadowgroundsgame.com/"
# FIXME: PV should perhaps be 0_p1, in which case a filter is in order
SRC_URI="shadowgroundsUpdate${DIST_PV/p/}.run"
+S="${WORKDIR}"
LICENSE="frozenbyte-eula"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
RESTRICT="fetch strip"
-DEPEND="app-arch/unzip"
-RDEPEND=">=sys-libs/glibc-2.4
+RDEPEND="
>=sys-devel/gcc-4.3.0
+ >=sys-libs/glibc-2.4
!amd64? (
gnome-base/libglade
sys-libs/zlib
@@ -27,11 +28,11 @@ RDEPEND=">=sys-libs/glibc-2.4
amd64? (
>=gnome-base/libglade-2.6.4-r1[abi_x86_32(-)]
sys-libs/zlib[abi_x86_32(-)]
- )"
-
-S=${WORKDIR}
+ )
+"
+BDEPEND="app-arch/unzip"
-d="${GAMES_PREFIX_OPT}/${PN}"
+d="opt/${PN}"
QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
QA_TEXTRELS_amd64=${QA_TEXTRELS_x86}
@@ -41,9 +42,9 @@ pkg_nofetch() {
}
src_unpack() {
- # manually run unzip as the initial seek causes it to exit(1)
+ # Manually run unzip as the initial seek causes it to exit(1)
unpack_zip ${A}
- rm lib*/lib{gcc_s,m,rt,selinux,z}.so.?
+ rm lib*/lib{gcc_s,m,rt,selinux,z}.so.? || die
}
src_install() {
@@ -53,8 +54,9 @@ src_install() {
for b in bin launcher ; do
bb="shadowgrounds-${b}"
exeinto ${d}
- newexe ${bb} ${bb} || die
- games_make_wrapper ${bb} "./${bb}" "${d}"
+ newexe ${bb} ${bb}
+
+ make_wrapper ${bb} "./${bb}" "${d}"
make_desktop_entry ${bb} "Shadowgrounds ${b}" Shadowgrounds
done
@@ -63,6 +65,4 @@ src_install() {
insinto ${d}
doins -r Config data Profiles *.fbz *.glade *-logo.png
-
- prepgamesdirs
}