summaryrefslogtreecommitdiff
path: root/games-action/rive
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /games-action/rive
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'games-action/rive')
-rw-r--r--games-action/rive/Manifest3
-rw-r--r--games-action/rive/metadata.xml8
-rw-r--r--games-action/rive/rive-1.15.ebuild46
3 files changed, 57 insertions, 0 deletions
diff --git a/games-action/rive/Manifest b/games-action/rive/Manifest
new file mode 100644
index 000000000000..f3dd72749497
--- /dev/null
+++ b/games-action/rive/Manifest
@@ -0,0 +1,3 @@
+DIST RIVE-Linux-2017-02-28.sh 836583560 BLAKE2B 2194d6174217a395e84f0defc336e741671f62b71cb15dad16fd9c3f1f23d844771e830858bbc8e8a26bd4ebf93e2f9b316c6a2a9c9de74d876a393b9911a806 SHA512 94d236421dc060b8e69552ee6bcbdc4b41caa4934ccf73f8d82dcd2ee14a9c334f43bc74e787a470b3103699c31b4f4ccf9272fbe69640e27df1fdbc2191447c
+EBUILD rive-1.15.ebuild 980 BLAKE2B 7e27c8f993cf9c1c5455662442f95cefa37ec2c9ee96c3fb04b7d2411a763d05ee06e689cbc4e62d01991ca337b76ba1ffc076183f1ce69c2e5fe4bf6c793aad SHA512 02fa8d6a9258a508b98fa962638f14ed1d54b6e4a792d0b8ffb97cf3368cd170d61e52c66098bc77cd70b1a95d0e0db1ca1df632a6f30ca5f982ac5c0fc55e8b
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-action/rive/metadata.xml b/games-action/rive/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-action/rive/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-action/rive/rive-1.15.ebuild b/games-action/rive/rive-1.15.ebuild
new file mode 100644
index 000000000000..6014bf696dec
--- /dev/null
+++ b/games-action/rive/rive-1.15.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop unpacker xdg
+
+DESCRIPTION="Metal wrecking, robot hacking 360-degree shooter/platformer hybrid"
+HOMEPAGE="https://rivethegame.com/"
+SRC_URI="${PN^^}-Linux-2017-02-28.sh"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ media-libs/libsdl2[opengl,video]
+ media-libs/openal
+"
+
+S="${WORKDIR}/data"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe x86_64/${PN^^}.bin.x86_64 ${PN^^}.bin
+ dosym "../..${DIR}"/${PN^^}.bin /usr/bin/${PN}
+
+ insinto "${DIR}"
+ doins -r noarch/*
+
+ newicon -s 256 noarch/app_icon.png ${PN}.png
+ make_desktop_entry ${PN} ${PN^^}
+}