summaryrefslogtreecommitdiff
path: root/games-action/psychonauts-gog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-17 19:45:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-17 19:45:55 +0100
commit59fb6ea4eff116f078307a57217645762b78aba7 (patch)
treebc4b009c0fb67e5716ad01ba8306a486fe4744ed /games-action/psychonauts-gog
parent197f0639ca0a63b397552e059e2a992d39e09e55 (diff)
gentoo auto-resync : 17:06:2023 - 19:45:55
Diffstat (limited to 'games-action/psychonauts-gog')
-rw-r--r--games-action/psychonauts-gog/Manifest3
-rw-r--r--games-action/psychonauts-gog/metadata.xml14
-rw-r--r--games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild61
3 files changed, 78 insertions, 0 deletions
diff --git a/games-action/psychonauts-gog/Manifest b/games-action/psychonauts-gog/Manifest
new file mode 100644
index 000000000000..4062ed802c96
--- /dev/null
+++ b/games-action/psychonauts-gog/Manifest
@@ -0,0 +1,3 @@
+DIST gog_psychonauts_2.0.0.4.sh 4424617772 BLAKE2B 4102a7e23f71857c969349be3eb5b5fa4780d02ec92945a0be13098af4fa30d04fe4294e0fd5b3bd64dfe731a252ee4bcb73c07ca15df4dc532f26e12ed0335d SHA512 5f8cbcbd2eecab66f0a3bc555a6850536dd124fe720d6fe7eba0a56964978b045daac14630ec2e2f9129a3c6cf263baf5cbe65b15f08bc5cd5f754f35b3629a9
+EBUILD psychonauts-gog-2.0.0.4.ebuild 1300 BLAKE2B 534a2ecaf6daba3efeb0ff590579edf72c760a67b175da61de362d68bccca7c1c883053865df48f9a3965f57c37c52b7e047cd627044c44b15fb057fa1971234 SHA512 78dd7ec31b6f93d7814d8da06c17b2719636693de8dc77dd21b29f4d4474324cffa3a44374fd1830eb54df3c78f5ded87d5eb50d248a0d03fd56dc15859409d4
+MISC metadata.xml 539 BLAKE2B 63a0be6c8ba2f49f5bffb149fb37f306695444f8d61ea5232e110463567cd6062c526d7715f63e6926cea84d6cde74eef35a760b2e33e3339095c1b844b877cf SHA512 b813129a415f10afa2c68650e963d3f3149518716965fca98a2d7d6649f0455afbb0565dfba7f545aa67fed2986b2c1740c793a99f3367eb8c5a12afb0bf398c
diff --git a/games-action/psychonauts-gog/metadata.xml b/games-action/psychonauts-gog/metadata.xml
new file mode 100644
index 000000000000..6366a89a523f
--- /dev/null
+++ b/games-action/psychonauts-gog/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Psychic Odyssey Through the Mental Worlds of Misfits, Monsters, and
+ Mind Readers. This classic action/adventure platformer from acclaimed
+ developers Double Fine Productions follows the story of a young psychic
+ named Razputin.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild b/games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild
new file mode 100644
index 000000000000..bfe45f2b11b3
--- /dev/null
+++ b/games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHECKREQS_DISK_BUILD="5238M"
+inherit check-reqs desktop unpacker wrapper xdg
+
+MY_PN="Psychonauts"
+
+DESCRIPTION="A mind-bending platforming adventure from Double Fine Productions"
+HOMEPAGE="https://www.doublefine.com/games/psychonauts"
+SRC_URI="gog_${MY_PN,,}_${PV}.sh"
+
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+RDEPEND="
+ media-libs/libsdl[abi_x86_32,opengl,video]
+ media-libs/openal[abi_x86_32]
+ >=sys-devel/gcc-3.4[cxx]
+ sys-libs/glibc
+ !${CATEGORY}/${MY_PN,,}
+ !${CATEGORY}/${MY_PN,,}-hb
+"
+
+S="${WORKDIR}/data/noarch"
+DIR="/opt/${MY_PN,,}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ elog "Please buy and download ${SRC_URI} from:"
+ elog " https://www.gog.com/game/${MY_PN,,}"
+ elog "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ doexe game/${MY_PN}
+ make_wrapper ${MY_PN,,} "${DIR}"/${MY_PN}
+
+ insinto "${DIR}"
+ doins -r game/{icon.bmp,WorkResource/,*.pkg}
+
+ newicon -s 256 support/icon.png ${MY_PN,,}.png
+ make_desktop_entry ${MY_PN,,} ${MY_PN} ${MY_PN,,}
+
+ dodoc \
+ docs/"Psychonauts Manual Win.pdf" \
+ game/Documents/Readmes/*.txt
+}