summaryrefslogtreecommitdiff
path: root/games-action/prismlauncher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-02 15:09:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-02 15:09:59 +0000
commitbe524496e3171d5eab8c56570dd4342a880c3264 (patch)
tree7141abc4a70431332a0a63b8814cc5f06ac64f4f /games-action/prismlauncher
parent1ab8c7f6ed10f981d767a0acc2f420cf86775f12 (diff)
gentoo auto-resync : 02:11:2022 - 15:09:58
Diffstat (limited to 'games-action/prismlauncher')
-rw-r--r--games-action/prismlauncher/Manifest4
-rw-r--r--games-action/prismlauncher/prismlauncher-5.1.ebuild147
-rw-r--r--games-action/prismlauncher/prismlauncher-9999.ebuild4
3 files changed, 151 insertions, 4 deletions
diff --git a/games-action/prismlauncher/Manifest b/games-action/prismlauncher/Manifest
index 62846676a401..d04a9bedc692 100644
--- a/games-action/prismlauncher/Manifest
+++ b/games-action/prismlauncher/Manifest
@@ -1,4 +1,6 @@
DIST prismlauncher-5.0.tar.gz 9379431 BLAKE2B 0406b0e706068d32eaed427c5475b1388144b6155a69cf29674e7b45de84c86ca872615b6ec64602e942f155061630c7a866800e24ccb7546c2a32bf298380cf SHA512 71f19603a2e09d581ed80bbef6a3cd4a2c3081ba820fad8d73ebab155075d7a84e17ce9f70490a8984e7cb6a5d35089efb77bb5c364c4580fe4a8759fa79313d
+DIST prismlauncher-5.1.tar.gz 9401315 BLAKE2B 22a0508efc042a78099d0458d305c623465533d9770b111e584f4591cbd9372b354501fb3edf941f4c9f744f3540bd793c00f1ca428705bd2ca140be87056575 SHA512 2e0de23040b26c3bf9d3758b3c8ee0db6516edab9d25d64beca6ddde4c039d88655349895a1ab15b63c8c2e26f3fedbf2ef9f9c14ce5a86149aa75374c24cd5f
EBUILD prismlauncher-5.0.ebuild 3748 BLAKE2B 2095fce9e13b6880692a0afcc4b3ad03c0c2fa5a007db7d243bd2a7bc0657a43e7b24078953c0a931992ce923f3b1e7020775b1cdd1d8fccded1259c866f6d3a SHA512 27d9c94f3aaf3bd5d3783514891565e091de94c70a7ddb85f204edb565846393bc49ca400ccfa28a97b1cfbe8d378f28bf456204a511114411702e66a6c18572
-EBUILD prismlauncher-9999.ebuild 3741 BLAKE2B 4facddb38ff1f040831322895a45c18fb07f0da96040e041a7875345d696026cb480c74708e78c28c46d7f4bc3f536ea492769d5359b3eb95cc26d94feeaa801 SHA512 9f4a54647663cdeddd6d98846d507a39c2cd63f52758e83031cd5785ebd2b2242ba98dd7f72f7c0a2e9b2d714a9cea8787dd856c7cc4d0ce42d63d9e8590d148
+EBUILD prismlauncher-5.1.ebuild 3725 BLAKE2B 4d700eed137ef309b44e07c84743d22d67da69598717a03b4753844959f2a5a4c840fb8d72ea1b0b693e20970683793b517b14202483431afbf1c73f29cd72e9 SHA512 d7faf9bd18f9cac15b632e96171db09cf1a8eb40369955b44576cdb51c07285bbdeaa93f2f0560fd4935763a32f54b2edf49f96462121da54c36095207b1357f
+EBUILD prismlauncher-9999.ebuild 3725 BLAKE2B 4d700eed137ef309b44e07c84743d22d67da69598717a03b4753844959f2a5a4c840fb8d72ea1b0b693e20970683793b517b14202483431afbf1c73f29cd72e9 SHA512 d7faf9bd18f9cac15b632e96171db09cf1a8eb40369955b44576cdb51c07285bbdeaa93f2f0560fd4935763a32f54b2edf49f96462121da54c36095207b1357f
MISC metadata.xml 1084 BLAKE2B 7def85b6f71b9b18fc987e89c3c2c3e32eaef060183e05a1be179eefe322258c7f83c84066e7300df87c62857e66c2499943db960f45e6532d803b671aa028b9 SHA512 0f893adce9d7b7b259226da5047b594774930afbf25d5a933dbfc9d7247380ae255b97d765ef0b07814101cd017c3c4852131d2f38b57acae0961b4b4606da0e
diff --git a/games-action/prismlauncher/prismlauncher-5.1.ebuild b/games-action/prismlauncher/prismlauncher-5.1.ebuild
new file mode 100644
index 000000000000..ad60b690649f
--- /dev/null
+++ b/games-action/prismlauncher/prismlauncher-5.1.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake java-pkg-2 optfeature xdg
+
+HOMEPAGE="https://prismlauncher.org/ https://github.com/PrismLauncher/PrismLauncher"
+DESCRIPTION="A custom, open source Minecraft launcher"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="
+ https://github.com/PrismLauncher/PrismLauncher
+ "
+
+ # TODO: Add tomlplusplus as a system library, like quazip
+ EGIT_SUBMODULES=( '*' '-libraries/quazip' '-libraries/filesystem' )
+else
+ MY_PN="PrismLauncher"
+
+ # Let's use the vendored tarball to avoid dealing with the submodules directly
+ SRC_URI="
+ https://github.com/PrismLauncher/PrismLauncher/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
+ "
+
+ # The Prism's files are unpacked to ${WORKDIR}/PrismLauncher-${PV}
+ S="${WORKDIR}/${MY_PN}-${PV}"
+
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+# GPL-3 for PolyMC (PrismLauncher is forked from it) and Prism itself
+# Apache-2.0 for MultiMC (PolyMC is forked from it)
+# LGPL-3+ for libnbtplusplus
+# MIT for tomlplusplus
+# See the rest of PrismLauncher's libraries at https://github.com/PrismLauncher/PrismLauncher/tree/develop/libraries
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2+ GPL-3 ISC LGPL-2.1+ LGPL-3+ MIT"
+
+SLOT="0"
+
+IUSE="debug lto qt6 test"
+REQUIRED_USE="
+ lto? ( !debug )
+"
+
+RESTRICT="!test? ( test )"
+
+MIN_QT_5_VERSION="5.12.0"
+MIN_QT_6_VERSION="6.0.0"
+
+QT_DEPS="
+ !qt6? (
+ >=dev-qt/qtconcurrent-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtcore-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtgui-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtnetwork-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qttest-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtwidgets-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtxml-${MIN_QT_5_VERSION}:5
+ )
+
+ qt6? (
+ >=dev-qt/qtbase-${MIN_QT_6_VERSION}:6[concurrent,gui,network,widgets,xml(+)]
+ >=dev-qt/qt5compat-${MIN_QT_6_VERSION}:6
+ )
+"
+
+# Required at both build-time and run-time
+COMMON_DEPENDS="
+ ${QT_DEPS}
+
+ !qt6? ( >=dev-libs/quazip-1.3:=[qt5(+)] )
+ qt6? ( >=dev-libs/quazip-1.3:=[qt6(-)] )
+
+ sys-libs/zlib
+"
+
+# The gulrak-filesystem dependency is only needed at build time, because we don't actually use it on Linux,
+# only on legacy macOS. Still, we need it present at build time to appease CMake, and having it like this
+# makes it easier to maintain than patching the CMakeLists file directly.
+BDEPEND="
+ app-text/scdoc
+ dev-cpp/gulrak-filesystem
+ kde-frameworks/extra-cmake-modules:5
+"
+
+DEPEND="
+ ${COMMON_DEPENDS}
+ media-libs/libglvnd
+ >=virtual/jdk-1.8.0:*
+"
+
+# At run-time we don't depend on JDK, only JRE
+# And we need more than just the GL headers
+RDEPEND="
+ ${COMMON_DEPENDS}
+
+ !qt6? ( >=dev-qt/qtsvg-${MIN_QT_5_VERSION}:5 )
+ qt6? ( >=dev-qt/qtsvg-${MIN_QT_6_VERSION}:6 )
+
+ >=virtual/jre-1.8.0:*
+ virtual/opengl
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Prevent conflicting with the user's flags
+ # See https://bugs.gentoo.org/848765 for more info
+ sed -i -e 's/-Werror//' -e 's/-D_FORTIFY_SOURCE=2//' CMakeLists.txt || die 'Failed to remove -Werror and -D_FORTIFY_SOURCE via sed'
+}
+
+src_configure(){
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ # Resulting binary is named prismlauncher
+ -DLauncher_APP_BINARY_NAME="${PN}"
+ -DLauncher_QT_VERSION_MAJOR=$(usex qt6 6 5)
+
+ -DENABLE_LTO=$(usex lto)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ if use debug; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ cmake_src_configure
+}
+
+src_compile(){
+ cmake_src_compile
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Original issue: https://github.com/PolyMC/PolyMC/issues/227
+ optfeature "old Minecraft (<= 1.12.2) support" x11-apps/xrandr
+
+ optfeature "built-in MangoHud support" games-util/mangohud
+ optfeature "built-in Feral Gamemode support" games-util/gamemode
+}
diff --git a/games-action/prismlauncher/prismlauncher-9999.ebuild b/games-action/prismlauncher/prismlauncher-9999.ebuild
index 1de25bc2a4f4..ad60b690649f 100644
--- a/games-action/prismlauncher/prismlauncher-9999.ebuild
+++ b/games-action/prismlauncher/prismlauncher-9999.ebuild
@@ -28,7 +28,7 @@ else
# The Prism's files are unpacked to ${WORKDIR}/PrismLauncher-${PV}
S="${WORKDIR}/${MY_PN}-${PV}"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm64"
fi
# GPL-3 for PolyMC (PrismLauncher is forked from it) and Prism itself
@@ -97,8 +97,6 @@ DEPEND="
RDEPEND="
${COMMON_DEPENDS}
- !games-action/polymc
-
!qt6? ( >=dev-qt/qtsvg-${MIN_QT_5_VERSION}:5 )
qt6? ( >=dev-qt/qtsvg-${MIN_QT_6_VERSION}:6 )