summaryrefslogtreecommitdiff
path: root/games-action/prismlauncher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-20 07:59:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-20 07:59:50 +0100
commit2eda3a3b8ebdb3fc8552feb6f49e466d3bc8e88c (patch)
tree69a469da2fa8c3f4920325ac5595300929f5d884 /games-action/prismlauncher
parent9ed0c42eb618229fa6f45e10155ee535e1f605a2 (diff)
gentoo auto-resync : 20:10:2022 - 07:59:49
Diffstat (limited to 'games-action/prismlauncher')
-rw-r--r--games-action/prismlauncher/Manifest4
-rw-r--r--games-action/prismlauncher/metadata.xml26
-rw-r--r--games-action/prismlauncher/prismlauncher-5.0.ebuild149
-rw-r--r--games-action/prismlauncher/prismlauncher-9999.ebuild149
4 files changed, 328 insertions, 0 deletions
diff --git a/games-action/prismlauncher/Manifest b/games-action/prismlauncher/Manifest
new file mode 100644
index 000000000000..2b462b4b9576
--- /dev/null
+++ b/games-action/prismlauncher/Manifest
@@ -0,0 +1,4 @@
+DIST prismlauncher-5.0.tar.gz 9379431 BLAKE2B 0406b0e706068d32eaed427c5475b1388144b6155a69cf29674e7b45de84c86ca872615b6ec64602e942f155061630c7a866800e24ccb7546c2a32bf298380cf SHA512 71f19603a2e09d581ed80bbef6a3cd4a2c3081ba820fad8d73ebab155075d7a84e17ce9f70490a8984e7cb6a5d35089efb77bb5c364c4580fe4a8759fa79313d
+EBUILD prismlauncher-5.0.ebuild 3741 BLAKE2B 4facddb38ff1f040831322895a45c18fb07f0da96040e041a7875345d696026cb480c74708e78c28c46d7f4bc3f536ea492769d5359b3eb95cc26d94feeaa801 SHA512 9f4a54647663cdeddd6d98846d507a39c2cd63f52758e83031cd5785ebd2b2242ba98dd7f72f7c0a2e9b2d714a9cea8787dd856c7cc4d0ce42d63d9e8590d148
+EBUILD prismlauncher-9999.ebuild 3741 BLAKE2B 4facddb38ff1f040831322895a45c18fb07f0da96040e041a7875345d696026cb480c74708e78c28c46d7f4bc3f536ea492769d5359b3eb95cc26d94feeaa801 SHA512 9f4a54647663cdeddd6d98846d507a39c2cd63f52758e83031cd5785ebd2b2242ba98dd7f72f7c0a2e9b2d714a9cea8787dd856c7cc4d0ce42d63d9e8590d148
+MISC metadata.xml 1084 BLAKE2B 7def85b6f71b9b18fc987e89c3c2c3e32eaef060183e05a1be179eefe322258c7f83c84066e7300df87c62857e66c2499943db960f45e6532d803b671aa028b9 SHA512 0f893adce9d7b7b259226da5047b594774930afbf25d5a933dbfc9d7247380ae255b97d765ef0b07814101cd017c3c4852131d2f38b57acae0961b4b4606da0e
diff --git a/games-action/prismlauncher/metadata.xml b/games-action/prismlauncher/metadata.xml
new file mode 100644
index 000000000000..f54dc7d44a8d
--- /dev/null
+++ b/games-action/prismlauncher/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>flowlnlnln@gmail.com</email>
+ <name>Thiago Donato Ferreira</name>
+ </maintainer>
+ <maintainer type="person" proxied="proxy">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/PrismLauncher/PrismLauncher/issues</bugs-to>
+ <doc>https://prismlauncher.org/wiki/</doc>
+ <remote-id type="github">PrismLauncher/PrismLauncher</remote-id>
+ </upstream>
+ <longdescription>Prism Launcher is a multi-instance Minecraft launcher focused on user freedom, redistributability, and simplicity.</longdescription>
+ <use>
+ <flag name="lto">Enable link-time optimization</flag>
+ <flag name="qt6">Build with Qt6 support instead of the default Qt5</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-action/prismlauncher/prismlauncher-5.0.ebuild b/games-action/prismlauncher/prismlauncher-5.0.ebuild
new file mode 100644
index 000000000000..1de25bc2a4f4
--- /dev/null
+++ b/games-action/prismlauncher/prismlauncher-5.0.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake java-pkg-2 optfeature xdg
+
+HOMEPAGE="https://prismlauncher.org/ https://github.com/PrismLauncher/PrismLauncher"
+DESCRIPTION="A custom, open source Minecraft launcher"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="
+ https://github.com/PrismLauncher/PrismLauncher
+ "
+
+ # TODO: Add tomlplusplus as a system library, like quazip
+ EGIT_SUBMODULES=( '*' '-libraries/quazip' '-libraries/filesystem' )
+else
+ MY_PN="PrismLauncher"
+
+ # Let's use the vendored tarball to avoid dealing with the submodules directly
+ SRC_URI="
+ https://github.com/PrismLauncher/PrismLauncher/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
+ "
+
+ # The Prism's files are unpacked to ${WORKDIR}/PrismLauncher-${PV}
+ S="${WORKDIR}/${MY_PN}-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+# GPL-3 for PolyMC (PrismLauncher is forked from it) and Prism itself
+# Apache-2.0 for MultiMC (PolyMC is forked from it)
+# LGPL-3+ for libnbtplusplus
+# MIT for tomlplusplus
+# See the rest of PrismLauncher's libraries at https://github.com/PrismLauncher/PrismLauncher/tree/develop/libraries
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2+ GPL-3 ISC LGPL-2.1+ LGPL-3+ MIT"
+
+SLOT="0"
+
+IUSE="debug lto qt6 test"
+REQUIRED_USE="
+ lto? ( !debug )
+"
+
+RESTRICT="!test? ( test )"
+
+MIN_QT_5_VERSION="5.12.0"
+MIN_QT_6_VERSION="6.0.0"
+
+QT_DEPS="
+ !qt6? (
+ >=dev-qt/qtconcurrent-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtcore-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtgui-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtnetwork-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qttest-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtwidgets-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtxml-${MIN_QT_5_VERSION}:5
+ )
+
+ qt6? (
+ >=dev-qt/qtbase-${MIN_QT_6_VERSION}:6[concurrent,gui,network,widgets,xml(+)]
+ >=dev-qt/qt5compat-${MIN_QT_6_VERSION}:6
+ )
+"
+
+# Required at both build-time and run-time
+COMMON_DEPENDS="
+ ${QT_DEPS}
+
+ !qt6? ( >=dev-libs/quazip-1.3:=[qt5(+)] )
+ qt6? ( >=dev-libs/quazip-1.3:=[qt6(-)] )
+
+ sys-libs/zlib
+"
+
+# The gulrak-filesystem dependency is only needed at build time, because we don't actually use it on Linux,
+# only on legacy macOS. Still, we need it present at build time to appease CMake, and having it like this
+# makes it easier to maintain than patching the CMakeLists file directly.
+BDEPEND="
+ app-text/scdoc
+ dev-cpp/gulrak-filesystem
+ kde-frameworks/extra-cmake-modules:5
+"
+
+DEPEND="
+ ${COMMON_DEPENDS}
+ media-libs/libglvnd
+ >=virtual/jdk-1.8.0:*
+"
+
+# At run-time we don't depend on JDK, only JRE
+# And we need more than just the GL headers
+RDEPEND="
+ ${COMMON_DEPENDS}
+
+ !games-action/polymc
+
+ !qt6? ( >=dev-qt/qtsvg-${MIN_QT_5_VERSION}:5 )
+ qt6? ( >=dev-qt/qtsvg-${MIN_QT_6_VERSION}:6 )
+
+ >=virtual/jre-1.8.0:*
+ virtual/opengl
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Prevent conflicting with the user's flags
+ # See https://bugs.gentoo.org/848765 for more info
+ sed -i -e 's/-Werror//' -e 's/-D_FORTIFY_SOURCE=2//' CMakeLists.txt || die 'Failed to remove -Werror and -D_FORTIFY_SOURCE via sed'
+}
+
+src_configure(){
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ # Resulting binary is named prismlauncher
+ -DLauncher_APP_BINARY_NAME="${PN}"
+ -DLauncher_QT_VERSION_MAJOR=$(usex qt6 6 5)
+
+ -DENABLE_LTO=$(usex lto)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ if use debug; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ cmake_src_configure
+}
+
+src_compile(){
+ cmake_src_compile
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Original issue: https://github.com/PolyMC/PolyMC/issues/227
+ optfeature "old Minecraft (<= 1.12.2) support" x11-apps/xrandr
+
+ optfeature "built-in MangoHud support" games-util/mangohud
+ optfeature "built-in Feral Gamemode support" games-util/gamemode
+}
diff --git a/games-action/prismlauncher/prismlauncher-9999.ebuild b/games-action/prismlauncher/prismlauncher-9999.ebuild
new file mode 100644
index 000000000000..1de25bc2a4f4
--- /dev/null
+++ b/games-action/prismlauncher/prismlauncher-9999.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake java-pkg-2 optfeature xdg
+
+HOMEPAGE="https://prismlauncher.org/ https://github.com/PrismLauncher/PrismLauncher"
+DESCRIPTION="A custom, open source Minecraft launcher"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="
+ https://github.com/PrismLauncher/PrismLauncher
+ "
+
+ # TODO: Add tomlplusplus as a system library, like quazip
+ EGIT_SUBMODULES=( '*' '-libraries/quazip' '-libraries/filesystem' )
+else
+ MY_PN="PrismLauncher"
+
+ # Let's use the vendored tarball to avoid dealing with the submodules directly
+ SRC_URI="
+ https://github.com/PrismLauncher/PrismLauncher/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
+ "
+
+ # The Prism's files are unpacked to ${WORKDIR}/PrismLauncher-${PV}
+ S="${WORKDIR}/${MY_PN}-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+# GPL-3 for PolyMC (PrismLauncher is forked from it) and Prism itself
+# Apache-2.0 for MultiMC (PolyMC is forked from it)
+# LGPL-3+ for libnbtplusplus
+# MIT for tomlplusplus
+# See the rest of PrismLauncher's libraries at https://github.com/PrismLauncher/PrismLauncher/tree/develop/libraries
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2+ GPL-3 ISC LGPL-2.1+ LGPL-3+ MIT"
+
+SLOT="0"
+
+IUSE="debug lto qt6 test"
+REQUIRED_USE="
+ lto? ( !debug )
+"
+
+RESTRICT="!test? ( test )"
+
+MIN_QT_5_VERSION="5.12.0"
+MIN_QT_6_VERSION="6.0.0"
+
+QT_DEPS="
+ !qt6? (
+ >=dev-qt/qtconcurrent-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtcore-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtgui-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtnetwork-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qttest-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtwidgets-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtxml-${MIN_QT_5_VERSION}:5
+ )
+
+ qt6? (
+ >=dev-qt/qtbase-${MIN_QT_6_VERSION}:6[concurrent,gui,network,widgets,xml(+)]
+ >=dev-qt/qt5compat-${MIN_QT_6_VERSION}:6
+ )
+"
+
+# Required at both build-time and run-time
+COMMON_DEPENDS="
+ ${QT_DEPS}
+
+ !qt6? ( >=dev-libs/quazip-1.3:=[qt5(+)] )
+ qt6? ( >=dev-libs/quazip-1.3:=[qt6(-)] )
+
+ sys-libs/zlib
+"
+
+# The gulrak-filesystem dependency is only needed at build time, because we don't actually use it on Linux,
+# only on legacy macOS. Still, we need it present at build time to appease CMake, and having it like this
+# makes it easier to maintain than patching the CMakeLists file directly.
+BDEPEND="
+ app-text/scdoc
+ dev-cpp/gulrak-filesystem
+ kde-frameworks/extra-cmake-modules:5
+"
+
+DEPEND="
+ ${COMMON_DEPENDS}
+ media-libs/libglvnd
+ >=virtual/jdk-1.8.0:*
+"
+
+# At run-time we don't depend on JDK, only JRE
+# And we need more than just the GL headers
+RDEPEND="
+ ${COMMON_DEPENDS}
+
+ !games-action/polymc
+
+ !qt6? ( >=dev-qt/qtsvg-${MIN_QT_5_VERSION}:5 )
+ qt6? ( >=dev-qt/qtsvg-${MIN_QT_6_VERSION}:6 )
+
+ >=virtual/jre-1.8.0:*
+ virtual/opengl
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Prevent conflicting with the user's flags
+ # See https://bugs.gentoo.org/848765 for more info
+ sed -i -e 's/-Werror//' -e 's/-D_FORTIFY_SOURCE=2//' CMakeLists.txt || die 'Failed to remove -Werror and -D_FORTIFY_SOURCE via sed'
+}
+
+src_configure(){
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ # Resulting binary is named prismlauncher
+ -DLauncher_APP_BINARY_NAME="${PN}"
+ -DLauncher_QT_VERSION_MAJOR=$(usex qt6 6 5)
+
+ -DENABLE_LTO=$(usex lto)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ if use debug; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ cmake_src_configure
+}
+
+src_compile(){
+ cmake_src_compile
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Original issue: https://github.com/PolyMC/PolyMC/issues/227
+ optfeature "old Minecraft (<= 1.12.2) support" x11-apps/xrandr
+
+ optfeature "built-in MangoHud support" games-util/mangohud
+ optfeature "built-in Feral Gamemode support" games-util/gamemode
+}