summaryrefslogtreecommitdiff
path: root/games-action/postalplus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/postalplus
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/postalplus')
-rw-r--r--games-action/postalplus/Manifest2
-rw-r--r--games-action/postalplus/metadata.xml8
-rw-r--r--games-action/postalplus/postalplus-1-r1.ebuild35
3 files changed, 45 insertions, 0 deletions
diff --git a/games-action/postalplus/Manifest b/games-action/postalplus/Manifest
new file mode 100644
index 000000000000..5c6536dec6ae
--- /dev/null
+++ b/games-action/postalplus/Manifest
@@ -0,0 +1,2 @@
+EBUILD postalplus-1-r1.ebuild 821 BLAKE2B 751b7928b33ddfa68f752ccb0d1c2ac356df5ad7fa5dc0a49bd908564d4fea70d9f408e2295d68443c09f2859910d581373d4245ba08328ebf5b8705f5f0f59b SHA512 709242ec1096a0041ebecf97e890e6aef0561536efdabe6dda665c0fe7e9841568ee681fc543391419741837f55ad45cadce588ef73ccf4e2bb128f84b3a67df
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-action/postalplus/metadata.xml b/games-action/postalplus/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-action/postalplus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-action/postalplus/postalplus-1-r1.ebuild b/games-action/postalplus/postalplus-1-r1.ebuild
new file mode 100644
index 000000000000..569d32f5fa13
--- /dev/null
+++ b/games-action/postalplus/postalplus-1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils cdrom
+
+DESCRIPTION="Ultraviolent and controversial game featuring the Postal Dude"
+HOMEPAGE="http://www.lokigames.com/products/postal/"
+SRC_URI=""
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="strip"
+
+S=${WORKDIR}
+
+src_install() {
+ local dir=/opt/${PN}
+
+ cdrom_get_cds postal_plus.ini
+ exeinto "${dir}"
+ doexe "${CDROM_ROOT}"/bin/x86/postal
+ insinto "${dir}"
+ doins "${CDROM_ROOT}"/{icon.{bmp,xpm},postal_plus.ini,README}
+ cp "${CDROM_ROOT}"/icon.xpm ${PN}.xpm || die
+
+ cp -r "${CDROM_ROOT}"/res "${D}${dir}" || die
+ find "${D}" -name TRANS.TBL -exec rm '{}' + || die
+
+ make_wrapper ${PN} ./postal "${dir}"
+ doicon ${PN}.xpm
+ make_desktop_entry ${PN} "Postal Plus" ${PN}
+}