summaryrefslogtreecommitdiff
path: root/games-action/postalplus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-action/postalplus
reinit the tree, so we can have metadata
Diffstat (limited to 'games-action/postalplus')
-rw-r--r--games-action/postalplus/Manifest5
-rw-r--r--games-action/postalplus/metadata.xml8
-rw-r--r--games-action/postalplus/postalplus-1-r1.ebuild35
-rw-r--r--games-action/postalplus/postalplus-1.ebuild37
4 files changed, 85 insertions, 0 deletions
diff --git a/games-action/postalplus/Manifest b/games-action/postalplus/Manifest
new file mode 100644
index 000000000000..147eeb1b36b7
--- /dev/null
+++ b/games-action/postalplus/Manifest
@@ -0,0 +1,5 @@
+EBUILD postalplus-1-r1.ebuild 821 SHA256 0b743a8f5e50e615b9a1800f0a712c7fe874ffb77ce6f461371504fdfab3309c SHA512 709242ec1096a0041ebecf97e890e6aef0561536efdabe6dda665c0fe7e9841568ee681fc543391419741837f55ad45cadce588ef73ccf4e2bb128f84b3a67df WHIRLPOOL a294f8e787a99447bed2e1d613ad8150a2c3a2e2b28ddcb588e2ebe30f8f2898ebb47865ad942a433bbc1c09580666d4387f99435136c29c6bfac83690268f29
+EBUILD postalplus-1.ebuild 857 SHA256 dd8021b45c685f7ed2032ecdc47b38ff57d0d229d828425b999a8a93da83a71e SHA512 d86af0dc954016dcaa6c3b4c84496490c9471996f991a39765ca6be6e3f2266f3686986b75968bf51a287d69ddd30bbc5d897f4f844a0dd44d8745951ea98569 WHIRLPOOL f3796227a1634f5eb5f86e0dc86abfef00aca31e1d040937f72a76b05b3d4e84084873091c8bb649f897573cdd98b6b1905bc85eea51b205b7fca06110834ae8
+MISC ChangeLog 2432 SHA256 552ee8957ed5569887a3262118d4ec9e093317bbbbb08ee80a6524872c6ec469 SHA512 8e6b13ad9deca25bc9a527828c03e2c6c934c230ab1bcb0d07982a97dfef9018f4e1dc576f57a547a8f9857bf6d72ab50d8a7629e396330bb05eef97acad8e05 WHIRLPOOL f03a07a2cdc150d109b230fa655b39476c354661502840727f622638ed8a967b2dcc78e5cdf4b48b873f0cfe5ae06fdc3bde41bc01742462f0907a4bb5fc6c17
+MISC ChangeLog-2015 802 SHA256 d5a22b481fbb3277d0d580b3022b0145b2d52cb74a9f6488707691f5d1a9f9b8 SHA512 3def56e70252cd54c02d6e3b903e427c5ee416d0cec2572dbef5f36b2ac6d9d4d5bab8e2d040253d073f5fc70cdd32198eddb726f3a269b71431c97312d5d3fe WHIRLPOOL fcdfe7705c6a4991dc0746d4fa92834d1aa7a447b9faa4030a66506f255004c6e658f836d9242730827d785c8e3e34f445076d7fc64e063f4a3335f4b31d389d
+MISC metadata.xml 249 SHA256 943b9ce0cd072229b43569ab668dd7ec741d9dfefd942c8921dabd4490b27b0c SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118 WHIRLPOOL b10e21575c78e201a652c8582cd16e3f7c86b13dd20a30f4cea44066fb139440b3c186147dbaae83478f11a20b6f457a99c8b29ee1239a4caaa21eee01250088
diff --git a/games-action/postalplus/metadata.xml b/games-action/postalplus/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-action/postalplus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-action/postalplus/postalplus-1-r1.ebuild b/games-action/postalplus/postalplus-1-r1.ebuild
new file mode 100644
index 000000000000..569d32f5fa13
--- /dev/null
+++ b/games-action/postalplus/postalplus-1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils cdrom
+
+DESCRIPTION="Ultraviolent and controversial game featuring the Postal Dude"
+HOMEPAGE="http://www.lokigames.com/products/postal/"
+SRC_URI=""
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="strip"
+
+S=${WORKDIR}
+
+src_install() {
+ local dir=/opt/${PN}
+
+ cdrom_get_cds postal_plus.ini
+ exeinto "${dir}"
+ doexe "${CDROM_ROOT}"/bin/x86/postal
+ insinto "${dir}"
+ doins "${CDROM_ROOT}"/{icon.{bmp,xpm},postal_plus.ini,README}
+ cp "${CDROM_ROOT}"/icon.xpm ${PN}.xpm || die
+
+ cp -r "${CDROM_ROOT}"/res "${D}${dir}" || die
+ find "${D}" -name TRANS.TBL -exec rm '{}' + || die
+
+ make_wrapper ${PN} ./postal "${dir}"
+ doicon ${PN}.xpm
+ make_desktop_entry ${PN} "Postal Plus" ${PN}
+}
diff --git a/games-action/postalplus/postalplus-1.ebuild b/games-action/postalplus/postalplus-1.ebuild
new file mode 100644
index 000000000000..eb18db26279c
--- /dev/null
+++ b/games-action/postalplus/postalplus-1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils cdrom games
+
+DESCRIPTION="Ultraviolent and controversial game featuring the Postal Dude"
+HOMEPAGE="http://www.lokigames.com/products/postal/"
+SRC_URI=""
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="strip"
+
+S=${WORKDIR}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ cdrom_get_cds postal_plus.ini
+ exeinto "${dir}"
+ doexe "${CDROM_ROOT}"/bin/x86/postal
+ insinto "${dir}"
+ doins "${CDROM_ROOT}"/{icon.{bmp,xpm},postal_plus.ini,README}
+ cp "${CDROM_ROOT}"/icon.xpm ${PN}.xpm || die
+
+ cp -r "${CDROM_ROOT}"/res "${D}${dir}" || die
+ find "${D}" -name TRANS.TBL -exec rm '{}' +
+
+ games_make_wrapper ${PN} ./postal "${dir}"
+ doicon ${PN}.xpm
+ make_desktop_entry ${PN} "Postal Plus" ${PN}
+
+ prepgamesdirs
+}