summaryrefslogtreecommitdiff
path: root/games-action/polymc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /games-action/polymc
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'games-action/polymc')
-rw-r--r--games-action/polymc/Manifest4
-rw-r--r--games-action/polymc/metadata.xml26
-rw-r--r--games-action/polymc/polymc-1.1.1.ebuild108
-rw-r--r--games-action/polymc/polymc-9999.ebuild108
4 files changed, 246 insertions, 0 deletions
diff --git a/games-action/polymc/Manifest b/games-action/polymc/Manifest
new file mode 100644
index 000000000000..83c7ff3d6f46
--- /dev/null
+++ b/games-action/polymc/Manifest
@@ -0,0 +1,4 @@
+DIST polymc-1.1.1.tar.gz 5116164 BLAKE2B ca251cac3c8ea21de8a59297a0e637dac078d751476fec5fe86696df270c63ff079779056f016fa656506ea205bb7ace50ab6e0df190ffca14e43297b92292af SHA512 db32479e9e8a92ec61292c97281673b3084e1085d29b764214834de872d9eddf2ed1d2e383bcd79197e0c9321eec025af652b12c863596ff6abb0f5fba9a7af5
+EBUILD polymc-1.1.1.ebuild 2317 BLAKE2B d7862396b8af84cad3baca0415871f66a9012e8844d4207c144f380f493be5da8467f93b5ff40439134c8189157e610ff160497354b670cd1a77894c5c33a180 SHA512 cdce37a46ef2b4eee61e00e5cf6994909f1b46fff23dba07e68fb9ef5723b5f80c45c66162f8461ccd787c9c99a1999b99d74e6e02306dc1df8b857a8d77c4fd
+EBUILD polymc-9999.ebuild 2317 BLAKE2B d7862396b8af84cad3baca0415871f66a9012e8844d4207c144f380f493be5da8467f93b5ff40439134c8189157e610ff160497354b670cd1a77894c5c33a180 SHA512 cdce37a46ef2b4eee61e00e5cf6994909f1b46fff23dba07e68fb9ef5723b5f80c45c66162f8461ccd787c9c99a1999b99d74e6e02306dc1df8b857a8d77c4fd
+MISC metadata.xml 1013 BLAKE2B 350e90c59ce4e58fe013474a158b33688afbaa988d9749cecb1765689ce5a5c98cc8eda808bd6d8483ecdb7246ef0ab6c0112cd7b45e95dff9b2c3f6b3bc3f41 SHA512 2e152d4cabdf02bddc25854d03a38c06e1440ab0c400582b6ed5b8fb1b932e1968465bd54bea66f32988d7a721a67719a9513d2ae641e11f70557a9b62a80e45
diff --git a/games-action/polymc/metadata.xml b/games-action/polymc/metadata.xml
new file mode 100644
index 000000000000..78a705414ef3
--- /dev/null
+++ b/games-action/polymc/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>flowlnlnln@gmail.com</email>
+ <name>Thiago Donato Ferreira</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>swurl@swurl.xyz</email>
+ <name>Carson Rueter</name>
+ </maintainer>
+ <maintainer type="person" proxied="proxy">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/PolyMC/PolyMC/issues</bugs-to>
+ <doc>https://polymc.org/wiki/</doc>
+ <remote-id type="github">PolyMC/PolyMC</remote-id>
+ </upstream>
+ <longdescription>PolyMC is a multi-instance Minecraft launcher focused on user freedom, redistributability, and simplicity.</longdescription>
+</pkgmetadata>
diff --git a/games-action/polymc/polymc-1.1.1.ebuild b/games-action/polymc/polymc-1.1.1.ebuild
new file mode 100644
index 000000000000..d036cb15c635
--- /dev/null
+++ b/games-action/polymc/polymc-1.1.1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake java-pkg-2 optfeature xdg
+
+HOMEPAGE="https://polymc.org/ https://github.com/PolyMC/PolyMC"
+DESCRIPTION="A custom, open source Minecraft launcher"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="
+ https://github.com/PolyMC/PolyMC
+ https://github.com/MultiMC/libnbtplusplus
+ https://github.com/stachenov/quazip
+ "
+
+ # Include all submodules
+ EGIT_SUBMODULES=( '*' )
+else
+ MY_PN="PolyMC"
+
+ # Let's use the vendored tarball to avoid dealing with the submodules directly
+ SRC_URI="
+ https://github.com/PolyMC/PolyMC/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
+ "
+
+ # The PolyMC's files are unpacked to ${WORKDIR}/PolyMC-${PV}
+ S="${WORKDIR}/${MY_PN}-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+# Apache-2.0 for MultiMC (PolyMC is forked from it)
+# GPL-3 for PolyMC
+# LGPL-3 for libnbtplusplus
+# LGPL-2.1 with linking exception for Quazip
+# See the rest of PolyMC's libraries at https://github.com/PolyMC/PolyMC/tree/develop/libraries
+LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 LGPL-2.1-with-linking-exception OFL-1.1 MIT"
+
+SLOT="0"
+
+IUSE="debug"
+
+MIN_QT="5.6.0"
+
+QT_DEPS="
+ >=dev-qt/qtconcurrent-${MIN_QT}:5
+ >=dev-qt/qtcore-${MIN_QT}:5
+ >=dev-qt/qtgui-${MIN_QT}:5
+ >=dev-qt/qtnetwork-${MIN_QT}:5
+ >=dev-qt/qttest-${MIN_QT}:5
+ >=dev-qt/qtwidgets-${MIN_QT}:5
+ >=dev-qt/qtxml-${MIN_QT}:5
+"
+
+DEPEND="
+ ${QT_DEPS}
+ media-libs/libglvnd
+ sys-libs/zlib
+ >=virtual/jdk-1.8.0:*
+"
+
+# At run-time we don't depend on JDK, only JRE
+# And we need more than just the GL headers
+RDEPEND="
+ ${QT_DEPS}
+ sys-libs/zlib
+ >=virtual/jre-1.8.0:*
+ virtual/opengl
+"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure(){
+ if use debug; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ # Prepare for LTO in 1.2.0 (?)
+ # See https://github.com/PolyMC/PolyMC/pull/333
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ local mycmakeargs=(
+ # Do a system install
+ -DLauncher_PORTABLE=0
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ # Resulting binary is named polymc
+ -DLauncher_APP_BINARY_NAME="${PN}"
+ )
+
+ cmake_src_configure
+}
+
+src_compile(){
+ cmake_src_compile
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # https://github.com/PolyMC/PolyMC/issues/227
+ optfeature "old Minecraft (<= 1.12.2) support" x11-libs/libXrandr
+}
diff --git a/games-action/polymc/polymc-9999.ebuild b/games-action/polymc/polymc-9999.ebuild
new file mode 100644
index 000000000000..d036cb15c635
--- /dev/null
+++ b/games-action/polymc/polymc-9999.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake java-pkg-2 optfeature xdg
+
+HOMEPAGE="https://polymc.org/ https://github.com/PolyMC/PolyMC"
+DESCRIPTION="A custom, open source Minecraft launcher"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="
+ https://github.com/PolyMC/PolyMC
+ https://github.com/MultiMC/libnbtplusplus
+ https://github.com/stachenov/quazip
+ "
+
+ # Include all submodules
+ EGIT_SUBMODULES=( '*' )
+else
+ MY_PN="PolyMC"
+
+ # Let's use the vendored tarball to avoid dealing with the submodules directly
+ SRC_URI="
+ https://github.com/PolyMC/PolyMC/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
+ "
+
+ # The PolyMC's files are unpacked to ${WORKDIR}/PolyMC-${PV}
+ S="${WORKDIR}/${MY_PN}-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+# Apache-2.0 for MultiMC (PolyMC is forked from it)
+# GPL-3 for PolyMC
+# LGPL-3 for libnbtplusplus
+# LGPL-2.1 with linking exception for Quazip
+# See the rest of PolyMC's libraries at https://github.com/PolyMC/PolyMC/tree/develop/libraries
+LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 LGPL-2.1-with-linking-exception OFL-1.1 MIT"
+
+SLOT="0"
+
+IUSE="debug"
+
+MIN_QT="5.6.0"
+
+QT_DEPS="
+ >=dev-qt/qtconcurrent-${MIN_QT}:5
+ >=dev-qt/qtcore-${MIN_QT}:5
+ >=dev-qt/qtgui-${MIN_QT}:5
+ >=dev-qt/qtnetwork-${MIN_QT}:5
+ >=dev-qt/qttest-${MIN_QT}:5
+ >=dev-qt/qtwidgets-${MIN_QT}:5
+ >=dev-qt/qtxml-${MIN_QT}:5
+"
+
+DEPEND="
+ ${QT_DEPS}
+ media-libs/libglvnd
+ sys-libs/zlib
+ >=virtual/jdk-1.8.0:*
+"
+
+# At run-time we don't depend on JDK, only JRE
+# And we need more than just the GL headers
+RDEPEND="
+ ${QT_DEPS}
+ sys-libs/zlib
+ >=virtual/jre-1.8.0:*
+ virtual/opengl
+"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure(){
+ if use debug; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ # Prepare for LTO in 1.2.0 (?)
+ # See https://github.com/PolyMC/PolyMC/pull/333
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ local mycmakeargs=(
+ # Do a system install
+ -DLauncher_PORTABLE=0
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ # Resulting binary is named polymc
+ -DLauncher_APP_BINARY_NAME="${PN}"
+ )
+
+ cmake_src_configure
+}
+
+src_compile(){
+ cmake_src_compile
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # https://github.com/PolyMC/PolyMC/issues/227
+ optfeature "old Minecraft (<= 1.12.2) support" x11-libs/libXrandr
+}