summaryrefslogtreecommitdiff
path: root/games-action/mutantstorm-demo/mutantstorm-demo-1.33-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-action/mutantstorm-demo/mutantstorm-demo-1.33-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-action/mutantstorm-demo/mutantstorm-demo-1.33-r1.ebuild')
-rw-r--r--games-action/mutantstorm-demo/mutantstorm-demo-1.33-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-action/mutantstorm-demo/mutantstorm-demo-1.33-r1.ebuild b/games-action/mutantstorm-demo/mutantstorm-demo-1.33-r1.ebuild
new file mode 100644
index 000000000000..c97fee4f7172
--- /dev/null
+++ b/games-action/mutantstorm-demo/mutantstorm-demo-1.33-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils unpacker
+
+DESCRIPTION="shoot through crazy psychedelic 3D environments"
+HOMEPAGE="http://www.pompomgames.com/"
+SRC_URI="ftp://ggdev-1.homelan.com/mutantstorm/MutantStormDemo_${PV/./_}.sh.bin"
+
+LICENSE="POMPOM"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="
+ media-libs/libsdl[abi_x86_32(-)]
+ sys-libs/lib-compat
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=/opt/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/mutantstorm-bin"
+
+src_install() {
+ insinto "${dir}"
+ doins -r menu script styles
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/*
+ # Remove libSDL since we use the system version and our version doesn't
+ # have TEXTRELs in it.
+ rm -f "${Ddir}"/libSDL-1.2.so.0.0.5
+ make_wrapper mutantstorm-demo ./mutantstormdemo "${dir}" "${dir}"
+
+ insinto "${dir}"
+ doins README.txt buy_me mutant.xpm pompom readme.htm
+}