summaryrefslogtreecommitdiff
path: root/games-action/multimc-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /games-action/multimc-bin
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'games-action/multimc-bin')
-rw-r--r--games-action/multimc-bin/Manifest3
-rw-r--r--games-action/multimc-bin/metadata.xml28
-rw-r--r--games-action/multimc-bin/multimc-bin-1.5.1.ebuild48
3 files changed, 79 insertions, 0 deletions
diff --git a/games-action/multimc-bin/Manifest b/games-action/multimc-bin/Manifest
new file mode 100644
index 000000000000..2857e995da0b
--- /dev/null
+++ b/games-action/multimc-bin/Manifest
@@ -0,0 +1,3 @@
+DIST multimc_1.5-1.deb 7692 BLAKE2B c5b4de864c95cccd96b071d4d551e322eb5c78e17a8da361ee69a82405691c6d9fc81c7eef9dcf855a8e2145fbb362d31c7f63682c7a66edbc37dbf9215e7c1b SHA512 26fe11eff406efd09612002e4c53fc1ea0b3f7d0aca389475a7afff454efa52ed52097f6a0bbc27de61fba3fed252321754738a0f79b0d8a7308a39701087e67
+EBUILD multimc-bin-1.5.1.ebuild 1407 BLAKE2B c7524f67d2cf2005ad4626efa2d69ad078aedd65c9b2888c05d1e1d01ce758bf4b85a239d1efe923341126e217f64b461274a8253096d92fae8aa5cd3b0a648a SHA512 81d5cb1dc9b09aeea7017a4327391245dfff3e9eae8a4d805aeaa0e40994916cfc566e784ee27c455e31fd50e768b1b4ec2d0c77fadc63dbc4db4863678a0808
+MISC metadata.xml 1352 BLAKE2B 61d0cb2977513e27455c82f355c3e3138594c6c52da901cb6543ae78e2189007ab5188e72f1477950ac7844bd0e5201a98b37a1f088ca4e3b9a32abb074b4540 SHA512 1c63a1947008aea378f548443cd8af55dc7bc1cf9d4179aa01a8c815b5fb778eb2ca5e09e912473f0a1335d58add88a1e819207eb8461438b1da5a0ce45760f6
diff --git a/games-action/multimc-bin/metadata.xml b/games-action/multimc-bin/metadata.xml
new file mode 100644
index 000000000000..9246e9cd3415
--- /dev/null
+++ b/games-action/multimc-bin/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">MultiMC/MultiMC5</remote-id>
+ <bugs-to>https://github.com/MultiMC/MultiMC5/issues</bugs-to>
+ </upstream>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <longdescription>
+ MultiMC is a custom launcher for Minecraft that allows you to easily manage multiple installations of Minecraft at once. It also allows you to easily install and remove mods by simply dragging and dropping. Here are the current features of MultiMC:
+
+ - Manage multiple instances of Minecraft at once
+ - Start Minecraft with a custom resolution
+ - Change Java's runtime options (including memory options)
+ - Shows Minecraft's console output in a colour-coded window
+ - Kill Minecraft easily if it crashes/freezes
+ - Custom icons and groups for instances
+ - Forge, Fabric and LiteLoader integration (automatic installation, version downloads, mod management)
+ - Import of Curse modpacks
+ - LWJGL version changing built-in
+ - Supports every version of Minecraft that the vanilla launcher does
+ - Upload screenshots
+ - Import, export Instances allowing you to share with friends and/or make backups
+ </longdescription>
+</pkgmetadata>
diff --git a/games-action/multimc-bin/multimc-bin-1.5.1.ebuild b/games-action/multimc-bin/multimc-bin-1.5.1.ebuild
new file mode 100644
index 000000000000..2e4e4a210532
--- /dev/null
+++ b/games-action/multimc-bin/multimc-bin-1.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker xdg
+
+DESCRIPTION="An advanced Qt5-based open-source launcher for Minecraft"
+HOMEPAGE="https://multimc.org https://github.com/MultiMC/MultiMC5"
+SRC_URI="https://files.multimc.org/downloads/multimc_$(ver_rs 2 -).deb"
+# We need -bin because of secret API keys:
+# https://github.com/MultiMC/MultiMC5/issues/4087
+# https://github.com/MultiMC/MultiMC5/issues/4113
+# https://bugs.gentoo.org/814404
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+LICENSE="Apache-2.0 Boost-1.0 BSD-2 BSD GPL-2+ LGPL-2.1-with-linking-exception LGPL-3 OFL-1.1 MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtgui:5
+ dev-qt/qttest:5
+ dev-qt/qtxml:5
+ sys-libs/zlib
+ >=virtual/jre-1.8.0
+ virtual/opengl
+ x11-libs/libXrandr
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ mv "${S}"/* "${ED}" || die
+ # Rename the .desktop file to avoid file conflict with non-bin version
+ mv "${ED}/usr/share/applications/multimc.desktop" "${ED}/usr/share/applications/multimc-bin.desktop" || die
+ # Change the name so we can differentiate from the non-bin version in app menu
+ # and remove empty options
+ sed -i \
+ -e 's/Name=MultiMC 5/Name=MultiMC Official Binary/g' \
+ -e '/Path=/d' \
+ -e '/TerminalOptions=/d' \
+ "${ED}/usr/share/applications/multimc-bin.desktop" || die
+}