summaryrefslogtreecommitdiff
path: root/games-action/minecraft-launcher/minecraft-launcher-1.6.93.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /games-action/minecraft-launcher/minecraft-launcher-1.6.93.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'games-action/minecraft-launcher/minecraft-launcher-1.6.93.ebuild')
-rw-r--r--games-action/minecraft-launcher/minecraft-launcher-1.6.93.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-action/minecraft-launcher/minecraft-launcher-1.6.93.ebuild b/games-action/minecraft-launcher/minecraft-launcher-1.6.93.ebuild
new file mode 100644
index 000000000000..5a590a02ca45
--- /dev/null
+++ b/games-action/minecraft-launcher/minecraft-launcher-1.6.93.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop java-pkg-2 xdg
+
+DESCRIPTION="An open-world game whose gameplay revolves around breaking and placing blocks"
+HOMEPAGE="https://www.minecraft.net/"
+SRC_URI="https://launcher.mojang.com/v1/objects/eabbff5ff8e21250e33670924a0c5e38f47c840b/launcher.jar -> ${P}.jar
+ https://launcher.mojang.com/download/minecraft-launcher.svg"
+
+KEYWORDS="~amd64"
+LICENSE="Mojang"
+SLOT="legacy"
+
+RESTRICT="bindist mirror"
+
+RDEPEND="virtual/jre:1.8"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # do not unpack jar file
+ true
+}
+
+src_install() {
+ java-pkg_newjar "${DISTDIR}/${P}.jar" ${PN}-legacy.jar
+ java-pkg_dolauncher ${PN}-legacy --jar ${PN}-legacy.jar --java_args "\${JAVA_OPTS}"
+
+ newicon -s scalable "${DISTDIR}/${PN}.svg" "${PN}-legacy.svg"
+ make_desktop_entry ${PN}-legacy "Minecraft (legacy)" ${PN}-legacy Game
+}