summaryrefslogtreecommitdiff
path: root/games-action/maelstrom/maelstrom-3.0.6-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-action/maelstrom/maelstrom-3.0.6-r3.ebuild
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/maelstrom/maelstrom-3.0.6-r3.ebuild')
-rw-r--r--games-action/maelstrom/maelstrom-3.0.6-r3.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/games-action/maelstrom/maelstrom-3.0.6-r3.ebuild b/games-action/maelstrom/maelstrom-3.0.6-r3.ebuild
deleted file mode 100644
index bd1110643dbe..000000000000
--- a/games-action/maelstrom/maelstrom-3.0.6-r3.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools eutils user
-
-MY_P=Maelstrom-${PV}
-DESCRIPTION="An asteroids battle game"
-HOMEPAGE="http://www.libsdl.org/projects/Maelstrom/"
-SRC_URI="http://www.libsdl.org/projects/Maelstrom/src/${MY_P}.tar.gz"
-
-KEYWORDS="~alpha ~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-DEPEND="media-libs/libsdl[sound,joystick,video]
- media-libs/sdl-net"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${FILESDIR}"/${P}-security.patch
- "${FILESDIR}"/${P}-64bits.patch
- "${FILESDIR}"/${P}-gcc34.patch
- "${FILESDIR}"/${P}-warnings.patch
- "${FILESDIR}"/${P}-gcc53.patch
-)
-
-pkg_setup(){
- enewgroup gamestat 36
-}
-
-src_prepare() {
- default
-
- # Install the data into $(datadir)/..., not $(prefix)/games/...
- sed -i \
- -e "s:(prefix)/games/:(datadir)/:" configure.in || die
- sed -i \
- -e '/make install_gamedata/ { s:=:=$(DESTDIR)/:; s/make/$(MAKE)/; s/install_gamedata/install-binPROGRAMS install_gamedata/; }' Makefile.am || die
- # Install the high scores file in ${GAMES_STATEDIR}
- sed -i \
- -e "s:path.Path(MAELSTROM_SCORES):\"/var/games/\"MAELSTROM_SCORES:" scores.cpp || die
- mv configure.{in,ac}
- rm aclocal.m4 acinclude.m4
- eautoreconf
-}
-
-src_install() {
- default
- dodoc Changelog Docs/{Maelstrom-Announce,*FAQ,MaelstromGPL_press_release,*.Paper,Technical_Notes*}
-
- newicon "${D}/usr/share/Maelstrom/icon.xpm" maelstrom.xpm
- make_desktop_entry Maelstrom "Maelstrom" maelstrom
-
- # Put the high scores file in the right place
- insinto /var/games
- doins "${D}/usr/share/Maelstrom/Maelstrom-Scores"
-
- # clean up some cruft
- rm -f \
- "${D}/usr/share/Maelstrom/Maelstrom-Scores" \
- "${D}/usr/share/Maelstrom/Images/Makefile*"
-
- # make sure we can update the high scores
- fowners root:gamestat /var/games/Maelstrom-Scores /usr/bin/Maelstrom{,-netd}
- fperms 2755 /usr/bin/Maelstrom{,-netd}
- fperms 660 /var/games/Maelstrom-Scores
-}