summaryrefslogtreecommitdiff
path: root/games-action/lugaru
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/lugaru
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/lugaru')
-rw-r--r--games-action/lugaru/Manifest4
-rw-r--r--games-action/lugaru/files/lugaru-20151204-dir.patch11
-rw-r--r--games-action/lugaru/lugaru-20151204-r1.ebuild58
-rw-r--r--games-action/lugaru/metadata.xml11
4 files changed, 84 insertions, 0 deletions
diff --git a/games-action/lugaru/Manifest b/games-action/lugaru/Manifest
new file mode 100644
index 000000000000..25bd52d81ac9
--- /dev/null
+++ b/games-action/lugaru/Manifest
@@ -0,0 +1,4 @@
+AUX lugaru-20151204-dir.patch 317 BLAKE2B 47b73dad97c8a853eb14d6718db18e0541607770419da6b95eb56791f5629a0ebcb1600506934aea30d3cb216c91d38fa8cf45735b0049435693a39a229c48aa SHA512 c0830385ca57dfda082596f65e7166ba71148fcb2b99e416a4a6ef8882c280a823e6308fce9fcfab62127667a10f0ed0ef49df60f1f39627615ff21c9ffd62e2
+DIST lugaru-20151204.tar.bz2 88950866 BLAKE2B d1d42f8d06d20d8f06fbe52d95c925fefc0453cc577dc5a023189eb77508361737ab01298f2035c3071ac7f8a239ee47c13bb8bafa852dd3b5cdecc971e9b4ed SHA512 8e448b782847376ac10585996a91a571fd005ac51e0e510765a35bf44bfcbb09e566d9a9c3d87277e69511b0f8d74c04edcc4b59f467bed640d8ba7c74045e30
+EBUILD lugaru-20151204-r1.ebuild 1158 BLAKE2B 6d8c1123f6d1340afaca28b10167a058c9b53d761b2cfa2ef51b98302686494a20dceb86e0e00f267d2f12ae038501486a9d3cdf1a0dce22fe0c526b16ec70cc SHA512 c71ed998364c6938154a298ed6ff6333ed93fc5c27eba047537823c2e1141671b313b51f0a3758def6e81418372119f2bbb81fc8678e632034c648af5d1e6cf1
+MISC metadata.xml 337 BLAKE2B 5fa6d71103f9aad7af7d0766be33b63f5dcdcbba20c043a2d1183b18a23f4910d49d411defb7f1c604ef085437956af72a55fa366734be5827a3d736bc71f72f SHA512 10af1cda47d8d683fc8245f23c05243fb5809636399d75779081a3da09209829da31a8d5fa070687656e9c235e78c75f1571b5b4f1a686359a11d1232a543b5e
diff --git a/games-action/lugaru/files/lugaru-20151204-dir.patch b/games-action/lugaru/files/lugaru-20151204-dir.patch
new file mode 100644
index 000000000000..da9310dde58e
--- /dev/null
+++ b/games-action/lugaru/files/lugaru-20151204-dir.patch
@@ -0,0 +1,11 @@
+--- a/Source/OpenGL_Windows.cpp 2015-01-14 23:57:19.799186785 -0500
++++ b/Source/OpenGL_Windows.cpp 2015-01-14 23:57:36.022643953 -0500
+@@ -1330,7 +1330,7 @@
+
+ // !!! FIXME: we could use a Win32 API for this. --ryan.
+ #ifndef WIN32
+- chdirToAppPath(argv[0]);
++ chdir("@GENTOO_DIR@");
+ #endif
+
+ LOGFUNC;
diff --git a/games-action/lugaru/lugaru-20151204-r1.ebuild b/games-action/lugaru/lugaru-20151204-r1.ebuild
new file mode 100644
index 000000000000..f53cecb8d748
--- /dev/null
+++ b/games-action/lugaru/lugaru-20151204-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils cmake-utils
+
+DESCRIPTION="3D arcade with unique fighting system and anthropomorphic characters"
+HOMEPAGE="https://bitbucket.org/osslugaru/lugaru/wiki/Home"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+ free-noncomm CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libpng:0
+ media-libs/libsdl[opengl,video]
+ media-libs/libvorbis
+ media-libs/openal
+ sys-libs/zlib
+ virtual/glu
+ virtual/jpeg:0
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-dir.patch"
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -i \
+ -e "s:@GENTOO_DIR@:/usr/share/${PN}:" \
+ Source/OpenGL_Windows.cpp || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
+ "-DLUGARU_FORCE_INTERNAL_OPENGL=False"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ dobin "${WORKDIR}/${P}_build/lugaru"
+ insinto /usr/share/${PN}
+ doins -r Data/
+ newicon Source/win-res/Lugaru.png ${PN}.png
+ make_desktop_entry ${PN} Lugaru ${PN}
+}
diff --git a/games-action/lugaru/metadata.xml b/games-action/lugaru/metadata.xml
new file mode 100644
index 000000000000..f50d5486c2ab
--- /dev/null
+++ b/games-action/lugaru/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">osslugaru/lugaru</remote-id>
+ </upstream>
+</pkgmetadata>