summaryrefslogtreecommitdiff
path: root/games-action/heretic2-demo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/heretic2-demo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/heretic2-demo')
-rw-r--r--games-action/heretic2-demo/Manifest3
-rw-r--r--games-action/heretic2-demo/heretic2-demo-1.06a.ebuild57
-rw-r--r--games-action/heretic2-demo/metadata.xml11
3 files changed, 71 insertions, 0 deletions
diff --git a/games-action/heretic2-demo/Manifest b/games-action/heretic2-demo/Manifest
new file mode 100644
index 000000000000..3ad7013042ab
--- /dev/null
+++ b/games-action/heretic2-demo/Manifest
@@ -0,0 +1,3 @@
+DIST heretic2-demo.run 55065564 BLAKE2B d4d2e3383a14633d215f4cc7c979dc737e56a743998f10b36d0b9cbc3787df86cc0943802ce700e2123791f9d44cea9fd37d891b7c0562dbca1a4264e3eb48cc SHA512 62aba7b4569b76bf9a01864652da7be8e268ad3cad4eb5b986b7e84adbd88e826799d021b141f9a7a1135520e440de4ce2e57c5be6ceaa85dc08295d5e3ad30e
+EBUILD heretic2-demo-1.06a.ebuild 1352 BLAKE2B 27e78bca84c57cfe8ccb7fe99dc4780aaefdf38521f243d67dabf7ed76b3aece0844e8abfaaf550eb98fe2491cfe73abf446628062bb761477bd4faeaaf1f8fe SHA512 facfe4e8cca8e8d0d25db13459b9c1e2c145f0fe58e8ebdf0469b208d59a442bfefb74752cd67ebfc90236403f38abbb61329af952768b7768d9e6ba07af11b7
+MISC metadata.xml 710 BLAKE2B 2b9f13c1ebed41739b7700016440fbc43cb798906a68cd6c6c105218db4681863ebf1d711534967abed200c4e6ff2c5f42963b01fb33b63a6a1e6311e9f76c4a SHA512 3d5b818e953410bd3b51926173604c85ea1d74d6433e5ea52866153fa9da7d4627cd18adc844e10fa54cba1d156b505dca9364b22f6fe7d2d792127fa65b4586
diff --git a/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild b/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild
new file mode 100644
index 000000000000..0db2fab52331
--- /dev/null
+++ b/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils unpacker multilib games
+
+DESCRIPTION="Third-person classic magical action-adventure game"
+HOMEPAGE="http://www.lokigames.com/products/heretic2/
+ http://www.hereticii.com/"
+SRC_URI="mirror://lokigames/loki_demos/${PN}.run"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+QA_TEXTRELS="${GAMES_PREFIX_OPT:1}/heretic2-demo/ref_glx.so"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/*"
+
+src_install() {
+ ABI=x86
+
+ local demo="data/demos/heretic2_demo"
+ local exe="heretic2_demo.x86"
+
+ loki_patch patch.dat data/ || die
+
+ # Remove bad opengl library
+ rm -r "${demo}/gl_drivers/"
+
+ # Change to safe default of 800x600 and option of normal opengl driver
+ sed -i \
+ -e "s:fullscreen \"1\":fullscreen \"1\"\nset vid_mode \"4\":" \
+ -e "s:libGL:/usr/$(get_libdir)/libGL:" \
+ "${demo}"/base/default.cfg || die
+
+ insinto "${dir}"
+ exeinto "${dir}"
+ doins -r "${demo}"/*
+ doexe "${demo}/${exe}"
+
+ games_make_wrapper ${PN} "./${exe}" "${dir}" "${dir}"
+ newicon "${demo}"/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Heretic 2 (Demo)" ${PN}
+
+ prepgamesdirs
+}
diff --git a/games-action/heretic2-demo/metadata.xml b/games-action/heretic2-demo/metadata.xml
new file mode 100644
index 000000000000..3df7e72452ae
--- /dev/null
+++ b/games-action/heretic2-demo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+Power up your mana and help Corvus find the cure to a plague of epic dimensions -- and save the worlds of D'sparil before it's too late! A high-powered and mystical three-dimensional environment will enthrall you, with spectacular sound and visual effects, non-stop action and adventure. Prepare to be ensnared in the visual feast that is the worlds of D'sparil. This is the demo version of the commercially-ported game.
+</longdescription>
+</pkgmetadata>