summaryrefslogtreecommitdiff
path: root/games-action/heretic2-demo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-action/heretic2-demo
reinit the tree, so we can have metadata
Diffstat (limited to 'games-action/heretic2-demo')
-rw-r--r--games-action/heretic2-demo/Manifest5
-rw-r--r--games-action/heretic2-demo/heretic2-demo-1.06a.ebuild57
-rw-r--r--games-action/heretic2-demo/metadata.xml11
3 files changed, 73 insertions, 0 deletions
diff --git a/games-action/heretic2-demo/Manifest b/games-action/heretic2-demo/Manifest
new file mode 100644
index 000000000000..c5d1bf89229b
--- /dev/null
+++ b/games-action/heretic2-demo/Manifest
@@ -0,0 +1,5 @@
+DIST heretic2-demo.run 55065564 SHA256 623e1a277ff8eb47e48a6fa50f32eb1325eba1591cebdea002a32599464b881a SHA512 62aba7b4569b76bf9a01864652da7be8e268ad3cad4eb5b986b7e84adbd88e826799d021b141f9a7a1135520e440de4ce2e57c5be6ceaa85dc08295d5e3ad30e WHIRLPOOL fdde3e8caf5114e37e9db16801e99638a1fbe20b40c6bdf913d57d8e5f4774fa3d84bb44a365bb16ea6fefd1ad88e08c924bedd6ef58a50bc9612193cc4e8220
+EBUILD heretic2-demo-1.06a.ebuild 1350 SHA256 9cdcecfc0a17bd2aad78b9d873102fa7351d563f8ae931ce3879352d9d0443cc SHA512 f0092e7f031995adc322dc843ac28c62b67c5519d23df93957fe6f856091006d3e82c5eff72a7461ab77fd9a7c0d499e0ea462091fafcdd14d02f9389506aa21 WHIRLPOOL 3f1a907737192a98d3e24ac1629c195984ef362b762d9805e27eb1ebeaa11300722129662e0cb7cab8d59d2b7ecf594415388f426916c2e6a83d2220c2905a88
+MISC ChangeLog 2449 SHA256 16ce26a849b0786ccb43264b8000edb1d7fa6ed2feef9b287b9ff8c9ce9ebc2f SHA512 796d90f55ff9794d972147b281a6377eb32e40ff01b53c7be1810202e802a6fc4f34b1ddf3cf2a5cf7e34bdf48f295028a4c456eadef32342c37ecaaab1ac242 WHIRLPOOL b5bce9f620b5cf3b0d93dc8f96c3d668299c265aefab5c5ae0b26c59d2cbf4152725d349794e8214ce0397d2b92a04d9a3c61a643523e3e446f8d938bfdf0a30
+MISC ChangeLog-2015 1983 SHA256 fdc30d82b44aa8ce28482db17aedb2f16c0795e3cc41c7ca11734cb4b6c97369 SHA512 f6fa9c229a846b4c6f22d42f8568494ed877e9449f86662b0dfbc0265a10cfdbc5e97de63fe4adf5a0909f5a3df1f7c35ebe2def67dac1372e3f11c1ab67b5d6 WHIRLPOOL 13368bb2bf20806fdde97a39eb92dd8bf96ee0cfb868453371634f7fc1fe0b6f587f20f275a36439a99fa5b7180ab5ffb280669fc09ada641177f1c1525f8316
+MISC metadata.xml 710 SHA256 8cf6343462b095a63e03f72ad258674cdb23022f5612a0ea4127cf2ec16f922c SHA512 3d5b818e953410bd3b51926173604c85ea1d74d6433e5ea52866153fa9da7d4627cd18adc844e10fa54cba1d156b505dca9364b22f6fe7d2d792127fa65b4586 WHIRLPOOL ddba7d6b00104996c2effbfa8ee6224428303501fd15ceb5bb1952bf3d0917960f75852fc8edc37b59abb11aa78d14c196c92794e9511f1e13fa016c5a909d0b
diff --git a/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild b/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild
new file mode 100644
index 000000000000..d7c4210078da
--- /dev/null
+++ b/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils unpacker multilib games
+
+DESCRIPTION="Third-person classic magical action-adventure game"
+HOMEPAGE="http://www.lokigames.com/products/heretic2/
+ http://www.hereticii.com/"
+SRC_URI="mirror://lokigames/loki_demos/${PN}.run"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="strip"
+QA_TEXTRELS="${GAMES_PREFIX_OPT:1}/heretic2-demo/ref_glx.so"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/*"
+
+src_install() {
+ ABI=x86
+
+ local demo="data/demos/heretic2_demo"
+ local exe="heretic2_demo.x86"
+
+ loki_patch patch.dat data/ || die
+
+ # Remove bad opengl library
+ rm -r "${demo}/gl_drivers/"
+
+ # Change to safe default of 800x600 and option of normal opengl driver
+ sed -i \
+ -e "s:fullscreen \"1\":fullscreen \"1\"\nset vid_mode \"4\":" \
+ -e "s:libGL:/usr/$(get_libdir)/libGL:" \
+ "${demo}"/base/default.cfg || die
+
+ insinto "${dir}"
+ exeinto "${dir}"
+ doins -r "${demo}"/*
+ doexe "${demo}/${exe}"
+
+ games_make_wrapper ${PN} "./${exe}" "${dir}" "${dir}"
+ newicon "${demo}"/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Heretic 2 (Demo)" ${PN}
+
+ prepgamesdirs
+}
diff --git a/games-action/heretic2-demo/metadata.xml b/games-action/heretic2-demo/metadata.xml
new file mode 100644
index 000000000000..3df7e72452ae
--- /dev/null
+++ b/games-action/heretic2-demo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+Power up your mana and help Corvus find the cure to a plague of epic dimensions -- and save the worlds of D'sparil before it's too late! A high-powered and mystical three-dimensional environment will enthrall you, with spectacular sound and visual effects, non-stop action and adventure. Prepare to be ensnared in the visual feast that is the worlds of D'sparil. This is the demo version of the commercially-ported game.
+</longdescription>
+</pkgmetadata>