summaryrefslogtreecommitdiff
path: root/games-action/guacamelee
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /games-action/guacamelee
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'games-action/guacamelee')
-rw-r--r--games-action/guacamelee/Manifest3
-rw-r--r--games-action/guacamelee/guacamelee-20140222.ebuild57
-rw-r--r--games-action/guacamelee/metadata.xml8
3 files changed, 68 insertions, 0 deletions
diff --git a/games-action/guacamelee/Manifest b/games-action/guacamelee/Manifest
new file mode 100644
index 000000000000..20dc9bf8c3f9
--- /dev/null
+++ b/games-action/guacamelee/Manifest
@@ -0,0 +1,3 @@
+DIST Guacamelee_linux_1393037377.sh 552784497 BLAKE2B 1f36e1a6b65bcf774d0f4e15b37d8eda3ec91691c7e3c556f73e903559c3215f3611fdbec284259fe7690037cf4ab8e338c1caa7faea80c8ce98d02581b0de4b SHA512 e52c4099e15f20df6512c3c9617cbf29f5ea428c117a0520ce57bacf99b7d33ace6a04c811fd9ced63b7ba11a3a79549b93f83fd18e42ca9a1366aeb4114cd87
+EBUILD guacamelee-20140222.ebuild 1437 BLAKE2B a8827fd9d360d18dd8d755637e818a0bbc96632384218f39fb4247ed63e6179dc070b0b54bf28258772b101e192f40080181e846624a06adb8ecbc2fafa5ed43 SHA512 a03ce27e2ddad28782b8685fb0f7c5d2904086cfde78d433bbbacedba6237055e52b1adb3b62b583771c8fba00f1ae4b7467df20e35fd3aacdc5051bb4699160
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-action/guacamelee/guacamelee-20140222.ebuild b/games-action/guacamelee/guacamelee-20140222.ebuild
new file mode 100644
index 000000000000..4774a553e4eb
--- /dev/null
+++ b/games-action/guacamelee/guacamelee-20140222.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop unpacker xdg-utils
+
+DESCRIPTION="A Metroidvania-style action-platformer set in a magical Mexican-inspired world"
+HOMEPAGE="http://guacamelee.com"
+SRC_URI="Guacamelee_linux_1393037377.sh"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ media-libs/libsdl2[abi_x86_32,joystick,opengl,sound,threads,video]
+ virtual/opengl[abi_x86_32]
+"
+
+S="${WORKDIR}/data"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "This package requires the Guacamelee! Gold Edition file included in"
+ einfo "Humble Indie Bundle 11. If you have it then please move"
+ einfo "${SRC_URI} to your distfiles directory. If you"
+ einfo "missed it then the game is also available to buy from GOG but the"
+ einfo "package will need adapting first. Please contact the Gentoo Games team"
+ einfo "if you bought it from GOG."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe x86/game-bin ${PN}
+ dosym "${DIR}"/${PN} /usr/bin/${PN}
+
+ insinto "${DIR}"
+ doins -r noarch/{*.dat*,media/}
+
+ exeinto "${DIR}/lib32"
+ doexe x86/lib32/libfmod*.so
+
+ dodoc noarch/README.linux
+
+ newicon -s 512 noarch/Guacamelee.png ${PN}.png
+ make_desktop_entry ${PN} "Guacamelee"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-action/guacamelee/metadata.xml b/games-action/guacamelee/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-action/guacamelee/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>