summaryrefslogtreecommitdiff
path: root/games-action/gltron/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-action/gltron/files
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/gltron/files')
-rw-r--r--games-action/gltron/files/gltron-0.70-configure.patch24
-rw-r--r--games-action/gltron/files/gltron-0.70-debian.patch35
-rw-r--r--games-action/gltron/files/gltron-0.70-gcc49.patch13
-rw-r--r--games-action/gltron/files/gltron-0.70-prototypes.patch24
4 files changed, 0 insertions, 96 deletions
diff --git a/games-action/gltron/files/gltron-0.70-configure.patch b/games-action/gltron/files/gltron-0.70-configure.patch
deleted file mode 100644
index 5bdef979a57f..000000000000
--- a/games-action/gltron/files/gltron-0.70-configure.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-configure.in is written poorly so it just stomps all over CFLAGS
-
---- a/configure
-+++ b/configure
-@@ -2805,7 +2805,7 @@
- RANLIB="$ac_cv_prog_RANLIB"
- fi
-
--CFLAGS="-DSEPARATOR=\"'/'\""
-+CFLAGS="$CFLAGS -DSEPARATOR=\"'/'\""
-
- # Check whether --enable-warn or --disable-warn was given.
- if test "${enable_warn+set}" = set; then
-@@ -2852,10 +2852,6 @@
- else
- enable_optimize=s
- fi;
--if test "x$enable_optimize" ; then
-- CFLAGS="$CFLAGS -O$enable_optimize"
-- CXXFLAGS="$CXXFLAGS -O$enable_optimize"
--fi
-
- # Check whether --with-sdl-prefix or --without-sdl-prefix was given.
- if test "${with_sdl_prefix+set}" = set; then
diff --git a/games-action/gltron/files/gltron-0.70-debian.patch b/games-action/gltron/files/gltron-0.70-debian.patch
deleted file mode 100644
index 4e25618ce9b6..000000000000
--- a/games-action/gltron/files/gltron-0.70-debian.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Ripped from Debian patchset 6
-
---- a/src/include/game/game_data.h
-+++ b/src/include/game/game_data.h
-@@ -71,7 +71,7 @@
- typedef struct AI {
- int active;
- int tdiff;
-- long lasttime;
-+ unsigned int lasttime;
- segment2 left, right, front, backleft;
- } AI;
-
---- a/src/include/video/fonttex.h
-+++ b/src/include/video/fonttex.h
-@@ -10,7 +10,7 @@
- int lower; /* lowest ascii character (normally: 32) */
- int upper; /* highest ascii character (normally: 126) */
-
-- int *texID;
-+ unsigned int *texID;
-
- char *fontname;
- char *bitmapname;
---- a/src/video/trail.c
-+++ b/src/video/trail.c
-@@ -19,7 +19,7 @@
- n[1] = s->vStart.v[1] - s->vDirection.v[0];
- tmp[0] = eye[0] - s->vStart.v[0];
- tmp[1] = eye[1] - s->vStart.v[1];
-- if(n[0] == n[1] == 0) return length(tmp);
-+ if(n[0] == 0 && n[1] == 0) return length(tmp);
- return abs(scalarprod2(n, tmp) / length(n));
- }
-
diff --git a/games-action/gltron/files/gltron-0.70-gcc49.patch b/games-action/gltron/files/gltron-0.70-gcc49.patch
deleted file mode 100644
index 4a1d5cbe1e1e..000000000000
--- a/games-action/gltron/files/gltron-0.70-gcc49.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- 1/lua/src/lib/liolib.c
-+++ 1/lua/src/lib/liolib.c
-@@ -6,9 +6,9 @@
- */
-
-
-+#define __USE_MISC /* for mkstemp() */
- #include <ctype.h>
- #include <stdio.h>
--#define __USE_MISC /* for mkstemp() */
- #include <stdlib.h>
- #include <string.h>
- #include <time.h>
diff --git a/games-action/gltron/files/gltron-0.70-prototypes.patch b/games-action/gltron/files/gltron-0.70-prototypes.patch
deleted file mode 100644
index 621963aeb689..000000000000
--- a/games-action/gltron/files/gltron-0.70-prototypes.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-scripting.h declares these params as const so make sure they're the same.
-
---- a/nebu/scripting/scripting.c
-+++ b/nebu/scripting/scripting.c
-@@ -169,16 +169,16 @@
- return status;
- }
-
--void scripting_RunFile(char *name) {
-+void scripting_RunFile(const char *name) {
- lua_dofile(L, name);
- }
-
--void scripting_Run(char *command) {
-+void scripting_Run(const char *command) {
- /* fprintf(stderr, "[command] %s\n", command); */
- lua_dostring(L, command);
- }
-
--void scripting_RunFormat(char *format, ... ) {
-+void scripting_RunFormat(const char *format, ... ) {
- char buf[4096];
- va_list ap;
- va_start(ap, format);