summaryrefslogtreecommitdiff
path: root/games-action/formido
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/formido
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/formido')
-rw-r--r--games-action/formido/Manifest4
-rw-r--r--games-action/formido/formido-1.0.1-r1.ebuild47
-rw-r--r--games-action/formido/metadata.xml8
3 files changed, 59 insertions, 0 deletions
diff --git a/games-action/formido/Manifest b/games-action/formido/Manifest
new file mode 100644
index 000000000000..6a5b821a6eb9
--- /dev/null
+++ b/games-action/formido/Manifest
@@ -0,0 +1,4 @@
+DIST formido-1.0.1.tar.gz 3117496 BLAKE2B 19ba27513cb1ad28c2e1fdb80c956bb752b6a7515580d78de95d65a0e75d27c0ff780dc2b6ed2e0227570183976c2a5c6478218311af494139366e77a998fdc3 SHA512 72c4b92806eed79290da571c47fcd5427ccd0fafd3d5c5bc1cf641790e13b622eb40f8226e54daf30d1f301743f670115efe8f30279ed83b8fd58d69b6a7e123
+DIST formido-music.tar.bz2 6159005 BLAKE2B 606a0eee0728ef38f94acde72be33914ca22762b78452c25c846fde950e1d694a381aa41cbc8a56d78719876304add14ac983483800f138f4407e9e7bfbc8b5a SHA512 116ff8af42b68cf641f459b642d42c579decf8ee1314a45de30d4f5452e1669dab5cfdc3a61a72359305f690e686312ea0e1666e724de8b214f3d4d8f6034bd3
+EBUILD formido-1.0.1-r1.ebuild 1075 BLAKE2B a33854a221d204c4224425d9074a65f90b7d0e44970dc8a36ef33ce6f7c2b1fbb4facb91e060f5d2e49fc88ed1c27d4b2df896e7a9eb87992d703edefe4feedc SHA512 f35d0d8d13f0201d0d67bcc6dcc7ee967f4154b568e8006b4a020c97f861dc715fb9e856243ead8c8c00a83ac5897c204965f88b727c79b9e345b8fa0cc5dbed
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-action/formido/formido-1.0.1-r1.ebuild b/games-action/formido/formido-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..c7e9e86f1740
--- /dev/null
+++ b/games-action/formido/formido-1.0.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A shooting game in the spirit of Phobia games"
+HOMEPAGE="http://www.mhgames.org/oldies/formido/"
+SRC_URI="http://noe.falzon.free.fr/prog/${P}.tar.gz
+ http://koti.mbnet.fi/lsoft/formido/formido-music.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"/data || die
+ unpack ${PN}-music.tar.bz2
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:g++:$(tc-getCXX):" \
+ -e "/^FLAGS=/s:$: ${CXXFLAGS}:" \
+ -e "/^LINKFLAGS=/s:=.*:=${LDFLAGS}:" \
+ -e "s:\${DATDIR}:/usr/share/${PN}/data:" \
+ -e "s:\${DEFCONFIGDIR}:/usr/share/${PN}:" \
+ Makefile || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r ${PN}.cfg data
+ newicon data/icon.dat ${PN}.bmp
+ make_desktop_entry ${PN} Formido /usr/share/pixmaps/${PN}.bmp
+ dodoc README README-1.0.1
+}
diff --git a/games-action/formido/metadata.xml b/games-action/formido/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-action/formido/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>