summaryrefslogtreecommitdiff
path: root/games-action/fakk2/fakk2-1.02-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/fakk2/fakk2-1.02-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/fakk2/fakk2-1.02-r1.ebuild')
-rw-r--r--games-action/fakk2/fakk2-1.02-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/games-action/fakk2/fakk2-1.02-r1.ebuild b/games-action/fakk2/fakk2-1.02-r1.ebuild
new file mode 100644
index 000000000000..b038c25d14ee
--- /dev/null
+++ b/games-action/fakk2/fakk2-1.02-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils cdrom
+
+DESCRIPTION="3D third-person action shooter based on the Heavy Metal comics/movies"
+HOMEPAGE="http://www.lokigames.com/products/fakk2/"
+SRC_URI=""
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nocd"
+RESTRICT="strip"
+
+RDEPEND="virtual/opengl"
+
+S=${WORKDIR}
+
+dir=/opt/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ if use nocd ; then
+ ewarn "The installed game takes about 378MB of space!"
+ fi
+}
+
+src_install() {
+ cdrom_get_cds fakk
+ einfo "Copying files... this may take a while..."
+ exeinto "${dir}"
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/${PN}
+ insinto "${dir}"
+ doins ${CDROM_ROOT}/{README,icon.{bmp,xpm}}
+ exeinto "${dir}"/fakk
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/fakk/{c,f}game.so
+ if use nocd ; then
+ insinto "${dir}"/fakk
+ doins ${CDROM_ROOT}/fakk/pak{0,1,2,3}.pk3
+ doins ${CDROM_ROOT}/fakk/default.cfg
+ fi
+
+ # Now, since these files are coming off a cd, the times/sizes/md5sums won't
+ # be different ... that means portage will try to unmerge some files (!)
+ # So, we run touch on ${D} to make sure portage doesn't do any such thing
+ find "${Ddir}" -exec touch '{}' \;
+
+ make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
+ newicon ${CDROM_ROOT}/icon.xpm ${PN}.xpm
+
+ make_desktop_entry ${PN} "FAKK2" ${PN}
+}
+
+pkg_postinst() {
+ echo
+ ewarn "There are two possible security bugs in this package, both causing a denial of"
+ ewarn "service. One affects the game when running a server, the other when running as"
+ ewarn "a client. For more information, see bug #82149."
+ echo
+ elog "To play the game run:"
+ elog " fakk2"
+}