summaryrefslogtreecommitdiff
path: root/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-25 19:30:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-25 19:30:41 +0100
commit6fe5af3f06c92a6b1a6b21ff5e1bc9d107490971 (patch)
tree872ff7ba355a0b1735779b329c6a6b8b8f728a88 /games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
parente564f1661521043bc9e03e613c3cd8c79d5d7713 (diff)
gentoo auto-resync : 25:06:2023 - 19:30:41
Diffstat (limited to 'games-action/dxx-rebirth/dxx-rebirth-9999.ebuild')
-rw-r--r--games-action/dxx-rebirth/dxx-rebirth-9999.ebuild34
1 files changed, 19 insertions, 15 deletions
diff --git a/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild b/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
index b13187e490c0..81bd934fd3b2 100644
--- a/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
+++ b/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
@@ -1,31 +1,35 @@
# Copyright 2017-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{10..11} )
+MY_COMMIT=""
+
+# Games under Gentoo are marked as 'testing' by convention
+#
+# Other architectures are reported to work, but not tested regularly by
+# the core team.
+#
+# Raspberry Pi support is tested by an outside contributor, and his
+# fixes are merged into the main source by upstream.
+#
+# Cross-compilation to Windows is also supported.
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
inherit desktop flag-o-matic python-any-r1 scons-utils toolchain-funcs xdg
if [[ "${PV}" = 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/dxx-rebirth/dxx-rebirth"
-else
- MY_COMMIT=''
+ unset KEYWORDS
+elif [[ -n ${MY_COMMIT} ]]; then
S="${WORKDIR}/${PN}-${MY_COMMIT}"
SRC_URI="https://codeload.github.com/dxx-rebirth/dxx-rebirth/tar.gz/${MY_COMMIT} -> ${PN}-${PVR}.tar.gz"
unset MY_COMMIT
-
- # Games under Gentoo are marked as 'testing' by convention
- #
- # Other architectures are reported to work, but not tested regularly by
- # the core team.
- #
- # Raspberry Pi support is tested by an outside contributor, and his
- # fixes are merged into the main source by upstream.
- #
- # Cross-compilation to Windows is also supported.
- KEYWORDS="~amd64 ~arm64 ~x86"
+else
+ S="${WORKDIR}/${PN}_${PV##*_pre}-src"
+ SRC_URI="https://www.dxx-rebirth.com/download/dxx/rebirth/${PN}_${PV##*_pre}-src.tar.xz"
fi
DESCRIPTION="Descent Rebirth - enhanced Descent 1 & 2 engine"