summaryrefslogtreecommitdiff
path: root/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-action/dxx-rebirth/dxx-rebirth-9999.ebuild')
-rw-r--r--games-action/dxx-rebirth/dxx-rebirth-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild b/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
index 61777f8871ce..5a01f9daaefc 100644
--- a/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
+++ b/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
@@ -5,15 +5,15 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
-inherit desktop eutils python-any-r1 scons-utils toolchain-funcs xdg
-if [[ "$PV" = 9999 ]]; then
+inherit desktop python-any-r1 scons-utils toolchain-funcs xdg
+
+if [[ "${PV}" = 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/dxx-rebirth/dxx-rebirth"
- PROPERTIES="live"
else
MY_COMMIT=''
- S="$WORKDIR/$PN-$MY_COMMIT"
- SRC_URI="https://codeload.github.com/dxx-rebirth/dxx-rebirth/tar.gz/$MY_COMMIT -> $PN-$PVR.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_COMMIT}"
+ SRC_URI="https://codeload.github.com/dxx-rebirth/dxx-rebirth/tar.gz/${MY_COMMIT} -> ${PN}-${PVR}.tar.gz"
unset MY_COMMIT
# Other architectures are reported to work, but not tested regularly by
@@ -219,7 +219,7 @@ src_compile() {
src_install() {
# Use upstream install target to handle the various combinations of
# enabled/disabled engines and optional editor support.
- dxx_scons register_compile_target=0 register_install_target=1 DESTDIR="$D" "$D"
+ dxx_scons register_compile_target=0 register_install_target=1 DESTDIR="${D}" "${D}"
local DV
for DV in 1 2; do
if ! use d${DV}x; then
@@ -236,7 +236,7 @@ src_install() {
pkg_postinst() {
xdg_pkg_postinst
if ! use data; then
- elog "$PN requires game data to play."
+ elog "${PN} requires game data to play."
elog "Game data is not included in this package. To play the game,"
elog "emerge the packages required by USE=data or install the game"
elog "data by hand."