summaryrefslogtreecommitdiff
path: root/games-action/descent3-demo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/descent3-demo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/descent3-demo')
-rw-r--r--games-action/descent3-demo/Manifest3
-rw-r--r--games-action/descent3-demo/descent3-demo-1.4.0a-r1.ebuild73
-rw-r--r--games-action/descent3-demo/metadata.xml15
3 files changed, 91 insertions, 0 deletions
diff --git a/games-action/descent3-demo/Manifest b/games-action/descent3-demo/Manifest
new file mode 100644
index 000000000000..fd55865aaa8b
--- /dev/null
+++ b/games-action/descent3-demo/Manifest
@@ -0,0 +1,3 @@
+DIST descent3-demo.run 45118289 BLAKE2B 7e64f03aa6cf75839d1eddf0116686c9d2a121f69a764cf416695455008b608579449ab7458177a2be11910ad361f707501153749d5c8b58dacc36e338251c1c SHA512 8f5e790257d0477e4238aae8fb5b4b1f21e23f188775cb53a5197baf0c174017d821e3a8dd696f9c0fd27838e08cff4bde0d6f5a9dca87a7e8af29cdc627d29c
+EBUILD descent3-demo-1.4.0a-r1.ebuild 1702 BLAKE2B 0fb7d751f7599d12f08311951e40eed34a6fd37c6a403bf98f77b6f685c0b23d7dbeba535f9cceb10c925fe2de2f992e36b974d023f0c4b2de312f5a9507617a SHA512 38e25044e6afc983f0e3ee4762b2f6c1b623362c2c87d72c54cb6af7c7e95c23394dd14126bde41ce5bdd08e0c68690cb173cb48d62c5fa71e12a7ff5c8371c9
+MISC metadata.xml 674 BLAKE2B 55ee8a8a4dddfca143c66a762de971984fcea130d085eb0f1d97d51eaa41e439cbbba1787a8700cf1018dd065a7126e1e206a7ea079bf6ed650905cd6c61580a SHA512 44cd0adf66a791a20af8eda38f8a7adef9aaeaf74b5a3db388d33efaec4bc14781ad9c8697fdbd18a2ff2188f848601409631b02537589bbae9eb9d8d0c5792f
diff --git a/games-action/descent3-demo/descent3-demo-1.4.0a-r1.ebuild b/games-action/descent3-demo/descent3-demo-1.4.0a-r1.ebuild
new file mode 100644
index 000000000000..cad5192149ca
--- /dev/null
+++ b/games-action/descent3-demo/descent3-demo-1.4.0a-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils unpacker xdg
+
+DESCRIPTION="Indoor/outdoor 3D combat with evil robotic mining spacecraft"
+HOMEPAGE="http://www.lokigames.com/products/descent3/"
+SRC_URI="mirror://lokigames/loki_demos/${PN}.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa pulseaudio"
+REQUIRED_USE="?? ( alsa pulseaudio )"
+RESTRICT="bindist mirror strip"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="sys-libs/glibc
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ alsa? ( media-libs/alsa-oss[abi_x86_32(-)] )
+ pulseaudio? ( media-sound/pulseaudio[abi_x86_32(-)] )"
+
+dir="/opt/${PN}"
+QA_PREBUILT="${dir:1}/descent3_demo.x86
+ ${dir:1}/netgames/*.d3m"
+
+S="${WORKDIR}"
+
+src_install() {
+ local \
+ snd= \
+ demo="data/demos/descent3_demo" \
+ exe="descent3_demo.x86"
+
+ loki_patch patch.dat data/ || die
+
+ insinto "${dir}"
+ exeinto "${dir}"
+ doins -r "${demo}"/*
+ doexe "${demo}/${exe}"
+
+ # Required directory
+ keepdir "${dir}"/missions
+
+ # Fix for 2.6 kernel crash, bug #151148
+ dosym ppics.hog "${dir}"/PPics.Hog
+
+ if use alsa; then
+ snd="aoss "
+ elif use pulseaudio; then
+ snd="env LD_PRELOAD=\"${EPREFIX}/usr/$(ABI=x86 get_libdir)/pulseaudio/libpulsedsp.so\" "
+ fi
+
+ make_wrapper ${PN} "${snd}./${exe} -G -o" "${dir}"
+ newicon "${demo}"/launch/box.png ${PN}.png
+ make_desktop_entry ${PN} "Descent 3 (Demo)"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ echo
+ elog "To play the game run:"
+ elog " descent3-demo"
+ elog
+ elog "If the game appears blank, then run it windowed with:"
+ elog " descent3-demo -w"
+ echo
+}
diff --git a/games-action/descent3-demo/metadata.xml b/games-action/descent3-demo/metadata.xml
new file mode 100644
index 000000000000..27cdd4f34a28
--- /dev/null
+++ b/games-action/descent3-demo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+Descent 3 is a first-person 3-D action flight-sim which takes place in both
+indoor and outdoor arenas. The game was ported to Linux by the now defunct Loki
+Entertainment and is commercial software. You can still pick up a copy from
+Tuxgames (http://www.tuxgames.com), but supplies are limited, as the publisher
+is no longer in business. This is the free demo version of the full game.
+</longdescription>
+</pkgmetadata>