summaryrefslogtreecommitdiff
path: root/games-action/bzflag/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-action/bzflag/files
reinit the tree, so we can have metadata
Diffstat (limited to 'games-action/bzflag/files')
-rw-r--r--games-action/bzflag/files/bzflag-2.4.10-configure.patch37
-rw-r--r--games-action/bzflag/files/bzflag-2.4.2-nocxxflags.patch56
-rw-r--r--games-action/bzflag/files/bzflag-2.4.4-configure.patch37
-rw-r--r--games-action/bzflag/files/bzflag-2.4.6-configure.patch37
-rw-r--r--games-action/bzflag/files/bzflag-2.4.8-configure.patch37
5 files changed, 204 insertions, 0 deletions
diff --git a/games-action/bzflag/files/bzflag-2.4.10-configure.patch b/games-action/bzflag/files/bzflag-2.4.10-configure.patch
new file mode 100644
index 000000000000..b280621f6ec2
--- /dev/null
+++ b/games-action/bzflag/files/bzflag-2.4.10-configure.patch
@@ -0,0 +1,37 @@
+diff -ru bzflag-2.4.4.orig/configure.ac bzflag-2.4.4/configure.ac
+--- bzflag-2.4.4.orig/configure.ac 2016-02-14 19:09:51.000000000 -0500
++++ bzflag-2.4.4/configure.ac 2016-05-05 16:35:35.475935345 -0400
+@@ -215,7 +215,7 @@
+ AC_SUBST(AR)
+ AC_SUBST(AR_FLAGS)
+
+-AC_PATH_PROG(CCACHE, ccache)
++AC_PATH_PROG(CCACHE, ccachex)
+ if test "$CCACHE" ; then
+ CC="ccache $CC"
+ CXX="ccache $CXX"
+@@ -747,13 +747,13 @@
+ #
+ # the GCC version is known to be at least 4.3 because it has C++0x support
+ # possible future warnings: -Wconversion (1894) -Wfloat-equal (317)
+-FLAGS="-Wall -Wextra -Wcast-qual -Wredundant-decls -Wshadow -Wundef -pedantic"
++FLAGSx="-Wall -Wextra -Wcast-qual -Wredundant-decls -Wshadow -Wundef -pedantic"
+ case $host_os in
+ linux*)
+ AC_DEFINE(HALF_RATE_AUDIO, 1, [Half rate Audio])
+ CONF_CFLAGS="$CONF_CFLAGS $FLAGS"
+ CONF_CXXFLAGS="$CONF_CXXFLAGS $FLAGS"
+- case $host_vendor in
++ case $host_vendorx in
+ pc)
+ if expr `$CC -dumpversion` \>= "3.4" > /dev/null ; then
+ FLAGS=-mtune
+@@ -836,7 +836,7 @@
+ CXXFLAGS="$user_CXXFLAGS"
+ AC_DEFINE(DEBUG, 1, [Debugging enabled])
+ else
+- if test "$GCC" = yes ; then
++ if test "$GCC" = yesx ; then
+ case "`$CC --version 2>&1`" in
+ *LLVM*)
+ # Apple LLVM falsely claims to be GCC
diff --git a/games-action/bzflag/files/bzflag-2.4.2-nocxxflags.patch b/games-action/bzflag/files/bzflag-2.4.2-nocxxflags.patch
new file mode 100644
index 000000000000..0b74d57bc41e
--- /dev/null
+++ b/games-action/bzflag/files/bzflag-2.4.2-nocxxflags.patch
@@ -0,0 +1,56 @@
+--- configure.ac.old 2013-05-12 13:33:05.738250140 +0200
++++ configure.ac 2013-05-12 13:33:24.732927312 +0200
+@@ -89,7 +89,7 @@
+ AM_INIT_AUTOMAKE([1.6 dist-zip dist-bzip2])
+
+ dnl all configured definitions get written here
+-AM_CONFIG_HEADER([include/config.h])
++AC_CONFIG_HEADER([include/config.h])
+
+ AC_SUBST(MAJOR_VERSION)
+ AC_SUBST(MINOR_VERSION)
+@@ -689,13 +689,9 @@
+ else
+ FLAGS="$FLAGS=$host_cpu"
+ fi
+- CONF_CFLAGS="$CONF_CFLAGS $FLAGS";
+- CONF_CXXFLAGS="$CONF_CXXFLAGS $FLAGS";
+ CONF_CXXFLAGS="$CONF_CXXFLAGS -fsigned-char";;
+ ppc)
+ FLAGS="-mcpu=$host_cpu"
+- CONF_CFLAGS="$CONF_CFLAGS $FLAGS";
+- CONF_CXXFLAGS="$CONF_CXXFLAGS $FLAGS";;
+ esac;;
+ cygwin)
+ AC_DEFINE(HALF_RATE_AUDIO, 1, [Half rate Audio])
+@@ -755,8 +751,6 @@
+ else
+ if test "$GCC" = yes ; then
+ OPTIMIZE="-fexpensive-optimizations"
+- CONF_CFLAGS="$CONF_CFLAGS $OPTIMIZE"
+- CONF_CXXFLAGS="$CONF_CXXFLAGS $OPTIMIZE"
+ fi
+ AC_DEFINE(NDEBUG, 1, [Debugging disabled])
+ fi
+--- src/other/ares/configure.ac.old 2013-05-12 13:44:25.147676903 +0200
++++ src/other/ares/configure.ac 2013-05-12 13:44:39.353684194 +0200
+@@ -7,7 +7,7 @@
+ CARES_OVERRIDE_AUTOCONF
+
+ AC_CONFIG_SRCDIR([ares_ipv6.h])
+-AM_CONFIG_HEADER([ares_config.h ares_build.h])
++AC_CONFIG_HEADER([ares_config.h ares_build.h])
+ AC_CONFIG_MACRO_DIR([m4])
+ AM_MAINTAINER_MODE
+
+--- src/other/curl/configure.ac.old 2013-05-12 13:49:00.814352825 +0200
++++ src/other/curl/configure.ac 2013-05-12 13:49:15.216341340 +0200
+@@ -34,7 +34,7 @@
+ terms of the curl license; see COPYING for more details])
+
+ AC_CONFIG_SRCDIR([lib/urldata.h])
+-AM_CONFIG_HEADER(lib/curl_config.h src/curl_config.h include/curl/curlbuild.h)
++AC_CONFIG_HEADER(lib/curl_config.h src/curl_config.h include/curl/curlbuild.h)
+ AC_CONFIG_MACRO_DIR([m4])
+ AM_MAINTAINER_MODE
+
diff --git a/games-action/bzflag/files/bzflag-2.4.4-configure.patch b/games-action/bzflag/files/bzflag-2.4.4-configure.patch
new file mode 100644
index 000000000000..b280621f6ec2
--- /dev/null
+++ b/games-action/bzflag/files/bzflag-2.4.4-configure.patch
@@ -0,0 +1,37 @@
+diff -ru bzflag-2.4.4.orig/configure.ac bzflag-2.4.4/configure.ac
+--- bzflag-2.4.4.orig/configure.ac 2016-02-14 19:09:51.000000000 -0500
++++ bzflag-2.4.4/configure.ac 2016-05-05 16:35:35.475935345 -0400
+@@ -215,7 +215,7 @@
+ AC_SUBST(AR)
+ AC_SUBST(AR_FLAGS)
+
+-AC_PATH_PROG(CCACHE, ccache)
++AC_PATH_PROG(CCACHE, ccachex)
+ if test "$CCACHE" ; then
+ CC="ccache $CC"
+ CXX="ccache $CXX"
+@@ -747,13 +747,13 @@
+ #
+ # the GCC version is known to be at least 4.3 because it has C++0x support
+ # possible future warnings: -Wconversion (1894) -Wfloat-equal (317)
+-FLAGS="-Wall -Wextra -Wcast-qual -Wredundant-decls -Wshadow -Wundef -pedantic"
++FLAGSx="-Wall -Wextra -Wcast-qual -Wredundant-decls -Wshadow -Wundef -pedantic"
+ case $host_os in
+ linux*)
+ AC_DEFINE(HALF_RATE_AUDIO, 1, [Half rate Audio])
+ CONF_CFLAGS="$CONF_CFLAGS $FLAGS"
+ CONF_CXXFLAGS="$CONF_CXXFLAGS $FLAGS"
+- case $host_vendor in
++ case $host_vendorx in
+ pc)
+ if expr `$CC -dumpversion` \>= "3.4" > /dev/null ; then
+ FLAGS=-mtune
+@@ -836,7 +836,7 @@
+ CXXFLAGS="$user_CXXFLAGS"
+ AC_DEFINE(DEBUG, 1, [Debugging enabled])
+ else
+- if test "$GCC" = yes ; then
++ if test "$GCC" = yesx ; then
+ case "`$CC --version 2>&1`" in
+ *LLVM*)
+ # Apple LLVM falsely claims to be GCC
diff --git a/games-action/bzflag/files/bzflag-2.4.6-configure.patch b/games-action/bzflag/files/bzflag-2.4.6-configure.patch
new file mode 100644
index 000000000000..b280621f6ec2
--- /dev/null
+++ b/games-action/bzflag/files/bzflag-2.4.6-configure.patch
@@ -0,0 +1,37 @@
+diff -ru bzflag-2.4.4.orig/configure.ac bzflag-2.4.4/configure.ac
+--- bzflag-2.4.4.orig/configure.ac 2016-02-14 19:09:51.000000000 -0500
++++ bzflag-2.4.4/configure.ac 2016-05-05 16:35:35.475935345 -0400
+@@ -215,7 +215,7 @@
+ AC_SUBST(AR)
+ AC_SUBST(AR_FLAGS)
+
+-AC_PATH_PROG(CCACHE, ccache)
++AC_PATH_PROG(CCACHE, ccachex)
+ if test "$CCACHE" ; then
+ CC="ccache $CC"
+ CXX="ccache $CXX"
+@@ -747,13 +747,13 @@
+ #
+ # the GCC version is known to be at least 4.3 because it has C++0x support
+ # possible future warnings: -Wconversion (1894) -Wfloat-equal (317)
+-FLAGS="-Wall -Wextra -Wcast-qual -Wredundant-decls -Wshadow -Wundef -pedantic"
++FLAGSx="-Wall -Wextra -Wcast-qual -Wredundant-decls -Wshadow -Wundef -pedantic"
+ case $host_os in
+ linux*)
+ AC_DEFINE(HALF_RATE_AUDIO, 1, [Half rate Audio])
+ CONF_CFLAGS="$CONF_CFLAGS $FLAGS"
+ CONF_CXXFLAGS="$CONF_CXXFLAGS $FLAGS"
+- case $host_vendor in
++ case $host_vendorx in
+ pc)
+ if expr `$CC -dumpversion` \>= "3.4" > /dev/null ; then
+ FLAGS=-mtune
+@@ -836,7 +836,7 @@
+ CXXFLAGS="$user_CXXFLAGS"
+ AC_DEFINE(DEBUG, 1, [Debugging enabled])
+ else
+- if test "$GCC" = yes ; then
++ if test "$GCC" = yesx ; then
+ case "`$CC --version 2>&1`" in
+ *LLVM*)
+ # Apple LLVM falsely claims to be GCC
diff --git a/games-action/bzflag/files/bzflag-2.4.8-configure.patch b/games-action/bzflag/files/bzflag-2.4.8-configure.patch
new file mode 100644
index 000000000000..b280621f6ec2
--- /dev/null
+++ b/games-action/bzflag/files/bzflag-2.4.8-configure.patch
@@ -0,0 +1,37 @@
+diff -ru bzflag-2.4.4.orig/configure.ac bzflag-2.4.4/configure.ac
+--- bzflag-2.4.4.orig/configure.ac 2016-02-14 19:09:51.000000000 -0500
++++ bzflag-2.4.4/configure.ac 2016-05-05 16:35:35.475935345 -0400
+@@ -215,7 +215,7 @@
+ AC_SUBST(AR)
+ AC_SUBST(AR_FLAGS)
+
+-AC_PATH_PROG(CCACHE, ccache)
++AC_PATH_PROG(CCACHE, ccachex)
+ if test "$CCACHE" ; then
+ CC="ccache $CC"
+ CXX="ccache $CXX"
+@@ -747,13 +747,13 @@
+ #
+ # the GCC version is known to be at least 4.3 because it has C++0x support
+ # possible future warnings: -Wconversion (1894) -Wfloat-equal (317)
+-FLAGS="-Wall -Wextra -Wcast-qual -Wredundant-decls -Wshadow -Wundef -pedantic"
++FLAGSx="-Wall -Wextra -Wcast-qual -Wredundant-decls -Wshadow -Wundef -pedantic"
+ case $host_os in
+ linux*)
+ AC_DEFINE(HALF_RATE_AUDIO, 1, [Half rate Audio])
+ CONF_CFLAGS="$CONF_CFLAGS $FLAGS"
+ CONF_CXXFLAGS="$CONF_CXXFLAGS $FLAGS"
+- case $host_vendor in
++ case $host_vendorx in
+ pc)
+ if expr `$CC -dumpversion` \>= "3.4" > /dev/null ; then
+ FLAGS=-mtune
+@@ -836,7 +836,7 @@
+ CXXFLAGS="$user_CXXFLAGS"
+ AC_DEFINE(DEBUG, 1, [Debugging enabled])
+ else
+- if test "$GCC" = yes ; then
++ if test "$GCC" = yesx ; then
+ case "`$CC --version 2>&1`" in
+ *LLVM*)
+ # Apple LLVM falsely claims to be GCC