summaryrefslogtreecommitdiff
path: root/games-action/brutal-legend-hb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-12 01:31:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-12 01:31:22 +0100
commit3ad0a4619950efcdb234f117cb58611443537534 (patch)
tree7150119377a43327bafe10c005538363f798517e /games-action/brutal-legend-hb
parent276bf8cd1947ad9dd4295234e2ede5793ee301e6 (diff)
gentoo auto-resync : 12:07:2022 - 01:31:22
Diffstat (limited to 'games-action/brutal-legend-hb')
-rw-r--r--games-action/brutal-legend-hb/Manifest3
-rw-r--r--games-action/brutal-legend-hb/brutal-legend-hb-20130615-r3.ebuild69
-rw-r--r--games-action/brutal-legend-hb/metadata.xml26
3 files changed, 98 insertions, 0 deletions
diff --git a/games-action/brutal-legend-hb/Manifest b/games-action/brutal-legend-hb/Manifest
new file mode 100644
index 000000000000..7863f0e049bd
--- /dev/null
+++ b/games-action/brutal-legend-hb/Manifest
@@ -0,0 +1,3 @@
+DIST BrutalLegend-Linux-2013-06-15-setup.bin 8999631895 BLAKE2B 08b9db194412f61618f318e63b7e94fd789e84fa4c8ca695b59c6b3afc511945075cf0916a806a0af71dab093038bddda15667d75e4f100275a5ab676fb69123 SHA512 4099ed07cf78d62617eeac7de396aa01e4e9b0514861a1b0e8988f383b458281be0b3c84c33e2a2e85f80fbbacf8a4b381fc880b138af2e73a226a492cf9620a
+EBUILD brutal-legend-hb-20130615-r3.ebuild 1661 BLAKE2B 71aa4e021958aee2cf955eea07695c916ba6f8e99003167041f2c09db81e7ff76336109b210ada407a1d10baf48e595d54e1028bcbb57c77075339f16f32ac66 SHA512 3ddd9d24f0b883cb3544777910202c529a77cc8044795941901601609fa9b8e5572a4872b1190d88e72bd1b4292160b61749555e135eba904c422921a35986cd
+MISC metadata.xml 1121 BLAKE2B f11b6af2858d471934287af2769074b8ee0b54fc0f8b35e83a497b51889640ef70f4b0efb7e2b5b6de66142dee4121facde6c00b9f2fdb2c3577e23c65aa4458 SHA512 0681d81a3497b304d5b0d6ca9abf623a5b7a57037fbe34c1dc24d529ebb7e148b127314c37344a88a21f39de0b9db4403d4a0f5d4ff5ee74ec6e39de98879f93
diff --git a/games-action/brutal-legend-hb/brutal-legend-hb-20130615-r3.ebuild b/games-action/brutal-legend-hb/brutal-legend-hb-20130615-r3.ebuild
new file mode 100644
index 000000000000..b751bca21841
--- /dev/null
+++ b/games-action/brutal-legend-hb/brutal-legend-hb-20130615-r3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHECKREQS_DISK_BUILD="8600M"
+inherit check-reqs desktop unpacker xdg
+
+MY_PN="${PN%-hb}"
+DESCRIPTION="Rock-themed action-adventure that marries visceral action combat with open-world freedom"
+HOMEPAGE="https://www.humblebundle.com/store/brutal-legend"
+SRC_URI="BrutalLegend-Linux-${PV:0:4}-${PV:4:2}-${PV:6:2}-setup.bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+BDEPEND="
+ app-arch/unzip
+ media-libs/libpng
+"
+
+RDEPEND="
+ media-libs/glu[abi_x86_32]
+ media-libs/libsdl2[abi_x86_32,joystick,opengl,sound,video]
+ >=sys-devel/gcc-3.4[cxx]
+ >=sys-libs/glibc-2.7[stack-realign(-)]
+ sys-libs/zlib[abi_x86_32]
+ virtual/opengl[abi_x86_32]
+ !${CATEGORY}/${MY_PN}-gog
+"
+
+S="${WORKDIR}/data"
+DIR="/opt/${MY_PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip "${A}"
+}
+
+src_prepare() {
+ default
+
+ # The distributed icon is broken so fix it. pngfix exits unsuccessfully when
+ # it fixes an image, so run it again to check the fixed image.
+ pngfix --out="${T}"/Buddha.png Buddha.png ||
+ pngfix "${T}"/Buddha.png || die
+}
+
+src_install() {
+ exeinto "${DIR}"
+ doexe Buddha.bin.x86
+ dosym ../..${DIR}/Buddha.bin.x86 /usr/bin/${MY_PN}
+
+ insinto "${DIR}"
+ doins -r "${T}"/Buddha.png DFCONFIG Data/ Linux/ OGL/ Win/
+
+ exeinto "${DIR}"/lib
+ doexe lib/libfmod*.so lib/libsteam_api.so
+
+ make_desktop_entry ${MY_PN} "Brütal Legend" "${EPREFIX}${DIR}"/Buddha.png
+}
diff --git a/games-action/brutal-legend-hb/metadata.xml b/games-action/brutal-legend-hb/metadata.xml
new file mode 100644
index 000000000000..5e62fc42f009
--- /dev/null
+++ b/games-action/brutal-legend-hb/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Jack Black stars as Eddie Riggs, a roadie who’s sucked into a
+ mythical Age of Rock to fight evil, liberate an army of headbangers
+ from a life of oppression, find love, and discover his life’s
+ purpose. Heavy stuff until one realizes the universe of Brütal
+ Legend has sprung up from the mind of legendary game director Tim
+ Schafer.
+
+ Enter the world of Heavy Metal where mountains are made of
+ amplifiers, killer spiders spin guitar strings, druids want to
+ kill you, and Rock Legends roam the landscape.
+
+ Armed with a massive battle-axe, guitar, and his hot-rod, Eddie
+ will rip the faces off of demons. As Eddie, expect to crush skulls,
+ ravage the road in the Deuce, and unleash the power of Heavy Metal
+ to reign down fire from the sky — all to save humanity and become
+ a brutal legend.
+ </longdescription>
+</pkgmetadata>