summaryrefslogtreecommitdiff
path: root/games-action/atanks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/atanks
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/atanks')
-rw-r--r--games-action/atanks/Manifest4
-rw-r--r--games-action/atanks/atanks-6.4-r1.ebuild53
-rw-r--r--games-action/atanks/files/atanks-6.4-fix-build-system.patch28
-rw-r--r--games-action/atanks/metadata.xml11
4 files changed, 96 insertions, 0 deletions
diff --git a/games-action/atanks/Manifest b/games-action/atanks/Manifest
new file mode 100644
index 000000000000..8c9c1ee6f223
--- /dev/null
+++ b/games-action/atanks/Manifest
@@ -0,0 +1,4 @@
+AUX atanks-6.4-fix-build-system.patch 579 BLAKE2B 002bbbbba9981e010669f5b85cccb48816d35f1dfde0a35ef9c6cb1634cc75686b531572fa0c2163f78d49e56f15375b4cc0810798adb56b91e51e877ca3b279 SHA512 86b046c37de4ff24f30dce799f32674d33930605c9da32a1c95e8438f6573e66f46455cbf371f66a1b4d8240c608dd338376be150bab59d4048bb46326f82daa
+DIST atanks-6.4.tar.gz 6059315 BLAKE2B ea217b5dceaf63e85e3772369ebab1f76d35175cf8e2d0914e2806db8209f9d4721590f8a285bbfe0938f4957eec409e1581189257f117ec5d5e4c3af59707c1 SHA512 e9410e5bf0e8ec0281718ad8ddca74b67000db96b09b6af8aa906bbf2cd815f07ff550087ecdee2e4c5bfabc42941f184173f35e50538e57bb008372a599e1e6
+EBUILD atanks-6.4-r1.ebuild 971 BLAKE2B 88e97b1497c2d0fb55f1038eb74f1e21e91dff44f610d6b9158427e3abd12ddb3050ef425221701d70667b066f9a2d5cc46f0335f7e1f8e36788d79c673cd790 SHA512 6b855aacfec1311d5c85bdbbf1607829c81183e15e3fbddcd2177492184eab1b94c1d250e3b269783602e4d0e37bdc8da1664a944ed8cb6bf586eea45950caba
+MISC metadata.xml 329 BLAKE2B 7a85aeb104fe2068285701ff8f771f7337a7b5f884b33e683206be3d66aca6e1fbfc611b312e71288ec842c28790bf025b979235677387d72070aa85f0bf0adc SHA512 1dc2914fc7dfe5c7f87ac565b6183b50d281fdf768e05cf211309699a264fde8a3e434ed07049b984e6f116256fec2124ed458ccfc70374ff35ff3189ec57917
diff --git a/games-action/atanks/atanks-6.4-r1.ebuild b/games-action/atanks/atanks-6.4-r1.ebuild
new file mode 100644
index 000000000000..ed2deed79042
--- /dev/null
+++ b/games-action/atanks/atanks-6.4-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils gnome2-utils toolchain-funcs
+
+DESCRIPTION="Worms and Scorched Earth-like game"
+HOMEPAGE="http://atanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atanks/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/allegro:0[X]"
+RDEPEND=${DEPEND}
+
+PATCHES=( "${FILESDIR}"/${PN}-6.4-fix-build-system.patch )
+
+src_configure() {
+ tc-export CXX
+}
+
+src_compile() {
+ emake \
+ INSTALLDIR="${EPREFIX}/usr/share/${PN}"
+}
+
+src_install() {
+ dobin ${PN}
+ local DOCS=( Changelog README TODO )
+ einstalldocs
+
+ insinto /usr/share/${PN}
+ doins -r button misc missile sound stock tank tankgun text title unicode.dat *.txt
+
+ doicon -s 48 ${PN}.png
+ make_desktop_entry atanks "Atomic Tanks"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-action/atanks/files/atanks-6.4-fix-build-system.patch b/games-action/atanks/files/atanks-6.4-fix-build-system.patch
new file mode 100644
index 000000000000..e13ebb1d1421
--- /dev/null
+++ b/games-action/atanks/files/atanks-6.4-fix-build-system.patch
@@ -0,0 +1,28 @@
+* Don't try to find where $(CXX) is, just use it
+* Don't muck with CXXFLAGS
+
+--- a/Makefile
++++ b/Makefile
+@@ -85,13 +85,9 @@
+ # ------------------------------------
+ INSTALL := $(shell which install)
+ RM := $(shell which rm) -f
+-CXX ?= g++
+ SED := $(shell which sed)
+ WINDRES :=
+
+-ifeq (,$(findstring /,$(CXX)))
+- CXX := $(shell which $(CXX))
+-endif
+
+
+ # if this is a Windows target, prefer mingw32-g++ over g++
+@@ -231,8 +227,6 @@
+ CPPFLAGS := ${CPPFLAGS} -DATANKS_DEBUG_LOGTOFILE
+ endif
+
+-else
+- CXXFLAGS := -march=native ${CXXFLAGS} -O2
+ endif
+
+
diff --git a/games-action/atanks/metadata.xml b/games-action/atanks/metadata.xml
new file mode 100644
index 000000000000..f4e068857c3f
--- /dev/null
+++ b/games-action/atanks/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">atanks</remote-id>
+ </upstream>
+</pkgmetadata>