summaryrefslogtreecommitdiff
path: root/games-action/atanks/atanks-6.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /games-action/atanks/atanks-6.5.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'games-action/atanks/atanks-6.5.ebuild')
-rw-r--r--games-action/atanks/atanks-6.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-action/atanks/atanks-6.5.ebuild b/games-action/atanks/atanks-6.5.ebuild
new file mode 100644
index 000000000000..1efffe797e76
--- /dev/null
+++ b/games-action/atanks/atanks-6.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop gnome2-utils toolchain-funcs
+
+DESCRIPTION="Worms and Scorched Earth-like game"
+HOMEPAGE="https://atanks.sourceforge.io/"
+SRC_URI="mirror://sourceforge/atanks/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-libs/allegro:0[X]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-6.4-fix-build-system.patch )
+
+src_configure() {
+ tc-export CXX
+}
+
+src_compile() {
+ emake INSTALLDIR="${EPREFIX}/usr/share/${PN}"
+}
+
+src_install() {
+ dobin ${PN}
+
+ local DOCS=( Changelog README TODO )
+ einstalldocs
+
+ insinto /usr/share/${PN}
+ doins -r button misc missile sound stock tank tankgun text title unicode.dat *.txt
+
+ doicon -s 48 ${PN}.png
+ make_desktop_entry atanks "Atomic Tanks"
+}