summaryrefslogtreecommitdiff
path: root/games-action/atanks/atanks-6.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /games-action/atanks/atanks-6.5.ebuild
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'games-action/atanks/atanks-6.5.ebuild')
-rw-r--r--games-action/atanks/atanks-6.5.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/games-action/atanks/atanks-6.5.ebuild b/games-action/atanks/atanks-6.5.ebuild
index 1efffe797e76..0c043402a9a0 100644
--- a/games-action/atanks/atanks-6.5.ebuild
+++ b/games-action/atanks/atanks-6.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop gnome2-utils toolchain-funcs
+inherit desktop toolchain-funcs
DESCRIPTION="Worms and Scorched Earth-like game"
HOMEPAGE="https://atanks.sourceforge.io/"
@@ -13,28 +13,27 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="media-libs/allegro:0[X]"
-RDEPEND="${DEPEND}"
+RDEPEND="media-libs/allegro:0[X]"
+DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${PN}-6.4-fix-build-system.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.4-fix-build-system.patch
+)
-src_configure() {
+src_compile() {
tc-export CXX
-}
-src_compile() {
emake INSTALLDIR="${EPREFIX}/usr/share/${PN}"
}
src_install() {
dobin ${PN}
- local DOCS=( Changelog README TODO )
- einstalldocs
+ dodoc Changelog README TODO
insinto /usr/share/${PN}
doins -r button misc missile sound stock tank tankgun text title unicode.dat *.txt
- doicon -s 48 ${PN}.png
+ doicon ${PN}.png
make_desktop_entry atanks "Atomic Tanks"
}