summaryrefslogtreecommitdiff
path: root/games-action/astromenace
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /games-action/astromenace
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'games-action/astromenace')
-rw-r--r--games-action/astromenace/Manifest5
-rw-r--r--games-action/astromenace/astromenace-1.3.2-r1.ebuild74
-rw-r--r--games-action/astromenace/astromenace-1.4.1.ebuild65
-rw-r--r--games-action/astromenace/metadata.xml11
4 files changed, 155 insertions, 0 deletions
diff --git a/games-action/astromenace/Manifest b/games-action/astromenace/Manifest
new file mode 100644
index 000000000000..4ccb8b3d4cce
--- /dev/null
+++ b/games-action/astromenace/Manifest
@@ -0,0 +1,5 @@
+DIST astromenace-1.3.2.tar.gz 64643636 BLAKE2B f3b7dfbeeed56eab8946e122bebf98baa37b7a3e4291007d4f0bb12a220c26ded063f51fcd6f529c9f00cd4b6172d37dcb0798d41e553c682556ba7f4243bce7 SHA512 dd24dc80e0a6b1d47a5e6874ee8aac58790518ef7a910573b6fd7a71541cd811774a8607e6c175c51fb03983d0799db7acbafb79b167dee3bdb79ff6168c1451
+DIST astromenace-1.4.1.tar.gz 68041500 BLAKE2B a6e0c98feae200440bc3e3bd0e3338325ce7953f4e4241d69e1d3b6cc3aaef54c1966f62b08a27aef2a6f6b1ee028e8c7c78788aabc2622bcc1eeab10186c428 SHA512 408fd8a9fcc51d0cdfd31d77bc1c05b079b3248622a252e73e1145db9715b3a331eef5fde295c3390143fb7bb2f88460d374eddea719b6452577bf5e83bd14c1
+EBUILD astromenace-1.3.2-r1.ebuild 1480 BLAKE2B b4410c0f25f4357834bf4a545f7809640eb3eee05b64b0c7d153d5bcf8ce76fb3bee7d9bbe84077d79fc738c788d3a57e31cc72e10a4d8e6af52e8a933e0c562 SHA512 e3e6958cb3f220367b107d8525e7b46f1b73395f03021f10dac625474a16894d4658f1435dcf2111be3bb240983175169fd0d7ea9f69957ad45438a1c7f40ba1
+EBUILD astromenace-1.4.1.ebuild 1313 BLAKE2B a7e07dd22cb83b865a41254f5b8970b64f7c4cb174a12013a552f3246cfdd62da25dd341d8a00847171e42e90a13bb71918c32b482e82e41f3023a73abbef6a4 SHA512 adc0bce2292bc3b5d404f05b4e37d0c4fe0df9452974a2f6174741cf47936278f1dc865a97bd1641f1e2f3110ce6bcc9e2881f3442d948fed96a39bc19cf9e4b
+MISC metadata.xml 338 BLAKE2B 6c318ab57a89bd4e1ae46723bf6d0a64e7ef78f8507dabbfb8a0ff3f39b58ce5642f04e2d65d93722d74a4783b67fe860513785a12098aa7ee03f8d7df2054f6 SHA512 b2364e10d11ba13a39560816a4b7bc99bd00eb5917e81842a909813cd0fe55bb5324baf4181238fcd1122508bde58f2f0d064c6d6cf52401bc7a76372c6e6e44
diff --git a/games-action/astromenace/astromenace-1.3.2-r1.ebuild b/games-action/astromenace/astromenace-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..66ea563b64ba
--- /dev/null
+++ b/games-action/astromenace/astromenace-1.3.2-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils desktop gnome2-utils
+
+DESCRIPTION="Hardcore 3D space scroll-shooter with spaceship upgrade possibilities"
+HOMEPAGE="https://viewizard.com"
+SRC_URI="https://github.com/viewizard/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 GPL-3+ CC-BY-SA-3.0 UbuntuFontLicense-1.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ media-libs/freealut
+ media-libs/freetype:2
+ media-libs/libogg
+ media-libs/libsdl[joystick,video,X]
+ media-libs/libvorbis
+ media-libs/openal
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXinerama"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # no messing with CXXFLAGS please.
+ sed -i -e '/-Os/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=("-DDATADIR=/usr/share/${PN}")
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ "${CMAKE_BUILD_DIR}"/AstroMenace --pack \
+ --rawdata="${S}"/RAW_VFS_DATA \
+ --dir=$(dirname "${CMAKE_BUILD_DIR}") || die
+}
+
+src_install() {
+ newbin "${CMAKE_BUILD_DIR}"/AstroMenace "${PN}"
+
+ insinto /usr/share/${PN}
+ doins ../*.vfs
+
+ newicon -s 128 astromenace_128.png ${PN}.png
+ newicon -s 64 astromenace_64.png ${PN}.png
+
+ dodoc ChangeLog.txt ReadMe.txt
+
+ make_desktop_entry "${PN}" AstroMenace
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-action/astromenace/astromenace-1.4.1.ebuild b/games-action/astromenace/astromenace-1.4.1.ebuild
new file mode 100644
index 000000000000..3300882e709e
--- /dev/null
+++ b/games-action/astromenace/astromenace-1.4.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils desktop xdg-utils
+
+DESCRIPTION="Hardcore 3D space scroll-shooter with spaceship upgrade possibilities"
+HOMEPAGE="https://viewizard.com"
+SRC_URI="https://github.com/viewizard/astromenace/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 GPL-3+ CC-BY-SA-4.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/freealut
+ media-libs/freetype:2
+ media-libs/libogg
+ media-libs/libsdl[joystick,video,X]
+ media-libs/libvorbis
+ media-libs/openal
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXinerama"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # no messing with CXXFLAGS please.
+ sed -i -e '/-Os/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=( -DDATADIR="${EPREFIX}/usr/share/${PN}" )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ dobin "${BUILD_DIR}"/astromenace
+
+ insinto /usr/share/${PN}
+ doins "${BUILD_DIR}"/gamedata.vfs
+
+ newicon -s 128 share/astromenace_128.png ${PN}.png
+ newicon -s 64 share/astromenace_64.png ${PN}.png
+
+ dodoc CHANGELOG.md README.md
+
+ make_desktop_entry "${PN}" AstroMenace
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/games-action/astromenace/metadata.xml b/games-action/astromenace/metadata.xml
new file mode 100644
index 000000000000..6894dd761700
--- /dev/null
+++ b/games-action/astromenace/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">openastromenace</remote-id>
+ </upstream>
+</pkgmetadata>