summaryrefslogtreecommitdiff
path: root/games-action/0verkill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-action/0verkill
reinit the tree, so we can have metadata
Diffstat (limited to 'games-action/0verkill')
-rw-r--r--games-action/0verkill/0verkill-0.16-r3.ebuild62
-rw-r--r--games-action/0verkill/0verkill-0.16-r4.ebuild62
-rw-r--r--games-action/0verkill/Manifest13
-rw-r--r--games-action/0verkill/files/0verkill-0.16-CC.patch50
-rw-r--r--games-action/0verkill/files/0verkill-0.16-docs.patch32
-rw-r--r--games-action/0verkill/files/0verkill-0.16-gentoo-paths.patch23
-rw-r--r--games-action/0verkill/files/0verkill-0.16-home-overflow.patch26
-rw-r--r--games-action/0verkill/files/0verkill-0.16-ovflfix.patch24
-rw-r--r--games-action/0verkill/files/0verkill-0.16-segv.patch39
-rw-r--r--games-action/0verkill/files/0verkill-0.16-underflow-check.patch17
-rw-r--r--games-action/0verkill/metadata.xml8
11 files changed, 356 insertions, 0 deletions
diff --git a/games-action/0verkill/0verkill-0.16-r3.ebuild b/games-action/0verkill/0verkill-0.16-r3.ebuild
new file mode 100644
index 000000000000..633abcca11bb
--- /dev/null
+++ b/games-action/0verkill/0verkill-0.16-r3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="a bloody 2D action deathmatch-like game in ASCII-ART"
+HOMEPAGE="http://artax.karlin.mff.cuni.cz/~brain/0verkill/"
+SRC_URI="http://artax.karlin.mff.cuni.cz/~brain/0verkill/release/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/libXpm )"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-docs.patch \
+ "${FILESDIR}"/${P}-home-overflow.patch \
+ "${FILESDIR}"/${P}-segv.patch \
+ "${FILESDIR}"/${P}-gentoo-paths.patch \
+ "${FILESDIR}"/${P}-ovflfix.patch \
+ "${FILESDIR}"/${P}-CC.patch \
+ "${FILESDIR}"/${P}-underflow-check.patch #136222 \
+ sed -i \
+ -e "s:data/:${GAMES_DATADIR}/${PN}/data/:" cfg.h || die
+ sed -i \
+ -e "s:@CFLAGS@ -O3 :@CFLAGS@ :" Makefile.in || die
+ sed -i \
+ -e "/gettimeofday/s/getopt/getopt calloc/" configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf $(use_with X x)
+}
+
+src_install() {
+ local x
+ dogamesbin 0verkill
+ for x in avi bot editor server test_server ; do
+ newgamesbin ${x} 0verkill-${x}
+ done
+ if use X ; then
+ dogamesbin x0verkill
+ for x in avi editor ; do
+ newgamesbin ${x} 0verkill-${x}
+ done
+ fi
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data grx
+
+ dohtml doc/*.html
+ rm doc/*.html doc/README.OS2 doc/Readme\ Win32.txt doc/COPYING
+ dodoc doc/*
+
+ prepgamesdirs
+}
diff --git a/games-action/0verkill/0verkill-0.16-r4.ebuild b/games-action/0verkill/0verkill-0.16-r4.ebuild
new file mode 100644
index 000000000000..b512d03cdb80
--- /dev/null
+++ b/games-action/0verkill/0verkill-0.16-r4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="a bloody 2D action deathmatch-like game in ASCII-ART"
+HOMEPAGE="http://artax.karlin.mff.cuni.cz/~brain/0verkill/"
+SRC_URI="http://artax.karlin.mff.cuni.cz/~brain/0verkill/release/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/libXpm )"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-docs.patch
+ "${FILESDIR}"/${P}-home-overflow.patch
+ "${FILESDIR}"/${P}-segv.patch
+ "${FILESDIR}"/${P}-gentoo-paths.patch
+ "${FILESDIR}"/${P}-ovflfix.patch
+ "${FILESDIR}"/${P}-CC.patch
+ "${FILESDIR}"/${P}-underflow-check.patch #136222
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:data/:/usr/share/${PN}/data/:" cfg.h || die
+ sed -i \
+ -e "s:@CFLAGS@ -O3 :@CFLAGS@ :" Makefile.in || die
+ sed -i \
+ -e "/gettimeofday/s/getopt/getopt calloc/" configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with X x)
+}
+
+src_install() {
+ local x
+ dobin 0verkill
+ for x in avi bot editor server test_server ; do
+ newbin ${x} 0verkill-${x}
+ done
+ if use X ; then
+ dobin x0verkill
+ for x in avi editor ; do
+ newbin ${x} 0verkill-${x}
+ done
+ fi
+
+ insinto "/usr/share/${PN}"
+ doins -r data grx
+
+ rm doc/README.OS2 doc/Readme\ Win32.txt doc/COPYING
+ dodoc -r doc/
+}
diff --git a/games-action/0verkill/Manifest b/games-action/0verkill/Manifest
new file mode 100644
index 000000000000..ea088b698acc
--- /dev/null
+++ b/games-action/0verkill/Manifest
@@ -0,0 +1,13 @@
+AUX 0verkill-0.16-CC.patch 3795 SHA256 24f539547849de1541f2bff9450877416f46559e08dfc47c1d5d1f3abedd5326 SHA512 ea3c848d20e4a3ce197104dac2ff26948c7bdd77eb03a7492f6d62cf6cb316c12a38f3d4555bdac87582692ce4ff15794c2996a6015a2ea18398cb84b8dee022 WHIRLPOOL 3014a8b30b1dfbb2077b2e1f256ef893b3aa39af6541f768d1fe05320c62bff059c3344f6cdf31b3117f6a500a1e2a2a0b3078d4c42742ad20e1a549cc4b6fbe
+AUX 0verkill-0.16-docs.patch 1477 SHA256 aa866aa38f93ac4fee8fe72f58dfd7ce6311780303169917a79fdc479ed2d1b6 SHA512 a1ce9ca8083855b77747f0ea32587651d9e7bdf3f41406bed6e8f76debd7fe475681a1a59571b3244a65864700db18bc5fe48858113ea22ee00cd7feff13438d WHIRLPOOL fc7eff2f8d8cb7e54ed2896b8f31485179c2c3c9a266c56dc3f524acccfe179ece24956fe3d97fb59d64205264f2ebb2c222d53a4af67d42ac71ad5425105a0b
+AUX 0verkill-0.16-gentoo-paths.patch 530 SHA256 3d6d128cc48e8618e698457163e44333e12f3a79ff3f03ed55d922c3d49502ce SHA512 9419b990df205c93baf4d2e2391269f2543bc2b6ba9a3d0219983be518cce01d4a1384ce9cc0dfd8ffba743e8879658b70859e6f7a4df0b97a47186dd90b3337 WHIRLPOOL 16357c64451077051a66a8eb7ae83850bd80a3b2252c9e6b79e06b38e7f323513dd9df68e51021461c318b5583b5a719c0e0dcfd24b701213bc456f069092877
+AUX 0verkill-0.16-home-overflow.patch 724 SHA256 fab4e4249168f4a2409a4bcb3417a12a500ee33368873d9004d4e5725578e2a6 SHA512 379edf4f8f9bd31d38bd39812bd0602429afb4254e040cb9f5677764bfe4e34fede5f6e0d07c27e691c9682e205c78fa53109b8c1e4ca6be509d06e752eb08b5 WHIRLPOOL 38f72582a90adc5619ddf27f1fb5bed3d514f26322b77778a50c39b50ef9c8f9145cf15882f20b5bc5c9c6b29382c6665b4c35ce548e429741426c679f4bb0de
+AUX 0verkill-0.16-ovflfix.patch 805 SHA256 437c92bdd39d44842fad0ee8386e4dae2093c51ab2d04b54a04059ab471d017f SHA512 ad4f57d6d44c663af4d7a2b75c680ad287f582a5c7b4038e392bdc6425c5819de719e0dadd38e45d784d077f22eb5d098fd0e65c7ecb8bd29824b4fb81032220 WHIRLPOOL 6ebf9d3c78c3ee2b1ae30725dc7b11a9302a1d6086a32b15913428a140d03f5de0984e7c709b0294aff2cde87d9c033f4b91d7e0c48ddb96ee1e7f560306bb3f
+AUX 0verkill-0.16-segv.patch 1560 SHA256 b49cb1a14667cc4033e6094f99a9ddc1ef242381acac83a3abdeebf208724291 SHA512 05ce966d80cf199a9602cb7143a2d7e8479ccb4b03da2275dc8a93a9065d387fe15426c48559279acb73eb3c371306a02706de899d5c6a97c123319426b3f6bc WHIRLPOOL 9578ee8bd00cdb6860a348a6aa37c1ac3efc9ccead20152d3317377e2afec99798b523d8e0d458699d6ecd10d86e35b25416c8e11b5bc555d1b72b34b0502e8a
+AUX 0verkill-0.16-underflow-check.patch 675 SHA256 e918e3b2b632632cca8c337caf019b0c2565ded120b8055a4d31677d446ef8e5 SHA512 3b5bff2c18c1862fadbb3d932be23f35559ed9eb3ffb979cf11c50bbac9fff8928b5ead8349ddfc78c84d07a5d1afe4431af56263568b3b82fd7cb015f442e42 WHIRLPOOL 1ba725a9232cd2374d4273a770c1223ebae68d81486e4443c5d9a6ebd7fe12d8a20815b07d2afe6e8d40948aa81c9e19ec440bbd313b9876b7baec73453caf42
+DIST 0verkill-0.16.tgz 276579 SHA256 8091261c3fef3535edb97ab46cb48c067befb329e951bfa3f1b54ae6b7e1dadf SHA512 6ab273085f2be3a6d0a2b785a51a9bfd52add0212b3c8522b22255c4e3e48a9470f20d9d678158233da9c9465563279079c29ca5526d322247f2ef1d74107144 WHIRLPOOL 7a1dff93014ea67f6d16efea408ed77219a391b015a0d533a53d52eb735d8b84c8cc0f4e1cb6997aca2b3d238b57f7cff780f11fe838ded362769529cf437665
+EBUILD 0verkill-0.16-r3.ebuild 1444 SHA256 d88c79dafd84a385b91a421ad7bdbe13d1d766ef45304a2189b4e6b323ac3729 SHA512 922583a76d0efc8e1cb80c20e98e36fdad24eba3cd26432bf91b350b15ab8f214412a89bd6c2559532fb0afb29533ebd147ff7a93d0256a8e31ddb785bd20cc9 WHIRLPOOL 61e5abefc85033fedb1af22333aaf3ed972deab7547670b822826d71d60e7688a5c4463d36b57b9c7ac93a8015adf1a67522b8cb2a683d4c1914a96023108b0e
+EBUILD 0verkill-0.16-r4.ebuild 1357 SHA256 7c3d1955848c9bea9b1f6ba10245c3d63575431c2244e1f1b6f2ec24b77d8932 SHA512 886bbb6cf2c2ee91e04ca4c2305a81980fe135b0c2945ebb6911e0abe6d7c304a6e8df8f311d79e11c5637af8c8b4595dbd22db4622aad28bee94c9edf0b1e06 WHIRLPOOL 2979c1ae3ccb644acfae1c9fdaffb880519cd6ceb0696d6597be70a6e3b0231d8c193bc5ea921a5744c0ddf246cd091c7db4e4bdf8b6639fb5567a4a5db8ec4e
+MISC ChangeLog 3253 SHA256 a43fba250411ce853c279fc0accdc0cea8b5328f8a42ee28d2cb34f909380bf7 SHA512 2cac7a43f6a2a7ddcc67618750b53b3c73b83112a042589d1d198b9954bd2211bcfa28da3d7ff9c545beed3dea1bcf59527928851aefdc3ecf2813de895ba2dd WHIRLPOOL f3bbf18bd555a429721a3131b582864f3fc4b81f5a73c09f24214a79c8c9aaf6d8253c0427b4a502d6e322140163c2ff4909ba56881ddf73893a6aba08f6e8b8
+MISC ChangeLog-2015 2606 SHA256 1974704c5722bdd51f6d91e620c791f110bb94838d35ceeb943873d0a3260d1e SHA512 51aa9146da9c9b4f1a2eb5167fe7000093a7db8e2e8cc12cff0a736e70e869671408d1b4fd9ae577ad1e3d654a82de0a96fff31337dc86f08e6b82c5c8f15829 WHIRLPOOL 9ecb5ee655fe2e6a96c7d123bb0f3252a330a7ee2bb4de63769f62797c795b8c6fb214d0544021b9dc3c3e3532fdc73e88f71842d82324039cc1a67e14ae5b47
+MISC metadata.xml 249 SHA256 943b9ce0cd072229b43569ab668dd7ec741d9dfefd942c8921dabd4490b27b0c SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118 WHIRLPOOL b10e21575c78e201a652c8582cd16e3f7c86b13dd20a30f4cea44066fb139440b3c186147dbaae83478f11a20b6f457a99c8b29ee1239a4caaa21eee01250088
diff --git a/games-action/0verkill/files/0verkill-0.16-CC.patch b/games-action/0verkill/files/0verkill-0.16-CC.patch
new file mode 100644
index 000000000000..568f8a4aa6f2
--- /dev/null
+++ b/games-action/0verkill/files/0verkill-0.16-CC.patch
@@ -0,0 +1,50 @@
+--- a/Makefile.in 2010-11-08 13:30:42.060916323 -0500
++++ b/Makefile.in 2010-11-08 13:31:03.199940471 -0500
+@@ -24,7 +24,7 @@
+ server.o: server.c server.h net.h data.h hash.h cfg.h time.h math.h config.h error.h
+ client.o: client.c data.h sprite.h cfg.h net.h hash.h time.h math.h console.h help.h blit.h config.h error.h
+ xclient.o: client.c data.h sprite.h cfg.h net.h hash.h time.h math.h console.h help.h config.h error.h
+- gcc -c $(CFLAGS) -DXWINDOW -o xclient.o client.c
++ $(CC) -c $(CFLAGS) -DXWINDOW -o xclient.o client.c
+ time.o: time.c time.h error.h
+ help.o: help.c blit.h error.h
+ avihelp.o: avihelp.c blit.h error.h
+@@ -38,29 +38,29 @@
+
+
+ avi: avi.o blit.o console.o kbd.o time.o avihelp.o error.o
+- gcc $(LDFLAGS) -o avi avi.o blit.o console.o kbd.o error.o time.o avihelp.o $(LIBS)
++ $(CC) $(LDFLAGS) -o avi avi.o blit.o console.o kbd.o error.o time.o avihelp.o $(LIBS)
+
+ xavi: avi.o blit.o xinterface.o xkbd.o time.o avihelp.o error.o
+- gcc $(LDFLAGS) -o xavi avi.o blit.o xinterface.o xkbd.o error.o time.o avihelp.o $(LIBS) $(XLIBS)
++ $(CC) $(LDFLAGS) -o xavi avi.o blit.o xinterface.o xkbd.o error.o time.o avihelp.o $(LIBS) $(XLIBS)
+
+ bot: bot.o data.o hash.o time.o net.o crc32.o md5.o md5hl.o error.o
+- gcc $(LDFLAGS) -o bot bot.o data.o hash.o time.o net.o error.o md5.o md5hl.o crc32.o sprite.o $(LIBS)
++ $(CC) $(LDFLAGS) -o bot bot.o data.o hash.o time.o net.o error.o md5.o md5hl.o crc32.o sprite.o $(LIBS)
+
+ 0verkill: client.o data.o sprite.o blit.o console.o hash.o time.o net.o error.o crc32.o md5.o md5hl.o kbd.o help.o
+- gcc $(LDFLAGS) -o 0verkill client.o data.o sprite.o blit.o console.o error.o hash.o time.o md5.o md5hl.o kbd.o net.o crc32.o help.o $(LIBS)
++ $(CC) $(LDFLAGS) -o 0verkill client.o data.o sprite.o blit.o console.o error.o hash.o time.o md5.o md5hl.o kbd.o net.o crc32.o help.o $(LIBS)
+ @OVERKILL_SPECIAL@
+
+ x0verkill: xclient.o data.o sprite.o blit.o xinterface.o hash.o time.o net.o crc32.o error.o xkbd.o help.o md5.o md5hl.o
+- gcc $(LDFLAGS) -o x0verkill xclient.o data.o blit.o sprite.o xinterface.o xkbd.o error.o md5.o md5hl.o hash.o time.o net.o crc32.o help.o $(LIBS) $(XLIBS)
++ $(CC) $(LDFLAGS) -o x0verkill xclient.o data.o blit.o sprite.o xinterface.o xkbd.o error.o md5.o md5hl.o hash.o time.o net.o crc32.o help.o $(LIBS) $(XLIBS)
+
+ server: server.o data.o sprite.o blit.o console.o hash.o time.o kbd.o net.o crc32.o md5.o md5hl.o error.o
+- gcc $(LDFLAGS) -o server server.o data.o sprite.o blit.o console.o hash.o time.o kbd.o md5.o md5hl.o error.o net.o crc32.o $(LIBS)
++ $(CC) $(LDFLAGS) -o server server.o data.o sprite.o blit.o console.o hash.o time.o kbd.o md5.o md5hl.o error.o net.o crc32.o $(LIBS)
+
+ editor: editor.o data.o blit.o sprite.o console.o hash.o time.o kbd.o md5.o md5hl.o error.o
+- gcc $(LDFLAGS) -o editor editor.o data.o blit.o sprite.o console.o hash.o md5.o md5hl.o error.o time.o kbd.o $(LIBS)
++ $(CC) $(LDFLAGS) -o editor editor.o data.o blit.o sprite.o console.o hash.o md5.o md5hl.o error.o time.o kbd.o $(LIBS)
+
+ xeditor: editor.o data.o blit.o sprite.o xinterface.o hash.o time.o xkbd.o md5.o md5hl.o error.o
+- gcc $(LDFLAGS) -o xeditor editor.o data.o blit.o sprite.o xinterface.o hash.o md5.o error.o md5hl.o time.o xkbd.o $(LIBS) $(XLIBS)
++ $(CC) $(LDFLAGS) -o xeditor editor.o data.o blit.o sprite.o xinterface.o hash.o md5.o error.o md5hl.o time.o xkbd.o $(LIBS) $(XLIBS)
+
+ test_server: test_server.o net.o data.o crc32.o blit.o sprite.o time.o hash.o console.o kbd.o md5.o md5hl.o error.o
+- gcc $(LDFLAGS) -o test_server test_server.o net.o data.o crc32.o blit.o sprite.o time.o hash.o md5.o md5hl.o error.o console.o kbd.o $(LIBS)
++ $(CC) $(LDFLAGS) -o test_server test_server.o net.o data.o crc32.o blit.o sprite.o time.o hash.o md5.o md5hl.o error.o console.o kbd.o $(LIBS)
diff --git a/games-action/0verkill/files/0verkill-0.16-docs.patch b/games-action/0verkill/files/0verkill-0.16-docs.patch
new file mode 100644
index 000000000000..90d049309f4d
--- /dev/null
+++ b/games-action/0verkill/files/0verkill-0.16-docs.patch
@@ -0,0 +1,32 @@
+--- 0verkill-0.16/doc/README.html
++++ 0verkill-0.16-gentoo/doc/README.html
+@@ -30,7 +30,7 @@
+ <center><h1><a name="running">RUNNING</a></h1></center>
+
+ <p><h2><a name="server">Running server</a></h2>
+-<p>First thing to start 0verkill is run the server - type <i>server</i>. Server
++<p>First thing to start 0verkill is run the server - type <i>0verkill-server</i>. Server
+ takes options <i>-p</i> and <i>-n</i>. As usual, option <i>-h</i> prints help.
+
+ <p> Option <i>-p</i> takes one argument: port number. Server needs UDP port
+@@ -84,9 +84,9 @@
+
+ <p><h2><a name="testserver">Testing Program</a></h2>
+
+-<p>There's <i>test_server</i> program in the distribution. It avoids testing
++<p>There's <i>0verkill-test_server</i> program in the distribution. It avoids testing
+ remote server if it's up and how many players there is. To use it simply type
+-<i>test_server -a &lt;server address&gt; -p &lt;port number &gt;</i>.
++<i>0verkill-test_server -a &lt;server address&gt; -p &lt;port number &gt;</i>.
+
+ <center><h1><a name="controls">GAME CONTROLS</a></h1></center>
+
+--- 0verkill-0.16/doc/adding_a_level.txt
++++ 0verkill-0.16-gentoo/doc/adding_a_level.txt
+@@ -19,5 +19,5 @@
+ 5) If you want to create some cool new graphics, run
+ "avi grx/graphics_file.avi". Then add it to the data/new_level.sp
+
+-6) When the level is done, run "server -lX", where X is again from (1). And
++6) When the level is done, run "0verkill-server -lX", where X is again from (1). And
+ play!
diff --git a/games-action/0verkill/files/0verkill-0.16-gentoo-paths.patch b/games-action/0verkill/files/0verkill-0.16-gentoo-paths.patch
new file mode 100644
index 000000000000..d48b758c9e53
--- /dev/null
+++ b/games-action/0verkill/files/0verkill-0.16-gentoo-paths.patch
@@ -0,0 +1,23 @@
+--- a/sprite.c 2007-11-15 18:26:30.000000000 -0500
++++ b/sprite.c 2007-11-15 18:26:57.000000000 -0500
+@@ -2,6 +2,7 @@
+ #include <ctype.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <unistd.h>
+
+ #ifndef WIN32
+ #include "config.h"
+@@ -188,6 +189,12 @@
+
+ if (!(f=fopen(filename,"rb")))
+ {
++ chdir(DATA_PATH);
++ }
++ if (!(f=fopen(filename,"rb"))) {
++ chdir(DATA_PATH "/../");
++ }
++ if (!(f=fopen(filename,"rb"))) {
+ unsigned char msg[256];
+ snprintf(msg,256,"Error opening file \"%s\"!\n",filename);
+ ERROR(msg);
diff --git a/games-action/0verkill/files/0verkill-0.16-home-overflow.patch b/games-action/0verkill/files/0verkill-0.16-home-overflow.patch
new file mode 100644
index 000000000000..63bfb5fa7a6a
--- /dev/null
+++ b/games-action/0verkill/files/0verkill-0.16-home-overflow.patch
@@ -0,0 +1,26 @@
+--- a/client.c 2001-12-16 04:26:38.000000000 -0500
++++ b/client.c 2003-11-17 15:12:52.850772508 -0500
+@@ -191,9 +191,9 @@
+ unsigned char txt[256];
+
+ #ifndef WIN32
+- sprintf(txt,"%s/%s",getenv("HOME"),CFG_FILE);
++ snprintf(txt,sizeof(txt),"%s/%s",getenv("HOME"),CFG_FILE);
+ #else
+- sprintf(txt,"./%s",CFG_FILE);
++ snprintf(txt,sizeof(txt),"./%s",CFG_FILE);
+ #endif
+ stream=fopen(txt,"r");
+ if (!stream)return;
+@@ -223,9 +223,9 @@
+ unsigned char txt[256];
+
+ #ifndef WIN32
+- sprintf(txt,"%s/%s",getenv("HOME"),CFG_FILE);
++ snprintf(txt,sizeof(txt),"%s/%s",getenv("HOME"),CFG_FILE);
+ #else
+- sprintf(txt,"./%s",CFG_FILE);
++ snprintf(txt,sizeof(txt),"./%s",CFG_FILE);
+ #endif
+ stream=fopen(txt,"w");
+ if (!stream)return;
diff --git a/games-action/0verkill/files/0verkill-0.16-ovflfix.patch b/games-action/0verkill/files/0verkill-0.16-ovflfix.patch
new file mode 100644
index 000000000000..a8a832e19619
--- /dev/null
+++ b/games-action/0verkill/files/0verkill-0.16-ovflfix.patch
@@ -0,0 +1,24 @@
+--- a/server.c 2010-11-08 11:53:18.000000000 +0100
++++ b/server.c 2010-11-08 11:53:43.000000000 +0100
+@@ -905,8 +905,8 @@
+ int len;
+
+ packet[0]=P_MESSAGE;
+- if (!name){snprintf(packet+1,256,"%s",msg);len=strlen(msg)+1+1;}
+- else {snprintf(packet+1,256,"%s> %s",name,msg);len=strlen(name)+strlen(msg)+1+3;}
++ if (!name){snprintf(packet+1,255,"%s",msg);len=strlen(msg)+1+1;}
++ else {snprintf(packet+1,255,"%s> %s",name,msg);len=strlen(name)+strlen(msg)+1+3;}
+ send_chunk_packet_to_player(packet,len,player);
+ }
+
+--- a/console.c 2010-11-08 11:53:26.000000000 +0100
++++ b/console.c 2010-11-08 11:54:44.000000000 +0100
+@@ -206,7 +206,7 @@
+ void c_setcolor_3b(unsigned char a)
+ {
+ char txt[8];
+- snprintf(txt,16,"\033[%dm",30+(a&7));
++ snprintf(txt,sizeof(txt),"\033[%dm",30+(a&7));
+ my_print(txt);
+ }
+
diff --git a/games-action/0verkill/files/0verkill-0.16-segv.patch b/games-action/0verkill/files/0verkill-0.16-segv.patch
new file mode 100644
index 000000000000..9f9656dfd9fa
--- /dev/null
+++ b/games-action/0verkill/files/0verkill-0.16-segv.patch
@@ -0,0 +1,39 @@
+diff -Naurp 0verkill-0.16.old/data.c 0verkill-0.16/data.c
+--- 0verkill-0.16.old/data.c 2007-10-30 19:49:59.000000000 +0100
++++ 0verkill-0.16/data.c 2007-10-30 20:25:08.000000000 +0100
+@@ -471,7 +471,7 @@ my_double can_go_x(my_double old_x,my_do
+ for (x=double2int(old_x)+1;x<=round_up(new_x);x++) /* go to the right */
+ {
+ if (x>AREA_X-1) return int2double(AREA_X-1);
+- for (y=yh;y<=yl;y++)
++ for (y=(yh>=0?yh:0);y<=yl;y++)
+ if ((area_a[x+y*AREA_X]&240)==TYPE_WALL)
+ return int2double(x-1);
+ }
+@@ -479,7 +479,7 @@ my_double can_go_x(my_double old_x,my_do
+ for (x=round_up(old_x)-1;x>=double2int(new_x);x--) /* go to the left */
+ {
+ if (x<0) return 0;
+- for (y=yh;y<=yl;y++)
++ for (y=(yh>=0?yh:0);y<=yl;y++)
+ if ((area_a[x+y*AREA_X]&240)==TYPE_WALL) return int2double(x+1);
+ }
+ if(flag)*flag=0;
+@@ -501,7 +501,7 @@ my_double can_go_y(my_double old_y, my_d
+ for (y=double2int(old_y)+1;y<=round_up(new_y);y++) /* go down */
+ {
+ if (y>AREA_Y-1) return int2double(AREA_Y-1);
+- for (x=xl;x<=xr;x++)
++ for (x=(xl>=0?xl:0);x<=xr;x++)
+ if ((area_a[x+y*AREA_X]&240)==TYPE_WALL||(!down_ladder&&((area_a[x+y*AREA_X]&240)==TYPE_JUMP||(area_a[x+y*AREA_X]&240)==TYPE_JUMP_FOREGROUND))) return int2double(y-1);
+ }
+ else
+@@ -510,7 +510,7 @@ my_double can_go_y(my_double old_y, my_d
+ for (y=round_up(old_y)-1;y>=double2int(new_y);y--) /* go up */
+ {
+ if (y<0) return 0;
+- for (x=xl;x<=xr;x++)
++ for (x=(xl>=0?xl:0);x<=xr;x++)
+ if ((area_a[x+y*AREA_X]&240)==TYPE_WALL) return int2double(y+1);
+ }
+ }
diff --git a/games-action/0verkill/files/0verkill-0.16-underflow-check.patch b/games-action/0verkill/files/0verkill-0.16-underflow-check.patch
new file mode 100644
index 000000000000..d0af396deafd
--- /dev/null
+++ b/games-action/0verkill/files/0verkill-0.16-underflow-check.patch
@@ -0,0 +1,17 @@
+The vulnerability is cause due to an integer underflow error in "recv_packet()"
+within the handling of a received UDP packet. This can be exploited to cause
+out-of-bounds memory access which crashes the server process via a UDP packet
+that is smaller than 12 bytes in size.
+
+http://bugs.gentoo.org/136222
+
+--- 0verkill-0.16/net.c
++++ 0verkill-0.16/net.c
+@@ -84,6 +84,7 @@
+ p=mem_alloc(max_len+12);
+ if (!p)return -1; /* not enough memory */
+ retval=recvfrom(fd,p,max_len+12,0,addr,addr_len);
++ if (retval<12)return -1; /* not enough data from network */
+ memcpy(packet,p+12,max_len);
+ crc=p[0]+(p[1]<<8)+(p[2]<<16)+(p[3]<<24);
+ s=p[4]+(p[5]<<8)+(p[6]<<16)+(p[7]<<24);
diff --git a/games-action/0verkill/metadata.xml b/games-action/0verkill/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-action/0verkill/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>