summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-17 14:06:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-17 14:06:19 +0000
commitfc6e577018dec28e18904f9ad5c1417976e3c728 (patch)
treed1bffe78e4c3db88c10e85e3efd2f7e2c0e5a156 /eclass
parente74bddc195533f6d160ee96220f5cfcc205bda1c (diff)
gentoo auto-resync : 17:01:2024 - 14:06:19
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin38961 -> 38955 bytes
-rw-r--r--eclass/kernel-install.eclass13
2 files changed, 9 insertions, 4 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index a9c150a66cea..bc33dc43e9fa 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/kernel-install.eclass b/eclass/kernel-install.eclass
index 9ab96628b5e4..2b6e80aee571 100644
--- a/eclass/kernel-install.eclass
+++ b/eclass/kernel-install.eclass
@@ -50,7 +50,7 @@ case ${EAPI} in
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
-inherit dist-kernel-utils mount-boot toolchain-funcs
+inherit dist-kernel-utils mount-boot multiprocessing toolchain-funcs
SLOT="${PV}"
IUSE="+initramfs test"
@@ -756,9 +756,14 @@ kernel-install_compress_modules() {
if use modules-compress; then
einfo "Compressing kernel modules ..."
- # taken from scripts/Makefile.modinst
- find "${ED}/lib" -name '*.ko' -exec \
- xz --check=crc32 --lzma2=dict=1MiB {} + || die
+ # xz options taken from scripts/Makefile.modinst
+ # we don't do 'xz -T' because it applies multithreading per file,
+ # so it works only for big files, and we have lots of small files
+ # instead
+ find "${ED}/lib" -name '*.ko' -print0 |
+ xargs -0 -P "$(makeopts_jobs)" -n 128 \
+ xz --check=crc32 --lzma2=dict=1MiB
+ assert "Compressing kernel modules failed"
fi
}