summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /eclass
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin38399 -> 38385 bytes
-rw-r--r--eclass/kernel-2.eclass40
-rw-r--r--eclass/linux-info.eclass50
-rw-r--r--eclass/llvm.eclass2
-rw-r--r--eclass/meson.eclass2
-rw-r--r--eclass/ros-catkin.eclass6
-rw-r--r--eclass/virtualx.eclass14
7 files changed, 53 insertions, 61 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index 5edb79a9d218..d0572b7e4841 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/kernel-2.eclass b/eclass/kernel-2.eclass
index a7501e936cad..0345061631a5 100644
--- a/eclass/kernel-2.eclass
+++ b/eclass/kernel-2.eclass
@@ -192,11 +192,10 @@
PYTHON_COMPAT=( python{2_6,2_7} )
-inherit eutils toolchain-funcs versionator multilib python-any-r1
+inherit toolchain-funcs python-any-r1
+[[ ${EAPI:-0} == [012345] ]] && inherit epatch
+[[ ${EAPI:-0} == [0123456] ]] && inherit estack eapi7-ver
case ${EAPI:-0} in
- 0|1)
- EXPORT_FUNCTIONS src_{unpack,compile,install,test} \
- pkg_{setup,preinst,postinst,postrm} ;;
2|3|4|5|6)
EXPORT_FUNCTIONS src_{unpack,prepare,compile,install,test} \
pkg_{setup,preinst,postinst,postrm} ;;
@@ -216,8 +215,6 @@ fi
HOMEPAGE="https://www.kernel.org/ https://www.gentoo.org/ ${HOMEPAGE}"
: ${LICENSE:="GPL-2"}
-has "${EAPI:-0}" 0 1 2 && ED=${D} EPREFIX= EROOT=${ROOT}
-
# This is the latest KV_PATCH of the deblob tool available from the
# libre-sources upstream. If you bump this, you MUST regenerate the Manifests
# for ALL kernel-2 consumer packages where deblob is available.
@@ -326,7 +323,7 @@ detect_version() {
OKV=${OKV/-r*}
OKV=${OKV/_p*}
- KV_MAJOR=$(get_version_component_range 1 ${OKV})
+ KV_MAJOR=$(ver_cut 1 ${OKV})
# handle if OKV is X.Y or X.Y.Z (e.g. 3.0 or 3.0.1)
local OKV_ARRAY
IFS="." read -r -a OKV_ARRAY <<<"${OKV}"
@@ -334,17 +331,17 @@ detect_version() {
# if KV_MAJOR >= 3, then we have no more KV_MINOR
#if [[ ${KV_MAJOR} -lt 3 ]]; then
if [[ ${#OKV_ARRAY[@]} -ge 3 ]]; then
- KV_MINOR=$(get_version_component_range 2 ${OKV})
- KV_PATCH=$(get_version_component_range 3 ${OKV})
+ KV_MINOR=$(ver_cut 2 ${OKV})
+ KV_PATCH=$(ver_cut 3 ${OKV})
if [[ ${KV_MAJOR}${KV_MINOR}${KV_PATCH} -ge 269 ]]; then
- KV_EXTRA=$(get_version_component_range 4- ${OKV})
+ KV_EXTRA=$(ver_cut 4- ${OKV})
KV_EXTRA=${KV_EXTRA/[-_]*}
else
- KV_PATCH=$(get_version_component_range 3- ${OKV})
+ KV_PATCH=$(ver_cut 3- ${OKV})
fi
else
- KV_PATCH=$(get_version_component_range 2 ${OKV})
- KV_EXTRA=$(get_version_component_range 3- ${OKV})
+ KV_PATCH=$(ver_cut 2 ${OKV})
+ KV_EXTRA=$(ver_cut 3- ${OKV})
KV_EXTRA=${KV_EXTRA/[-_]*}
fi
@@ -645,12 +642,7 @@ if [[ ${ETYPE} == sources ]]; then
DEBLOB_CHECK_A="deblob-check-${DEBLOB_PV}"
DEBLOB_HOMEPAGE="https://www.fsfla.org/svn/fsfla/software/linux-libre/releases/tags/"
DEBLOB_URI_PATH="${DEBLOB_PV}${K_DEBLOB_TAG}"
- if ! has "${EAPI:-0}" 0 1 ; then
- DEBLOB_CHECK_URI="${DEBLOB_HOMEPAGE}/${DEBLOB_URI_PATH}/deblob-check -> ${DEBLOB_CHECK_A}"
- else
- DEBLOB_CHECK_URI="mirror://gentoo/${DEBLOB_CHECK_A}"
- fi
-
+ DEBLOB_CHECK_URI="${DEBLOB_HOMEPAGE}/${DEBLOB_URI_PATH}/deblob-check -> ${DEBLOB_CHECK_A}"
DEBLOB_URI="${DEBLOB_HOMEPAGE}/${DEBLOB_URI_PATH}/${DEBLOB_A}"
HOMEPAGE="${HOMEPAGE} ${DEBLOB_HOMEPAGE}"
@@ -1075,9 +1067,9 @@ postinst_sources() {
fi
# warn sparc users that they need to do cross-compiling with >= 2.6.25(bug #214765)
- KV_MAJOR=$(get_version_component_range 1 ${OKV})
- KV_MINOR=$(get_version_component_range 2 ${OKV})
- KV_PATCH=$(get_version_component_range 3 ${OKV})
+ KV_MAJOR=$(ver_cut 1 ${OKV})
+ KV_MINOR=$(ver_cut 2 ${OKV})
+ KV_PATCH=$(ver_cut 3 ${OKV})
if [[ "$(tc-arch)" = "sparc" ]]; then
if [[ $(gcc-major-version) -lt 4 && $(gcc-minor-version) -lt 4 ]]; then
if [[ ${KV_MAJOR} -ge 3 || ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} > 2.6.24 ]] ; then
@@ -1478,10 +1470,6 @@ kernel-2_src_unpack() {
# we run misc `make` functions below
[[ $(type -t kernel-2_hook_premake) == "function" ]] && kernel-2_hook_premake
- case ${EAPI:-0} in
- 0|1) kernel-2_src_prepare ;;
- esac
-
debug-print "Doing unpack_set_extraversion"
[[ -z ${K_NOSETEXTRAVERSION} ]] && unpack_set_extraversion
diff --git a/eclass/linux-info.eclass b/eclass/linux-info.eclass
index 6cd64457edd2..b158e345d166 100644
--- a/eclass/linux-info.eclass
+++ b/eclass/linux-info.eclass
@@ -548,6 +548,30 @@ get_version() {
return 1
fi
+ # Grab the kernel release from the output directory.
+ # TODO: we MUST detect kernel.release being out of date, and 'return 1' from
+ # this function.
+ if [ -s "${KV_DIR}"/include/config/kernel.release ]; then
+ KV_LOCAL=$(<"${KV_DIR}"/include/config/kernel.release)
+ elif [ -s "${KV_DIR}"/.kernelrelease ]; then
+ KV_LOCAL=$(<"${KV_DIR}"/.kernelrelease)
+ else
+ KV_LOCAL=
+ fi
+
+ # KV_LOCAL currently contains the full release; discard the first bits.
+ tmplocal=${KV_LOCAL#${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}${KV_EXTRA}}
+
+ # If the updated local version was not changed, the tree is not prepared.
+ # Clear out KV_LOCAL in that case.
+ # TODO: this does not detect a change in the localversion part between
+ # kernel.release and the value that would be generated.
+ if [ "$KV_LOCAL" = "$tmplocal" ]; then
+ KV_LOCAL=
+ else
+ KV_LOCAL=$tmplocal
+ fi
+
# and in newer versions we can also pull LOCALVERSION if it is set.
# but before we do this, we need to find if we use a different object directory.
# This *WILL* break if the user is using localversions, but we assume it was
@@ -555,7 +579,7 @@ get_version() {
if [[ -z ${OUTPUT_DIR} ]] ; then
# Try to locate a kernel that is most relevant for us.
for OUTPUT_DIR in "${SYSROOT}" "${ROOT%/}" "" ; do
- OUTPUT_DIR+="/lib/modules/${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}${KV_EXTRA}/build"
+ OUTPUT_DIR+="/lib/modules/${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}${KV_EXTRA}${KV_LOCAL}/build"
if [[ -e ${OUTPUT_DIR} ]] ; then
break
fi
@@ -571,30 +595,6 @@ get_version() {
# and if we STILL have not got it, then we better just set it to KV_DIR
KV_OUT_DIR="${KV_OUT_DIR:-${KV_DIR}}"
- # Grab the kernel release from the output directory.
- # TODO: we MUST detect kernel.release being out of date, and 'return 1' from
- # this function.
- if [ -s "${KV_OUT_DIR}"/include/config/kernel.release ]; then
- KV_LOCAL=$(<"${KV_OUT_DIR}"/include/config/kernel.release)
- elif [ -s "${KV_OUT_DIR}"/.kernelrelease ]; then
- KV_LOCAL=$(<"${KV_OUT_DIR}"/.kernelrelease)
- else
- KV_LOCAL=
- fi
-
- # KV_LOCAL currently contains the full release; discard the first bits.
- tmplocal=${KV_LOCAL#${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}${KV_EXTRA}}
-
- # If the updated local version was not changed, the tree is not prepared.
- # Clear out KV_LOCAL in that case.
- # TODO: this does not detect a change in the localversion part between
- # kernel.release and the value that would be generated.
- if [ "$KV_LOCAL" = "$tmplocal" ]; then
- KV_LOCAL=
- else
- KV_LOCAL=$tmplocal
- fi
-
# And we should set KV_FULL to the full expanded version
KV_FULL="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}${KV_EXTRA}${KV_LOCAL}"
diff --git a/eclass/llvm.eclass b/eclass/llvm.eclass
index 7a7695aff85c..56ebd7ed7b8d 100644
--- a/eclass/llvm.eclass
+++ b/eclass/llvm.eclass
@@ -78,7 +78,7 @@ if [[ ! ${_LLVM_ECLASS} ]]; then
# @INTERNAL
# @DESCRIPTION:
# Correct values of LLVM slots, newest first.
-declare -g -r _LLVM_KNOWN_SLOTS=( 7 6 5 4 )
+declare -g -r _LLVM_KNOWN_SLOTS=( 8 7 6 5 4 )
# @FUNCTION: get_llvm_prefix
# @USAGE: [<max_slot>]
diff --git a/eclass/meson.eclass b/eclass/meson.eclass
index f2202a04593d..45aee91f1a9b 100644
--- a/eclass/meson.eclass
+++ b/eclass/meson.eclass
@@ -59,7 +59,7 @@ EXPORT_FUNCTIONS src_configure src_compile src_test src_install
if [[ -z ${_MESON_ECLASS} ]]; then
_MESON_ECLASS=1
-MESON_DEPEND=">=dev-util/meson-0.40.0
+MESON_DEPEND=">=dev-util/meson-0.45.1
>=dev-util/ninja-1.7.2"
# @ECLASS-VARIABLE: MESON_AUTO_DEPEND
diff --git a/eclass/ros-catkin.eclass b/eclass/ros-catkin.eclass
index a556f28b4c95..17745d72ecaf 100644
--- a/eclass/ros-catkin.eclass
+++ b/eclass/ros-catkin.eclass
@@ -224,11 +224,7 @@ ros-catkin_src_test() {
einfo "Regenerating setup_cached.sh for tests"
${PYTHON:-python} catkin_generated/generate_cached_setup.py || die
fi
- # Using cmake-utils_src_make with nonfatal does not work and breaks e.g.
- # dev-ros/rviz.
- if nonfatal emake tests -n &> /dev/null ; then
- cmake-utils_src_make tests
- fi
+ nonfatal cmake-utils_src_make tests
cmake-utils_src_test "${@}"
}
diff --git a/eclass/virtualx.eclass b/eclass/virtualx.eclass
index 38e629eef4fe..cd0447a518c0 100644
--- a/eclass/virtualx.eclass
+++ b/eclass/virtualx.eclass
@@ -14,7 +14,7 @@ case "${EAPI:-0}" in
0|1|2|3)
die "virtualx.eclass: EAPI ${EAPI} is too old."
;;
- 4|5|6)
+ 4|5|6|7)
;;
*)
die "virtualx.eclass: EAPI ${EAPI} is not supported yet."
@@ -53,7 +53,11 @@ case ${VIRTUALX_REQUIRED} in
manual)
;;
always)
- DEPEND="${VIRTUALX_DEPEND}"
+ if [[ ${EAPI:-0} != [0123456] ]]; then
+ BDEPEND="${VIRTUALX_DEPEND}"
+ else
+ DEPEND="${VIRTUALX_DEPEND}"
+ fi
RDEPEND=""
;;
optional|tests)
@@ -77,7 +81,11 @@ case ${VIRTUALX_REQUIRED} in
IUSE="${VIRTUALX_USE}"
;;
*)
- DEPEND="${VIRTUALX_REQUIRED}? ( ${VIRTUALX_DEPEND} )"
+ if [[ ${EAPI:-0} != [0123456] ]]; then
+ BDEPEND="${VIRTUALX_REQUIRED}? ( ${VIRTUALX_DEPEND} )"
+ else
+ DEPEND="${VIRTUALX_REQUIRED}? ( ${VIRTUALX_DEPEND} )"
+ fi
RDEPEND=""
IUSE="${VIRTUALX_REQUIRED}"
;;