summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-15 10:03:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-15 10:03:16 +0100
commitd57892fd8c8d84b85e73005a433f66d85da12fa3 (patch)
tree6f735debac848918a243f90ae2fa6a2fb69e77ad /eclass
parent4a7e8a04f36caa88d1996b1dcdedb196bb4beb2f (diff)
gentoo auto-resync : 15:05:2023 - 10:03:16
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin37500 -> 37661 bytes
-rw-r--r--eclass/apache-2.eclass1
-rw-r--r--eclass/distutils-r1.eclass12
-rw-r--r--eclass/ruby-ng.eclass2
-rw-r--r--eclass/ruby-utils.eclass2
-rw-r--r--eclass/tests/Makefile27
6 files changed, 36 insertions, 8 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index ece92d84c9d9..0846023f39c7 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/apache-2.eclass b/eclass/apache-2.eclass
index f5816087826d..3dc3b3e56db0 100644
--- a/eclass/apache-2.eclass
+++ b/eclass/apache-2.eclass
@@ -162,6 +162,7 @@ RDEPEND="
apache2_modules_session_crypto? (
dev-libs/apr-util[openssl]
)
+ apache2_modules_tls? ( net-libs/rustls-ffi:= )
gdbm? ( sys-libs/gdbm:= )
ldap? ( net-nds/openldap:= )
selinux? ( sec-policy/selinux-apache )
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 2547af99eb76..d60fb0d72f18 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -107,7 +107,7 @@ esac
# The variable specifies the build system used. Currently,
# the following values are supported:
#
-# - flit - flit_core backend
+# - flit - flit-core backend
#
# - flit_scm - flit_scm backend
#
@@ -210,7 +210,7 @@ _distutils_set_globals() {
case ${DISTUTILS_USE_PEP517} in
flit)
bdep+='
- >=dev-python/flit_core-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/flit-core-3.8.0[${PYTHON_USEDEP}]
'
;;
flit_scm)
@@ -921,12 +921,12 @@ _distutils-r1_print_package_versions() {
case ${DISTUTILS_USE_PEP517} in
flit)
packages+=(
- dev-python/flit_core
+ dev-python/flit-core
)
;;
flit_scm)
packages+=(
- dev-python/flit_core
+ dev-python/flit-core
dev-python/flit_scm
dev-python/setuptools-scm
)
@@ -1145,7 +1145,7 @@ _distutils-r1_backend_to_key() {
local backend=${1}
case ${backend} in
- flit_core.buildapi|flit.buildapi)
+ flit-core.buildapi|flit.buildapi)
echo flit
;;
flit_scm:buildapi)
@@ -1224,7 +1224,7 @@ _distutils-r1_get_backend() {
local new_backend=
case ${build_backend} in
flit.buildapi)
- new_backend=flit_core.buildapi
+ new_backend=flit-core.buildapi
;;
poetry.masonry.api)
new_backend=poetry.core.masonry.api
diff --git a/eclass/ruby-ng.eclass b/eclass/ruby-ng.eclass
index d808b7bd98b3..8befa086ef02 100644
--- a/eclass/ruby-ng.eclass
+++ b/eclass/ruby-ng.eclass
@@ -107,7 +107,7 @@ _ruby_get_all_impls() {
for i in ${USE_RUBY}; do
case ${i} in
# removed implementations
- ruby19|ruby20|ruby21|ruby22|ruby23|ruby24|ruby25|ruby26|jruby)
+ ruby19|ruby20|ruby21|ruby22|ruby23|ruby24|ruby25|ruby26|ruby27|jruby)
;;
*)
found_valid_impl=1
diff --git a/eclass/ruby-utils.eclass b/eclass/ruby-utils.eclass
index d34ce47706ad..eef2aba2fb99 100644
--- a/eclass/ruby-utils.eclass
+++ b/eclass/ruby-utils.eclass
@@ -33,7 +33,7 @@ if [[ ! ${_RUBY_UTILS} ]]; then
# provide for a better first installation experience.
# All stable RUBY_TARGETS
-RUBY_TARGETS_PREFERENCE="ruby30 ruby27 "
+RUBY_TARGETS_PREFERENCE="ruby30 "
# All other active ruby targets
RUBY_TARGETS_PREFERENCE+="ruby31 ruby32"
diff --git a/eclass/tests/Makefile b/eclass/tests/Makefile
new file mode 100644
index 000000000000..ee4a454912c3
--- /dev/null
+++ b/eclass/tests/Makefile
@@ -0,0 +1,27 @@
+SH_FILES := $(wildcard *.sh)
+TEST_FILES := $(filter-out tests-common.sh, $(SH_FILES))
+TEST_OK_FILES := $(patsubst %.sh, .%.sh.ok,$ $(TEST_FILES))
+
+# We cache a successful test result if the testfile itself did not
+# change (%.sh) and the contents of the eclass/ directory did not
+# change (.eclasssum).
+.%.sh.ok: %.sh .eclasssum
+ ./$<
+ touch $@
+
+.PHONY: test
+test: $(TEST_OK_FILES)
+
+.PHONY: force
+.ONESHELL:
+.eclasssum: SHELL = /bin/bash
+.eclasssum: force
+ set -euo pipefail
+ find .. -maxdepth 1 -type f -name "*.eclass" \
+ -exec stat --format="%n %y" \{} \+ |\
+ sort |\
+ cksum - > $@.cur
+ trap "rm -f $@.cur" EXIT
+ if ! cmp --silent $@.cur $@; then
+ mv $@.cur $@
+ fi