summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /eclass
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin36384 -> 36387 bytes
-rw-r--r--eclass/ecm.eclass6
-rw-r--r--eclass/kernel-2.eclass2
-rw-r--r--eclass/linux-info.eclass4
-rw-r--r--eclass/linux-mod.eclass4
-rw-r--r--eclass/qt5-build.eclass9
-rw-r--r--eclass/readme.gentoo-r1.eclass7
-rw-r--r--eclass/unpacker.eclass5
8 files changed, 15 insertions, 22 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index b6913496bd25..4e41bed6001a 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/ecm.eclass b/eclass/ecm.eclass
index 5ae6e73401ef..baece9e6e637 100644
--- a/eclass/ecm.eclass
+++ b/eclass/ecm.eclass
@@ -380,7 +380,7 @@ ecm_src_prepare() {
if [[ ${ECM_HANDBOOK} = forceoptional ]] ; then
ecm_punt_bogus_dep KF5 DocTools
- sed -i -e "/kdoctools_install/ s/^/#DONT/" CMakeLists.txt || die
+ sed -i -e "/kdoctools_install/I s/^/#DONT/" CMakeLists.txt || die
fi
fi
@@ -412,12 +412,12 @@ ecm_src_prepare() {
local f pf="${T}/${P}"-tests-optional.patch
touch ${pf} || die "Failed to touch patch file"
for f in $(find . -type f -name "CMakeLists.txt" -exec \
- grep -l "^\s*add_subdirectory\s*\(\s*.*\(auto|unit\)\?tests\?\s*)\s*\)" {} \;); do
+ grep -li "^\s*add_subdirectory\s*\(\s*.*\(auto|unit\)\?tests\?\s*)\s*\)" {} \;); do
cp ${f} ${f}.old || die "Failed to prepare patch origfile"
pushd ${f%/*} > /dev/null || die
ecm_punt_bogus_dep Qt5 Test
sed -i CMakeLists.txt -e \
- "/^#/! s/add_subdirectory\s*\(\s*.*\(auto|unit\)\?tests\?\s*)\s*\)/if(BUILD_TESTING)\n&\nendif()/" \
+ "/^#/! s/add_subdirectory\s*\(\s*.*\(auto|unit\)\?tests\?\s*)\s*\)/if(BUILD_TESTING)\n&\nendif()/I" \
|| die
popd > /dev/null || die
diff -Naur ${f}.old ${f} 1>>${pf}
diff --git a/eclass/kernel-2.eclass b/eclass/kernel-2.eclass
index adc1425bc2e2..f1c27a36d99b 100644
--- a/eclass/kernel-2.eclass
+++ b/eclass/kernel-2.eclass
@@ -692,7 +692,7 @@ env_setup_xmakeopts() {
elif type -p ${CHOST}-ar >/dev/null; then
xmakeopts="${xmakeopts} CROSS_COMPILE=${CHOST}-"
fi
- xmakeopts="${xmakeopts} HOSTCC=$(tc-getBUILD_CC)"
+ xmakeopts="${xmakeopts} HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) LD=$(tc-getLD) AR=$(tc-getAR) NM=$(tc-getNM) OBJCOPY=$(tc-getOBJCOPY) READELF=$(tc-getREADELF) STRIP=$(tc-getSTRIP)"
export xmakeopts
}
diff --git a/eclass/linux-info.eclass b/eclass/linux-info.eclass
index 568f7a1a2832..a0942f0e554c 100644
--- a/eclass/linux-info.eclass
+++ b/eclass/linux-info.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: linux-info.eclass
@@ -137,8 +137,6 @@ inherit toolchain-funcs
EXPORT_FUNCTIONS pkg_setup
-IUSE="kernel_linux"
-
# Bug fixes
# fix to bug #75034
case ${ARCH} in
diff --git a/eclass/linux-mod.eclass b/eclass/linux-mod.eclass
index 9f4ae64f6b55..496b9c98b526 100644
--- a/eclass/linux-mod.eclass
+++ b/eclass/linux-mod.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: linux-mod.eclass
@@ -170,7 +170,7 @@ esac
0) die "EAPI=${EAPI} is not supported with MODULES_OPTIONAL_USE_IUSE_DEFAULT due to lack of IUSE defaults" ;;
esac
-IUSE="kernel_linux dist-kernel
+IUSE="dist-kernel
${MODULES_OPTIONAL_USE:+${_modules_optional_use_iuse_default}}${MODULES_OPTIONAL_USE}"
SLOT="0"
RDEPEND="
diff --git a/eclass/qt5-build.eclass b/eclass/qt5-build.eclass
index 8756d6e58497..a2a72bde46cd 100644
--- a/eclass/qt5-build.eclass
+++ b/eclass/qt5-build.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: qt5-build.eclass
@@ -490,13 +490,6 @@ qt5_base_configure() {
-testsdir "${QT5_TESTSDIR}"
# force appropriate compiler
- $(if use kernel_FreeBSD; then
- if tc-is-gcc; then
- echo -platform freebsd-g++
- elif tc-is-clang; then
- echo -platform freebsd-clang
- fi
- fi)
$(if use kernel_linux; then
if tc-is-gcc; then
echo -platform linux-g++
diff --git a/eclass/readme.gentoo-r1.eclass b/eclass/readme.gentoo-r1.eclass
index 3ad36fac2588..0d302179127b 100644
--- a/eclass/readme.gentoo-r1.eclass
+++ b/eclass/readme.gentoo-r1.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: readme.gentoo-r1.eclass
@@ -25,6 +25,11 @@ case ${EAPI} in
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
+# @ECLASS-VARIABLE: DOC_CONTENTS
+# @DEFAULT_UNSET
+# @DESCRIPTION:
+# The information that is used to create the README.gentoo file.
+
# @ECLASS-VARIABLE: DISABLE_AUTOFORMATTING
# @DEFAULT_UNSET
# @DESCRIPTION:
diff --git a/eclass/unpacker.eclass b/eclass/unpacker.eclass
index 74899fd77b70..4c0641d59ce1 100644
--- a/eclass/unpacker.eclass
+++ b/eclass/unpacker.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: unpacker.eclass
@@ -509,9 +509,6 @@ unpacker_src_uri_depends() {
case ${uri} in
*.cpio.*|*.cpio)
d="app-arch/cpio" ;;
- *.deb)
- # platforms like AIX don't have a good ar
- d="kernel_AIX? ( app-arch/deb2targz )" ;;
*.rar|*.RAR)
d="app-arch/unrar" ;;
*.7z)