summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /eclass
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin35978 -> 35965 bytes
-rw-r--r--eclass/cargo.eclass5
-rw-r--r--eclass/cmake-utils.eclass1
-rw-r--r--eclass/distutils-r1.eclass2
-rw-r--r--eclass/go-module.eclass81
-rw-r--r--eclass/kernel-2.eclass1
-rw-r--r--eclass/meson.eclass2
-rw-r--r--eclass/nvidia-driver.eclass2
-rw-r--r--eclass/php-ext-source-r2.eclass3
-rw-r--r--eclass/qt5-build.eclass10
-rw-r--r--eclass/toolchain.eclass11
-rw-r--r--eclass/usr-ldscript.eclass1
12 files changed, 29 insertions, 90 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index bc66db753e81..e4dfb4978a3e 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/cargo.eclass b/eclass/cargo.eclass
index 6f7ffdb626b4..ccbf87aa9a6c 100644
--- a/eclass/cargo.eclass
+++ b/eclass/cargo.eclass
@@ -16,12 +16,11 @@ _CARGO_ECLASS=1
RUST_DEPEND=">=virtual/rust-1.37.0"
case ${EAPI} in
- 6) DEPEND="${RUST_DEPEND}";;
7) BDEPEND="${RUST_DEPEND}";;
*) die "EAPI=${EAPI:-0} is not supported" ;;
esac
-inherit multiprocessing
+inherit multiprocessing toolchain-funcs
EXPORT_FUNCTIONS src_unpack src_compile src_install src_test
@@ -162,6 +161,8 @@ cargo_src_compile() {
export CARGO_HOME="${ECARGO_HOME}"
+ tc-export AR CC
+
cargo build $(usex debug "" --release) "$@" \
|| die "cargo build failed"
}
diff --git a/eclass/cmake-utils.eclass b/eclass/cmake-utils.eclass
index b0225992322c..b08c969707ec 100644
--- a/eclass/cmake-utils.eclass
+++ b/eclass/cmake-utils.eclass
@@ -12,6 +12,7 @@
# @SUPPORTED_EAPIS: 5 6 7
# @BLURB: common ebuild functions for cmake-based packages
# @DESCRIPTION:
+# DEPRECATED: This no longer receives any changes. Everyone must port to cmake.eclass.
# The cmake-utils eclass makes creating ebuilds for cmake-based packages much easier.
# It provides all inherited features (DOCS, HTML_DOCS, PATCHES) along with out-of-source
# builds (default), in-source builds and an implementation of the well-known use_enable
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 254a25fd3a6e..8fa343ae75f7 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -476,6 +476,8 @@ _distutils_verify_use_setuptools() {
expected=rdepend
elif grep -F -q -s '[options.entry_points]' setup.cfg; then
expected=rdepend
+ elif grep -F -q -s '[entry_points]' setup.cfg; then # pbr
+ expected=rdepend
else
expected=bdepend
fi
diff --git a/eclass/go-module.eclass b/eclass/go-module.eclass
index 17d37494f15f..7b66c3e2b1ed 100644
--- a/eclass/go-module.eclass
+++ b/eclass/go-module.eclass
@@ -120,29 +120,6 @@ EXPORT_FUNCTIONS src_unpack pkg_postinst
# This decision does NOT weaken Go module security, as Go will verify the
# go.sum copy of the Hash1 values during building of the package.
-# @ECLASS-VARIABLE: EGO_VENDOR
-# @DESCRIPTION:
-# This variable is deprecated and should no longer be used. Please
-# convert your ebuilds to use EGO_SUM.
-
-# @FUNCTION: go-module_vendor_uris
-# @DESCRIPTION:
-# This function is deprecated.
-go-module_vendor_uris() {
- local hash import line repo x
- for line in "${EGO_VENDOR[@]}"; do
- read -r import hash repo x <<< "${line}"
- if [[ -n ${x} ]]; then
- eerror "Trailing information in EGO_VENDOR in ${P}.ebuild"
- eerror "${line}"
- eerror "Trailing information is: \"${x}\""
- die "Invalid EGO_VENDOR format"
- fi
- : "${repo:=${import}}"
- echo "https://${repo}/archive/${hash}.tar.gz -> ${repo//\//-}-${hash}.tar.gz"
- done
-}
-
# @ECLASS-VARIABLE: _GOMODULE_GOPROXY_BASEURI
# @DESCRIPTION:
# Golang module proxy service to fetch module files from. Note that the module
@@ -261,17 +238,16 @@ go-module_set_globals() {
# @FUNCTION: go-module_src_unpack
# @DESCRIPTION:
-# - If EGO_VENDOR is set, use the deprecated function to unpack the base
-# tarballs and the tarballs indicated in EGO_VENDOR to the correct
-# locations.
-# - Otherwise, if EGO_SUM is set, unpack the base tarball(s) and set up the
+# If EGO_SUM is set, unpack the base tarball(s) and set up the
# local go proxy.
+# - Otherwise, if EGO_VENDOR is set, bail out.
# - Otherwise do a normal unpack.
go-module_src_unpack() {
- if [[ "${#EGO_VENDOR[@]}" -gt 0 ]]; then
- _go-module_src_unpack_vendor
- elif [[ "${#EGO_SUM[@]}" -gt 0 ]]; then
+ if [[ "${#EGO_SUM[@]}" -gt 0 ]]; then
_go-module_src_unpack_gosum
+ elif [[ "${#EGO_VENDOR[@]}" -gt 0 ]]; then
+ eerror "${EBUILD} is using EGO_VENDOR which is no longer supported"
+ die "Please update this ebuild"
else
default
fi
@@ -350,51 +326,6 @@ _go-module_gosum_synthesize_files() {
fi
}
-# @FUNCTION: _go-module_src_unpack_vendor
-# @DESCRIPTION:
-# Extract all archives in ${a} which are not nentioned in ${EGO_VENDOR}
-# to their usual locations then extract all archives mentioned in
-# ${EGO_VENDOR} to ${S}/vendor.
-_go-module_src_unpack_vendor() {
- # shellcheck disable=SC2120
- debug-print-function "${FUNCNAME}" "$@"
- local f hash import line repo tarball vendor_tarballs x
- vendor_tarballs=()
- for line in "${EGO_VENDOR[@]}"; do
- read -r import hash repo x <<< "${line}"
- if [[ -n ${x} ]]; then
- eerror "Trailing information in EGO_VENDOR in ${P}.ebuild"
- eerror "${line}"
- die "Invalid EGO_VENDOR format"
- fi
- : "${repo:=${import}}"
- vendor_tarballs+=("${repo//\//-}-${hash}.tar.gz")
- done
- for f in ${A}; do
- [[ -n ${vendor_tarballs[*]} ]] && has "${f}" "${vendor_tarballs[@]}" &&
- continue
- unpack "${f}"
- done
-
- [[ -z ${vendor_tarballs[*]} ]] && return
- for line in "${EGO_VENDOR[@]}"; do
- read -r import hash repo _ <<< "${line}"
- : "${repo:=${import}}"
- tarball=${repo//\//-}-${hash}.tar.gz
- ebegin "Vendoring ${import} ${tarball}"
- rm -fr "${S}/vendor/${import}" || die
- mkdir -p "${S}/vendor/${import}" || die
- tar -C "${S}/vendor/${import}" -x --strip-components 1 \
- -f "${DISTDIR}/${tarball}" || die
- eend
- done
- # replace GOFLAGS if EGO_VENDOR is being used
- [[ ${#EGO_VENDOR[@]} -gt 0 ]] &&
- GOFLAGS="-v -x -mod=vendor"
- eqawarn "${P}.ebuild: EGO_VENDOR will be removed in the future."
- eqawarn "Please request that the author migrate to EGO_SUM."
-}
-
# @FUNCTION: _go-module_src_unpack_verify_gosum
# @DESCRIPTION:
# Validate the Go modules declared by EGO_SUM are sufficient to cover building
diff --git a/eclass/kernel-2.eclass b/eclass/kernel-2.eclass
index 930bcf22e29e..04edee339306 100644
--- a/eclass/kernel-2.eclass
+++ b/eclass/kernel-2.eclass
@@ -712,6 +712,7 @@ env_setup_xmakeopts() {
elif type -p ${CHOST}-ar > /dev/null ; then
xmakeopts="${xmakeopts} CROSS_COMPILE=${CHOST}-"
fi
+ xmakeopts="${xmakeopts} HOSTCC=$(tc-getBUILD_CC)"
export xmakeopts
}
diff --git a/eclass/meson.eclass b/eclass/meson.eclass
index e79faa1beea3..1590c1f14cf5 100644
--- a/eclass/meson.eclass
+++ b/eclass/meson.eclass
@@ -178,6 +178,7 @@ _meson_create_cross_file() {
cpp = $(_meson_env_array "$(tc-getCXX)")
fortran = $(_meson_env_array "$(tc-getFC)")
llvm-config = '$(tc-getPROG LLVM_CONFIG llvm-config)'
+ nm = $(_meson_env_array "$(tc-getNM)")
objc = $(_meson_env_array "$(tc-getPROG OBJC cc)")
objcpp = $(_meson_env_array "$(tc-getPROG OBJCXX c++)")
pkgconfig = '$(tc-getPKG_CONFIG)'
@@ -228,6 +229,7 @@ _meson_create_native_file() {
cpp = $(_meson_env_array "$(tc-getBUILD_CXX)")
fortran = $(_meson_env_array "$(tc-getBUILD_PROG FC gfortran)")
llvm-config = '$(tc-getBUILD_PROG LLVM_CONFIG llvm-config)'
+ nm = $(_meson_env_array "$(tc-getBUILD_NM)")
objc = $(_meson_env_array "$(tc-getBUILD_PROG OBJC cc)")
objcpp = $(_meson_env_array "$(tc-getBUILD_PROG OBJCXX c++)")
pkgconfig = '$(tc-getBUILD_PKG_CONFIG)'
diff --git a/eclass/nvidia-driver.eclass b/eclass/nvidia-driver.eclass
index 8c108a9c338e..50c5395a686d 100644
--- a/eclass/nvidia-driver.eclass
+++ b/eclass/nvidia-driver.eclass
@@ -13,6 +13,8 @@
inherit readme.gentoo-r1
+DESCRIPTION="NVIDIA Accelerated Graphics Driver"
+HOMEPAGE="https://www.nvidia.com/Download/Find.aspx"
DEPEND="sys-apps/pciutils"
RESTRICT="bindist mirror test"
diff --git a/eclass/php-ext-source-r2.eclass b/eclass/php-ext-source-r2.eclass
index 931297da598d..a3658cce461d 100644
--- a/eclass/php-ext-source-r2.eclass
+++ b/eclass/php-ext-source-r2.eclass
@@ -1,6 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# @DEAD
# @ECLASS: php-ext-source-r2.eclass
# @MAINTAINER:
# Gentoo PHP team <php-bugs@gentoo.org>
diff --git a/eclass/qt5-build.eclass b/eclass/qt5-build.eclass
index cd2e19b0aa6a..8531d1294f40 100644
--- a/eclass/qt5-build.eclass
+++ b/eclass/qt5-build.eclass
@@ -104,11 +104,7 @@ EGIT_REPO_URI=(
# @OUTPUT_VARIABLE
# @DESCRIPTION:
# Build directory for out-of-source builds.
-if ver_test ${PV} -lt 5.14.2; then
- : ${QT5_BUILD_DIR:=${S}} # workaround for bug 497312
-else
- : ${QT5_BUILD_DIR:=${S}_build}
-fi
+: ${QT5_BUILD_DIR:=${S}_build}
IUSE="debug test"
@@ -663,9 +659,7 @@ qt5_base_configure() {
# config to always be used. bug 599636
# ${S}/include does not exist in live sources
local basedir="${S}/"
- if ver_test ${PV} -lt 5.14.2 || [[ ${QT5_BUILD_TYPE} == live ]]; then
- basedir=""
- fi
+ [[ ${QT5_BUILD_TYPE} == live ]] && basedir=""
cp src/corelib/global/qconfig.h "${basedir}"include/QtCore/ || die
popd >/dev/null || die
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index a8fd3e953bc3..1e164957b2b8 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -155,7 +155,13 @@ tc_has_feature() {
}
if [[ ${PN} != "kgcc64" && ${PN} != gcc-* ]] ; then
- IUSE+=" altivec debug +cxx +nptl" TC_FEATURES+=(nptl)
+ # --enable-altivec was dropped before gcc-4. We don't set it.
+ # We drop USE=altivec for newer gccs only to avoid rebuilds
+ # for most stable users. Once gcc-10 is stable we can drop it.
+ if ! tc_version_is_at_least 10; then
+ IUSE+=" altivec"
+ fi
+ IUSE+=" debug +cxx +nptl" TC_FEATURES+=(nptl)
[[ -n ${PIE_VER} ]] && IUSE+=" nopie"
[[ -n ${HTB_VER} ]] && IUSE+=" boundschecking"
[[ -n ${D_VER} ]] && IUSE+=" d"
@@ -1090,9 +1096,6 @@ toolchain_src_configure() {
gcc-multilib-configure
- # ppc altivec support
- in_iuse altivec && confgcc+=( $(use_enable altivec) )
-
# gcc has fixed-point arithmetic support in 4.3 for mips targets that can
# significantly increase compile time by several hours. This will allow
# users to control this feature in the event they need the support.
diff --git a/eclass/usr-ldscript.eclass b/eclass/usr-ldscript.eclass
index 7e406267b644..4ee129bda836 100644
--- a/eclass/usr-ldscript.eclass
+++ b/eclass/usr-ldscript.eclass
@@ -37,6 +37,7 @@ gen_usr_ldscript() {
local lib libdir=$(get_libdir) output_format="" auto=false suffix=$(get_libname)
tc-is-static-only && return
+ use prefix && return
# We only care about stuffing / for the native ABI. #479448
if [[ $(type -t multilib_is_native_abi) == "function" ]] ; then